9.0.1 Discussion


#43

@fc_candido no you are wrong and that is not a fix as anybody who has just installed the file you provided will only have to edit it again on the next update

the correct method to address the issue is to delete the folder, we provide the latest repository in the images.

To anybody who has followed the instructions by @fc_candido please disregard and remove the folder /storage/.kodi/addons/repository.coreelec


#44

I am loving the gpu overclocking feature.
I am going to experiment more and monitor temps, but it definately seems to give a little more ‘umpf’ on low end machines doing not-so-lowend tasks :wink:


#45

Hey there !
I just wanted to mention that in my case CoreElec would not auto-update to 9.0.1 (from 9.0.0).
Mini M8S II 2/16 with CoreElec on SD card.

  1. I had the “auto” set ON.
  2. In tried rebooting (twice) and wait for some time.
  3. I went and switched auto to manual and then again to auto.
  4. I also checked the update channel and the available version when I had it on “manual” but nothing was “available”.

One thing I did not do was to reboot after the 3rd step.
Are there any other steps I should have taken for the auto update to work ?

So this time, I resorted to manual update by placing the update 9.0.1 file into the updates folder and I rebooted. All seems fine now, the update was done. It just seemed strange to me that the auto update was not working. I will test it again with the next version (9.0.2) whenever that comes out and report.


#46

I think the .0.1 autoupdate is offered with some delay.
Just got 9.0.0 on a fresh testbox, so thats the one that is offfered now. I can see how delaying the very latest would help in solving some unforseen stuff before mass release


#47

Auto updates are always disabled for the first 24 hours after any release.

This is so we can pull releases quickly if there is a major problem that we have not picked up during testing before too many people install it.


#48

Thank you for the info :slight_smile:


#49

Thanks worked great

/Henrik


#50

After updating, the Zattoo PVR Client no longer worked.
I have:

  • deleted /storage/.kodi/addons/repository.coreelec
  • cleared the packages folder from all previous versions
    then updated Coreelec once more
    Error message upon attempting to install the Zattoo PVR Client is: the dependency on kodi.binary instance pvr version 5.1

#51

Could you check addons>my addons>pvr clients>yourpvrclient.
If you go to update here where you can select s version, is there a newer version presented?


#52

Yes, I have checked for updates of the PVR program. There is no update available.


#53

Ok, just checking.
In my case i had to trigger this manually.


#54

@netbuild you may have to force a manual update of the addon

These issues should only happen if you still have a repository package that you have not deleted, we have tried to make it so old versions of CoreELEC can install the addons that shipped at the time of release, so each release of CoreELEC has its own addons folder on the server now, that is why it is imperative that you check that you do not have one installed as it will force your installation to use 9.0.0 addons which are now incompatible and that is why you will see that message.


#55

Confirming rm -Rf /storage/.kodi/addons/repository.coreelec does not fix the TVheadend HTSP Client binary incompatibility problem.


#56

@KyleS then you will need a fresh install if none of the steps outlined have worked.

We can only help so much, the rest is up to the user.


#57

Thanks for trying :slight_smile:

Real fix is rm -Rf /storage/.kodi/addons/repository.*; everything works/updates again now. I had a couple other retail repos listed (kodinerds and similar) and I guess they were stale as well.

Is it safe to add this to autostart.sh ? Any idea what the implications are?


#58

No do not add this to autostart!

The problem with what you have just done is that you have now just deleted all of your repositories, so any 3rd party addons that you have installed will no longer update.


#59

shriek! Any idea how we can avoid this for 9.0.2 or the next rls?


#60

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)


#61

@fc_candido:
Please stop spreading this false imformation.
You were already told twice by two CE devs, that this isn’t a proper fix.


#62

@KyleS it shouldn’t be an issue again now that you have deleted the old repository.