9.0.2 Unable to install/update from CoreELEC repo

Was you using a different language?

Yes, portuguese

You should have changed to English as explained previously before deleting the file.

You need to stop Kodi with systemctl stop kodi and change locale.language in guisettings.xml to resource.language.en_gb and then start Kodi with systemctl start kodi

NOTICE to all other users, before deleting Addons27.db please ensure you change language to English GB first!

2 Likes

Tried to change that setting but it was already with language.en_gb. Anyway kodi now didn’t crash, and all my addons are enabled.
Should I delete Addons27.db now to be able to update addons?

As long as you set language to English before hand then yes you can delete it.

Is it safe to set “enabled” directly in the table Addons27.installed?

a short question. Will this break an existing installation? Do I need to manually change this on every updated box?

I use four 905X Boxes in grandmas house, and the only things changed is TVH and german language, and confluence as skin

@tavoc no, updating is fine, the above is only needed if you have issues accessing the CE add-ons repo.

1 Like

Hello, I’m not able to install any IPTV client into my Kodi - running on Coreelec 9.0.2.

“installation failed”

Thanks

Please read this topic.

Safer fix for the above identified issue, kudos to @vpeter for the tip, no need to change language or delete any files.

Paste the following commands into SSH if you have the above issue.

systemctl stop kodi
/usr/bin/sqlite3 /storage/.kodi/userdata/Database/Addons27.db "UPDATE addons SET metadata = REPLACE(metadata,'https://addons.coreelec.org/9.0/','https://addons.coreelec.org/9.1/');"
/usr/bin/sqlite3 /storage/.kodi/userdata/Database/Addons27.db "UPDATE addons SET metadata = REPLACE(metadata,'https://addons.coreelec.org/9.0.1/','https://addons.coreelec.org/9.1/');"
systemctl start kodi
2 Likes

I have the same problem, but changing the language to English and updating the Addons27.db with the above commands haven’t solved my problem.

The Kodi log says this:

2019-06-09 11:22:14.912 T:3602899824   ERROR: CCurlFile::Stat - Failed: HTTP response code said error(22) for https://addons.coreelec.org/9.1/Amlogic/arm/virtual.system-tools/virtual.system
-tools-9.1.111.zip
2019-06-09 11:22:14.913 T:3602899824   DEBUG: CurlFile::Open(0xf34eb8c8) https://addons.coreelec.org/9.1/Amlogic/arm/virtual.system-tools/virtual.system-tools-9.1.111.zip
2019-06-09 11:22:15.018 T:3936514928   ERROR: CCurlFile::Stat - Failed: HTTP response code said error(22) for https://addons.coreelec.org/9.1/Amlogic/arm/service.softcam.oscam/service.softc
am.oscam-9.1.109.zip
2019-06-09 11:22:15.019 T:3936514928   DEBUG: CurlFile::Open(0xdb34b290) https://addons.coreelec.org/9.1/Amlogic/arm/service.softcam.oscam/service.softcam.oscam-9.1.109.zip
2019-06-09 11:22:15.414 T:3602899824   ERROR: CCurlFile::FillBuffer - Failed: HTTP returned error 403
2019-06-09 11:22:15.414 T:3602899824   ERROR: CCurlFile::Open failed with code 403 for https://addons.coreelec.org/9.1/Amlogic/arm/virtual.system-tools/virtual.system-tools-9.1.111.zip:
2019-06-09 11:22:15.415 T:3602899824   ERROR: CAddonInstallJob[virtual.system-tools]: failed to download special://home/addons/packages/virtual.system-tools-9.1.111.zip
2019-06-09 11:22:15.439 T:4091461648   DEBUG: CGUIMediaWindow::GetDirectory (addons://outdated/)
2019-06-09 11:22:15.439 T:4091461648   DEBUG:   ParentPath = [addons://outdated/]
2019-06-09 11:22:15.440 T:3788268400   DEBUG: Thread waiting start, auto delete: false
2019-06-09 11:22:15.507 T:3936514928   ERROR: CCurlFile::FillBuffer - Failed: HTTP returned error 403
2019-06-09 11:22:15.508 T:3936514928   ERROR: CCurlFile::Open failed with code 403 for https://addons.coreelec.org/9.1/Amlogic/arm/service.softcam.oscam/service.softcam.oscam-9.1.109.zip:
2019-06-09 11:22:15.509 T:3936514928   ERROR: CAddonInstallJob[service.softcam.oscam]: failed to download special://home/addons/packages/service.softcam.oscam-9.1.109.zip
2019-06-09 11:22:15.527 T:3788268400   DEBUG: CAddonMgr::GetAvailableUpdates took 87 ms

Finally I downloaded the zip files manually with wget and installed these addons from zip successfully.
But do you have any idea why I got “update failed” message during update addons?

If I delete the Addons27.db file then the configuration of addons (tvheadend and oscam) will remain?

i dont think its your setup, looks like the coreelec repo has a 403 code at the moment.
i dont think it will be offline too long,

Are you trying that from a browser? Pretty sure that will always give a 403.

the 403 is in the log,
i havent had any problems with the repo, just today.
i just commented to help the above off speederer as ive been using the repo fine previous.
i tried off a fresh img, clean setup etc.
i just assumed it was down tempoprary.
can you install from the core repo? i cant at this time,

No, you’re right - I tried a few and they all failed. Usually if a repo’s down you can’t browse the contents though, so this is an odd one.

1 Like

it can happen on rare occasions, did with libre etc, never for long, im sure it will be online soon.
it was just so people didnt think it was their setup.

Maybe I didn’t emphasize that I could download the zip files from the original location (e.g. https://addons.coreelec.org/9.1/Amlogic/arm/virtual.system-tools/virtual.system-tools-9.1.111.zip) with wget at the same time as the addon update dropped an “update failed” message.
Also downloading with curl is working fine at the moment.
So I don’t think it was connection or repository problem.

if I remember correctly I removed the repository.coreelec folder after the 9.0.1 update to solve problems with TVH.

Same situation is here.
Can this cause the current problem?

you still can install and download the zip files, that url etc is fine.
if you did a fresh img youd see the coreelec repo wont open at this moment.
personally id just hold on a bit till repo opens properly, i dont think it will be too long.

should be good now, give it a try,