9.0.3 Discussion

It starts stuttering shortly after the video starts. Also tried stopping, fast-forwarding a bit and then it played the bits that previously stuttered fine, but then starts stuttering again after a few seconds. First I thought it might have been the media, since other files played fine, but it’s definitely the update (the same files play fine on pc, and on 9.0.2)


I have come across situations where after 30 seconds there is a stutter every 2 seconds with some X264 files but I was never able to pinpoint the issue as mediainfo could be the same but playback would differ.

Sometimes a reboot might fix it temporarily.

It never happened with X265 file though.

It is worth trying with a clean install though as it’s possible that addons that work with one release might cause issues with another, so worth eliminating/confirming.

How do you expect us to be able to help you when you don’t even post basic details for us to look into your issue?

Media type? Resolution? Logs?

May as well dig out the magic lantern and give it a rub and hope for the best.

If we have a magic lantern why aren’t we using it in the first place?? :wink:

I’ll update back to .3 somewhere tomorrow and try and reproduce and get you a log. Not expecting anything. Also, thank you, and all the people who are willing to invest their free time to work on this awesome piece of software.

PS, here’s the media info for one of the files which was giving me problems (unsure about which gui res I had setup in Kodi)

Format                                   : Matroska
Format version                           : Version 4
File size                                : 2.39 GiB
Duration                                 : 42 min 25 s
Overall bit rate                         : 8 048 kb/s
Encoded date                             : UTC 2019-05-15 05:08:08
Writing application                      : mkvmerge v24.0.0 ('Beyond The Pale') 64-bit
Writing library                          : libebml v1.3.6 + libmatroska v1.4.9

ID                                       : 1
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : High@L4
Format settings                          : CABAC / 3 Ref Frames
Format settings, CABAC                   : Yes
Format settings, Reference frames        : 3 frames
Codec ID                                 : V_MPEG4/ISO/AVC
Duration                                 : 42 min 25 s
Bit rate mode                            : Constant
Bit rate                                 : 8 000 kb/s
Width                                    : 1 920 pixels
Height                                   : 1 080 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Constant
Frame rate                               : 23.976 (24000/1001) FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Bits/(Pixel*Frame)                       : 0.161
Stream size                              : 2.35 GiB (98%)
Default                                  : Yes
Forced                                   : No

ID                                       : 2
Format                                   : AAC LC
Format/Info                              : Advanced Audio Codec Low Complexity
Codec ID                                 : A_AAC-2
Duration                                 : 42 min 25 s
Bit rate                                 : 126 kb/s
Channel(s)                               : 2 channels
Channel layout                           : L R
Sampling rate                            : 44.1 kHz
Frame rate                               : 43.066 FPS (1024 SPF)
Compression mode                         : Lossy
Delay relative to video                  : -36 ms
Stream size                              : 38.1 MiB (2%)
Language                                 : English
Default                                  : Yes

Have you tried toggling HEVC workaround in Settings>System>CoreELEC?

Did not make a difference, also there aren’t HEVC files I’m playing (unless I’m misinterpreting the mediainfo)

I have 3 devices running Coreelec 9.0.3.
2x s905x
1x s912

I am running a shared SQL library for all 3 devices.

I have a problem in both s905x devices.

After reboot or Kodi restart when I enter the movies section and switch to unwatched all is fine - I get all my unwatched movies as expected.
When I go back to main screen and reenter the movies section the I get ALL my movies under unwatched (not just the unwatched ones).
To solve this I need to reboot the box or restart KODI.

just to clarfiy - the s912 box does not have this problem and they are all using the same database - there is no problem with the database.

Does anyone else have this problem?

Edit: Seems it is a known issue https://forum.kodi.tv/showthread.php?tid=339773

1 Like

It could be just because batteries :face_with_monocle: I restarted box, so there is canary period, if that happens again (ie restart as workaround works), but before restart I tried with just bare OS + irkeytable test without kodi, and new batteries seems to helped.

Worth mentioning for other, as if thats true, then its really surprising, that ALL other buttons works except few of them, which suddenly doesnt send signal 70% of time. Lets see. I really hope that solution would be that simple and confusing :slight_smile:

EDIT: Confirmed: This was caused by slightly drained batteries. False alarm! Apologies, leaving this here just in case someone hit same situation :slight_smile:


I have installed CE 9.0.3 on my N2 but I have strange problems with the recordings from the Teleboy PVR-Addon.

When I start watching a recorded Video the sound and picture switches randomely from one point to another. It skips 2-3 seconds forward and during that time the sound is off and after that everything is out of sync.

I already tested it on a windows (PC) and libreelec (Pi3). I don’t have this issues on that plattforms. So this is not an issue from the PVR-Addon, it must be some bug in coreelec.

Can anyone help to fix it?

Here is my log: https://1drv.ms/u/s!AuvgQKbZ3QKwirxqTGlSgs6Jo0iZ4Q?e=dgUgqe


I solved the problem:

For anyone who will facing the same problem, the solution is the framrate in Coreelec. My TV usualy uses 60Hz but coreelec can not handle it, therefore I set the framrate to 50Hz on TV and Coreelec. Now everything works perfect.

Interesting its working differently on Rpi3, are you EU located? Ususally 60Hz is often used in North America, most europe nativelly use 50Hz for TV signal I think.

Why do you think that? All my boxes have 60p GUI without any problem.

I set my GUI to 50Hz in order to avoid constant refresh rate switching when watching TV.
Watching 25FPS or 50FPS content at 60Hz refresh rate results in constant frame skips/stutters.


Hi… I’ve made some test again with last nightly’s and 9.0.3 on my two C2’s… So i’ve got video playback only on one C2 which is plugged to an avr which is plugged to tv and benq videoprojector… I try to modify audio and video settings to fix… But nothing (i ve no problem with 9.0.1)

Yes, I am located in Germany. I already tested it with Pi3B+ and Libreelc. There were no problems with 60fps. But I bought an N2, therefore I switched to Coreelec. Indeed, I don’t realy need 60fps but it’s weird it doesn’t work with Coreelec. Maybe it’s because it is the first release with N2 support and not all problems were known.

Due to the fact that I have stutters/skips with the N2 when using 60fps

There are no problems with 60p. RPi probably had the option to adjust playback to display turned on.
This doesn’t work well on AML, and it also breaks audio passthrough, so it’s disabled by default and hidden from the GUI.

CE can handle 60p GUI for sure. If you experience stutters or skips then you have to find the reason for that.

Closing due to 9.2.0 release, further discussion here .