9.0.3 Discussion

Thanks @ozolli, good tip, yes, I knew, just wondering about the official release, for the moment when I find a file with this I use my shield TV., seems also that I failed to embed, sorry

@ozolli It was definitely on the C2 or one the RPi’s. But I can’t seem to find it on the official Windows version either, so it must’ve been taken out. The only reason I ask is because UI animation during playback on the N2 is kinda choppy, and I refuse to believe that it’s due to lack of power :smile:

It’s likely that movies playing at 24 fps will cause the UI to stutter, because it’s pretty slow for a responsive UI. I don’t think amlogic builds ever had that option. It would make sense to have it on rpi.

I have installed a clean 9.0.3 os on my n2 emmc in the hopes that an issue I had reported with an earlier nightly be resolved.

** I was told at the time to wait for a pvr update to be pushed into the next nightly, if I remember correctly this was about a week prior to the first official release 9.0.3 for the n2 **

My issue was and still lies with system hangs/crashes/restart shortly after. (Logs are reset) This occurs seemingly at random however it occurs often while navigating my pvr as well as after exiting plex addon.

I would like to be able to see my crash log, however I am consistently notified that no such crash log exists when opening kodi log uploader. Usually the previous kodi log does not show indication of any major issue immediately prior to the crashes.

Any help would be greatly appreciated! (Especially with accessing crash logs, if possible)

Thanks in advance!

The COREELEC team is nothing short of amazing :slight_smile:

I’ll second that. My wife insisted we get a Netflix sub so yesterday I loaded the add-on (https://forum.kodi.tv/showthread.php?tid=329767) to my N2 running 9.0.3 and it’s working great, that is amazing to me.

Can this release working on ancient S805 SoC boxes? if NOT can I compile to support S805 by myself?

There is no support for S805 in our repository, you would have to add support yourself.

No and unlikely that you will be able to compile it since those devices didn’t use dtb’s.

Shoog

Hi… What is the path/name of the log file and procedure for post my probkrms with C2 ?

Regards,

There you go:

Or the hard way:
SSH to your box then enter this command:
paste /storage/.kodi/temp/kodi.log
Then give the link here.

After upgrade from 9.0.2 HDMI CEC (Bravia Sync) stopped working auto-switching of HDMI ports on my Sony TV.
Interesting is that all my devices stopped auto-switching not just my CE tvbox.
Maybe because TVbox is connected to HDMI3/ARC port usually used by AVRs.
HDMI CEC settings are the same as before on older 9.0.x versions.
No other issues with the 9.0.3 version but this one is inconvenient :frowning:

I can’t access to the guide. Is a log level to define ? When videos problems occurs, there’s nothing new in log.
Edit : i found in parameters that i could enable pluging debug log… So i will make test
Regards,

Confirmed. I did a test with 50 fps file, and there was no stutter.

I installed 9.0.3 but it often happens that when stopped a video in streaming CE stops for several minutes. The solution is to stick to or disconnect the power supply because CE does not respond. I put 9.0.2 back on to see if the problem is solved. He has never seen such problems before.

The second problem is with the subtitles that are not displayed immediately, sometimes you see one after several minutes. Synchronization appears to be maintained.

I suggest you try a clean install on a separate SD card and test. This doesn’t sound like CE issues, but more like Kodi configuration issues, or something with addons.

Hi… A sample of error on my C2 (work on 9.0.1)

2019-07-16 21:11:43.015 T:3369071472 NOTICE: Creating InputStream
2019-07-16 21:11:43.161 T:3369071472 NOTICE: Creating Demuxer
2019-07-16 21:11:43.261 T:3369071472 NOTICE: Opening stream: 0 source: 256
2019-07-16 21:11:43.261 T:3369071472 NOTICE: CVideoPlayerVideo::OpenStream - Creating codec: 27
2019-07-16 21:11:43.264 T:3369071472 NOTICE: Creating video thread
2019-07-16 21:11:43.264 T:3510104944 NOTICE: running thread: video_thread
2019-07-16 21:11:43.265 T:3369071472 NOTICE: Opening stream: 1 source: 256
2019-07-16 21:11:43.265 T:3369071472 NOTICE: Finding audio codec for: 86019
2019-07-16 21:11:43.265 T:3369071472 NOTICE: Creating audio thread
2019-07-16 21:11:43.265 T:3385848688 NOTICE: running thread: CVideoPlayerAudio::Process()
2019-07-16 21:11:43.276 T:3385848688 NOTICE: Creating audio stream (codec id: 86019, channels: 2, sample rate: 48000, pass-through)
2019-07-16 21:11:43.282 T:3510104944 NOTICE: CAMLCodec::OpenDecoder - using V4L2 pts format: 64Bit
2019-07-16 21:11:43.481 T:4086136848 NOTICE: Whitelist search for: width: 1280, height: 720, fps: 25.000, 3D: false
2019-07-16 21:11:43.483 T:4086136848 NOTICE: Display resolution ADJUST : 1920x1080 @ 50.00 - Full Screen (29) (weight: 0.000)
2019-07-16 21:11:43.886 T:4086136848 NOTICE: VideoPlayer: OnLostDisplay received
2019-07-16 21:11:44.108 T:4086136848 NOTICE: VideoPlayer: OnResetDisplay received
2019-07-16 21:11:47.908 T:3510104944 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
2019-07-16 21:43:08.055 T:3369071472 WARNING: Previous line repeats 1073 times.
2019-07-16 21:43:08.055 T:3369071472 ERROR: Read - Error( -1, 103, Software caused connection abort )
2019-07-16 21:43:15.975 T:3369071472 ERROR: Previous line repeats 2 times.
2019-07-16 21:43:15.975 T:3369071472 NOTICE: CVideoPlayer::OnExit()
2019-07-16 21:43:15.976 T:3369071472 NOTICE: VideoPlayer: eof, waiting for queues to empty
2019-07-16 21:43:15.977 T:3369071472 NOTICE: Closing stream player 1
2019-07-16 21:43:15.977 T:3369071472 NOTICE: CDVDMessageQueue(audio)::WaitUntilEmpty
2019-07-16 21:43:16.060 T:3369071472 NOTICE: Waiting for audio thread to exit
2019-07-16 21:43:16.060 T:3385848688 ERROR: Got MSGQ_ABORT or MSGO_IS_ERROR return true
2019-07-16 21:43:16.060 T:3385848688 NOTICE: thread end: CVideoPlayerAudio::OnExit()
2019-07-16 21:43:16.061 T:3369071472 NOTICE: Closing audio device
2019-07-16 21:43:16.231 T:3369071472 NOTICE: Deleting audio codec
2019-07-16 21:43:16.232 T:3369071472 NOTICE: Closing stream player 2
2019-07-16 21:43:16.232 T:3369071472 NOTICE: CDVDMessageQueue(video)::WaitUntilEmpty
2019-07-16 21:43:16.458 T:3369071472 NOTICE: waiting for video thread to exit
2019-07-16 21:43:16.458 T:3510104944 ERROR: Got MSGQ_ABORT or MSGO_IS_ERROR return true
2019-07-16 21:43:16.458 T:3510104944 NOTICE: thread end: video_thread
2019-07-16 21:43:16.458 T:3369071472 NOTICE: deleting video codec
2019-07-16 21:43:17.658 T:4086136848 NOTICE: CVideoPlayer::CloseFile()
2019-07-16 21:43:17.658 T:4086136848 NOTICE: VideoPlayer: waiting for threads to exit
2019-07-16 21:43:17.658 T:4086136848 NOTICE: VideoPlayer: finished waiting
2019-07-16 21:43:17.658 T:4086136848 NOTICE: CVideoPlayer::CloseFile()
2019-07-16 21:43:17.658 T:4086136848 NOTICE: VideoPlayer: waiting for threads to exit
2019-07-16 21:43:17.658 T:4086136848 NOTICE: VideoPlayer: finished waiting

I get this error as well on both 9.0.2 and 9.0.3. My logs look very similar to yours as well. I have gone back to 9.0.1 and everything works without issue. I would often get the video stopping after only a few seconds, up to 5 minutes into the video.

I tried the previous version and seem to work well. But the issue is present also with the a local streaming through a nas in a lan. It happen this: When stop the file, CE freeze for several minutes. If i wait,usually it unblock automatically but not alwayt. I have few plugins installed only. There are some log file that store this event?

The reference file is .kodi/temp/kodi.log …but if kodi freeze and restart, the file is cleared…