9.0.3 Discussion

It should be renamed to kodi.old.log (same location) on startup.

Any way to rollback to previous versions? 9.0.3 seems to have begun giving me problems watching movies from my hard drive.

But before you downgrade, try resetting your audio and video settings.

I even did a hard reset. It still freezes up on certain files that somehow work on other firmware. Weird. My libreelec 8.x box plays them ok… it’s just really strange.

Was there any changes within lirc, meson-ir, keymaps, remote

I think since 9.0.3 I having problem with RETURN and Play occasionally. It seems to appears randomly, one time it works, and after 3sec it doesnt react. Just these two buttons, arrows etc. works fine. After while, buttons get back, but when pressing on and off one of these buttons repeatelly, they stopped working again (other buttons works). I didnt experience this before (using that remote since before 9.0.1 I guess). CEC is disabled in both TV and CE. Happened, when video is played (or stopped, i actually hit this with using the play/pause button). I tried to trigger this also on other buttons, by pressing it again and again, but they works as they should. On the contrary, the play button seems to triggers this after 4-5 consequently press.

In the general debug log theres no info particullary, working keys continuous to showing as keypress, but BACK and PLAY doesnt generate anything in time being non-functional.

2019-07-30 21:27:40.591 T:4014990192   DEBUG: LIRC: - NEW 67 0 KEY_UP devinput (KEY_UP)
2019-07-30 21:27:40.602 T:4092592928   DEBUG: HandleKey: 166 (0xa6, obc89) pressed, action is Up
2019-07-30 21:27:11.190 T:4014990192   DEBUG: LIRC: - NEW 166 0 KEY_INFO devinput (KEY_INFO)
2019-07-30 21:27:11.200 T:4092592928   DEBUG: HandleKey: launch_media_center (0xc3) pressed, action is Info
2019-07-30 21:27:16.186 T:4014990192   DEBUG: LIRC: - NEW 2 0 KEY_1 devinput (KEY_1)
2019-07-30 21:27:16.200 T:4092592928   DEBUG: HandleKey: 206 (0xce, obc49) pressed, action is Number1

I am using this old remote,

meson-ir * TV_Tuner_PC-43


# table TV_Tuner_PC-43, type: rc5
#0x821 KEY_                # Power
0x811 KEY_GREEN            # TV/DVR - Profil TV
0x831 KEY_YELLOW           # Radio - Profil Projektor
#0x809 KEY_                # Close
#0x829 KEY_                # Music
#0x819 KEY_                # Pictures
#0x839 KEY_                # Video
0x805 KEY_BLUE             # DVD/Menu - Najit titulky
0x80b KEY_TV               # Print
0x80d KEY_INFO             # Fullscreen - Informace o filmu
0x818 KEY_LEFT             # Left
0x810 KEY_RIGHT            # Right
0x808 KEY_UP               # Up
0x804 KEY_DOWN             # Down
0x822 KEY_OK               # OK
0x80f KEY_EXIT             # Back
0x813 KEY_MENU             # Check OK - Kontextove menu
#0x825 KEY_                # Previous
0x815 KEY_PLAY             # Play/pause
#0x835 KEY_                # Next
0x826 KEY_REWIND               # Rew - Posun audia -
0x812 KEY_STOP             # Stop
0x824 KEY_FORWARD               # Fwd - Posun audia +
0x816 KEY_NEXT               # Vol + - Posun titulku +
0x836 KEY_PREVIOUS               # Vol - - Posun titulku -
0x832 KEY_POWER            # Home - Uvodni obrazovka
0x814 KEY_PAGEUP           # Ch +
0x834 KEY_PAGEDOWN           # Ch -
0x80e KEY_RED              # Mute - Audio profiles
#0x80a KEY_                # Rec
0x80c KEY_DELETE           # Recall - Obnoveni sezname / Delete
0x82e KEY_1                # 1
0x82a KEY_2                # 2
0x82c KEY_3                # 3
0x81e KEY_4                # 4
0x81a KEY_5                # 5
0x81c KEY_6                # 6
0x83e KEY_7                # 7
0x83a KEY_8                # 8
0x83c KEY_9                # 9
0x806 KEY_0                # 0
#0x801 KEY_                # Shuffle
#0x802 KEY_                # Repeat


	<green>LoadProfile(Master user)</green>

Hi : my log is sufficient for open an issue ? As a reminder, this video problem occurs on 9.0.2 and 9.0.3 with odroid C2 S905 after some days. Result are video artefacts before video playback stop (cifs) or sometimes kodi reboot with htsp client.


I’m running into some trouble with 9.0.3 running on a Tanix T92 (S912)

I’ve had videos completely lock up the tvbox, to the point where I have to unplug the power to reboot.
On other videos I’m experiencing freezing frames / stutter, I’ve retried the same file multiple times. After this I reverted back to 9.0.2 and the same file plays fine again, also haven’t had any crashes so far (and almost never had them before upgrading, but with 9.0.3 have become frequent).


In terms of the stuttering.

Does it happen after playing about 30 seconds of the video?

I have noticed the stuttering issue with the same Tanix T92 box and reverted back to 9.0.2 and do not have any issues. It seemed to be an issue with most content, although I did have some 4k x265 HVEC uncompressed content that seemed to play without issues.

I would have to double check but I believe I noticed the issue even sooner then 30 seconds.

It starts stuttering shortly after the video starts. Also tried stopping, fast-forwarding a bit and then it played the bits that previously stuttered fine, but then starts stuttering again after a few seconds. First I thought it might have been the media, since other files played fine, but it’s definitely the update (the same files play fine on pc, and on 9.0.2)


I have come across situations where after 30 seconds there is a stutter every 2 seconds with some X264 files but I was never able to pinpoint the issue as mediainfo could be the same but playback would differ.

Sometimes a reboot might fix it temporarily.

It never happened with X265 file though.

It is worth trying with a clean install though as it’s possible that addons that work with one release might cause issues with another, so worth eliminating/confirming.

How do you expect us to be able to help you when you don’t even post basic details for us to look into your issue?

Media type? Resolution? Logs?

May as well dig out the magic lantern and give it a rub and hope for the best.

If we have a magic lantern why aren’t we using it in the first place?? :wink:

I’ll update back to .3 somewhere tomorrow and try and reproduce and get you a log. Not expecting anything. Also, thank you, and all the people who are willing to invest their free time to work on this awesome piece of software.

PS, here’s the media info for one of the files which was giving me problems (unsure about which gui res I had setup in Kodi)

Format                                   : Matroska
Format version                           : Version 4
File size                                : 2.39 GiB
Duration                                 : 42 min 25 s
Overall bit rate                         : 8 048 kb/s
Encoded date                             : UTC 2019-05-15 05:08:08
Writing application                      : mkvmerge v24.0.0 ('Beyond The Pale') 64-bit
Writing library                          : libebml v1.3.6 + libmatroska v1.4.9

ID                                       : 1
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : High@L4
Format settings                          : CABAC / 3 Ref Frames
Format settings, CABAC                   : Yes
Format settings, Reference frames        : 3 frames
Codec ID                                 : V_MPEG4/ISO/AVC
Duration                                 : 42 min 25 s
Bit rate mode                            : Constant
Bit rate                                 : 8 000 kb/s
Width                                    : 1 920 pixels
Height                                   : 1 080 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Constant
Frame rate                               : 23.976 (24000/1001) FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Bits/(Pixel*Frame)                       : 0.161
Stream size                              : 2.35 GiB (98%)
Default                                  : Yes
Forced                                   : No

ID                                       : 2
Format                                   : AAC LC
Format/Info                              : Advanced Audio Codec Low Complexity
Codec ID                                 : A_AAC-2
Duration                                 : 42 min 25 s
Bit rate                                 : 126 kb/s
Channel(s)                               : 2 channels
Channel layout                           : L R
Sampling rate                            : 44.1 kHz
Frame rate                               : 43.066 FPS (1024 SPF)
Compression mode                         : Lossy
Delay relative to video                  : -36 ms
Stream size                              : 38.1 MiB (2%)
Language                                 : English
Default                                  : Yes

Have you tried toggling HEVC workaround in Settings>System>CoreELEC?

Did not make a difference, also there aren’t HEVC files I’m playing (unless I’m misinterpreting the mediainfo)

I have 3 devices running Coreelec 9.0.3.
2x s905x
1x s912

I am running a shared SQL library for all 3 devices.

I have a problem in both s905x devices.

After reboot or Kodi restart when I enter the movies section and switch to unwatched all is fine - I get all my unwatched movies as expected.
When I go back to main screen and reenter the movies section the I get ALL my movies under unwatched (not just the unwatched ones).
To solve this I need to reboot the box or restart KODI.

just to clarfiy - the s912 box does not have this problem and they are all using the same database - there is no problem with the database.

Does anyone else have this problem?

Edit: Seems it is a known issue https://forum.kodi.tv/showthread.php?tid=339773

1 Like

It could be just because batteries :face_with_monocle: I restarted box, so there is canary period, if that happens again (ie restart as workaround works), but before restart I tried with just bare OS + irkeytable test without kodi, and new batteries seems to helped.

Worth mentioning for other, as if thats true, then its really surprising, that ALL other buttons works except few of them, which suddenly doesnt send signal 70% of time. Lets see. I really hope that solution would be that simple and confusing :slight_smile:

EDIT: Confirmed: This was caused by slightly drained batteries. False alarm! Apologies, leaving this here just in case someone hit same situation :slight_smile:


I have installed CE 9.0.3 on my N2 but I have strange problems with the recordings from the Teleboy PVR-Addon.

When I start watching a recorded Video the sound and picture switches randomely from one point to another. It skips 2-3 seconds forward and during that time the sound is off and after that everything is out of sync.

I already tested it on a windows (PC) and libreelec (Pi3). I don’t have this issues on that plattforms. So this is not an issue from the PVR-Addon, it must be some bug in coreelec.

Can anyone help to fix it?

Here is my log: https://1drv.ms/u/s!AuvgQKbZ3QKwirxqTGlSgs6Jo0iZ4Q?e=dgUgqe


I solved the problem:

For anyone who will facing the same problem, the solution is the framrate in Coreelec. My TV usualy uses 60Hz but coreelec can not handle it, therefore I set the framrate to 50Hz on TV and Coreelec. Now everything works perfect.

Interesting its working differently on Rpi3, are you EU located? Ususally 60Hz is often used in North America, most europe nativelly use 50Hz for TV signal I think.