9.2.0 Discussion

That’s done it, thanks.

1 Like

Couldnt find anything related to vnc in earlier posts.

Edit: [SOLVED] found that there is a different addon (Amlogic VNC instead of aml-vnc) which is more uptodate

Lot of post about addon problems with solution, like this:

Currently my LG TV is turned on by magic hand. In addition, I can no longer use the TV remote control to control Kodi. I uploaded the logs.

In my case the problem is dvb driver.
After many tries the only one working is “LibreELEC Module Drivers”.
Crazycat (DVB drivers fot TBS) and “DVB drivers from the latest kernel” make tvheadend fails. When the dvb adapter is visible in tvheadend config and try to play a tv channel, tvheadend doesn’t respon anymore. HTSP client complaints something is wrong.

No clear trace of error in log. Only these:

2019-09-17 18:17:59.411 T:4089636688 NOTICE: PVR Manager: Stopping
2019-09-17 18:17:59.976 T:3545658240 ERROR: AddOnLog: Tvheadend HTSP Client: pvr.hts - Command hello failed: No response received
2019-09-17 18:17:59.977 T:3545658240 ERROR: AddOnLog: Tvheadend HTSP Client: pvr.hts - failed to send hello
2019-09-17 18:17:59.991 T:4089636688 NOTICE: PVR Manager: Stopped

Before 9.2.0 I always was using crazycat without problems.

And restore doesn’t work either… I tried to restore a backup made before upgrade to 9.2.0. It seems to work, on screen I see the file decompression and after that, the message to reboot. It reboots, but to 9.2.0, without any message about restoring nothing in boot screens.
In /storage/.restore reside the correct .tar file, but nothing happends on reboots.

Best regards.

I updated the dvb-drivers when tvheadend did not work I updated the server and the dvb drivers. I can’t remember which drivers I am using but it was in My-Addons.

1 Like

I disabled my add-ons (Youtube, OpenVPN , TV Headend Client and server) before updating but could not get TVheadend to work after enabling them, after the update. I tried to get the add-ons to update but they appear to be the latest. In any case the update fails.

For those who have got it to work, what versions of the client and server are you running? My client version is and the server version is 9.1.118.

I keep getting the message PVR manager is starting up when I try to use it

Yeah this update was a mess and a headache. Even the backup that I made before I updated refused to install after the update. TVHeadend and the Plex server add-on just didn’t work.

I spent all day yesterday and did a clean install. I’ve been trying to get everything back to how it was before the update. TVHeadend is working now I just need the Plex server add-on from @tnds82. It seems like his server is down. So it’s a waiting game now.

I finally had to uninstall tvheadend client and server, delete add-on database and re-installed tvheadend client and server to get the latest updated version of these add-ons. For information, the latest tvheadend client is and the server is version 9.2.120

I am finding that most times I upgrade Coreelec, I have to delete the add-on database in order for proper updates to the add-ons to occur

Maybe I did not have to uninstall the client and server before deleting the add-on database (must remind myself to try that next time)

Did you tried save and recover at least channel settings? I can image that headache when I should scan/order/tag/setup all channels there manually again :woozy_face:

Hi solfeio. Do you know that you can run Plex media server through docker? It works very well and you get updates automatically. I used to use @tnds82’s add-on but found it a pain to update to the latest versions of PMS.

Yes I do. I tried it yesterday out of desperation but it was slowing the whole system down. I would ssh into CoreELEC and monitor the system via top and noticed high cpu usage by the Plex server. Needless to say I uninstalled it.

Thanks for the suggestion though.

I had a similar issue when I upgraded a nightlie about a month ago. In the end I did a full reinstall. Its down to a major Kodi branch change which breaks quite a few addons. I saved myself the hassle of having to resetup all of the TVH settings by moving the TVH userdata into a backup and then restoring just that data, brough all of my TVH back on the newer version that was pulled in.

The best approach seems to be to upgrade CE, remove your addons database. Re-enable each addon testing if it will boot after each one.


Do you know when (if?) auto update will be available ?
Is there any critical issues reported ?

I’ve upgraded two S905X boxes (an X96 and an X4) from 9.0.3 to 9.2.0 without problems.

I followed the instructions at the beginning of this thread: disable addons (including TVH server and client) > upgrade to CE 9.2.0 > refresh repos > update addons > enable addons.

Many thanks to the developers for their continued support of generic S905X boxes.

1 Like

k3 pro user here.after upgrading to 9.2.0 from 9.0.3 tvheadend 4.3 stopped working for me.i used to use crazycat drivers without problems but i cannot anymore.i can connect with tvheadend 4.2 from the official repo but then i cant transfer my channel list from 4.3 to 4.2.anyone can help me?

Did a fresh install on my Mecool KM9 PRO. All works great (ethernet, wifi, …) but bluetooth is not working anymore. It was working on one of the nightlies of the end of august.
Plugged in a cheap usb bluetooth dongle from AliExpress and all is working fine. Is some driver or setting missing for the internal chip? Thanks!

Try to download the tar file again and update your CE with it.

go into coreelec settings and select manual update, selec coreelec 9-0 and then the 9.2 release, after download is complete the box will restart itself and update.
I just did and it worked flawless - I didnt disable any addons either.

just emby and simpleIPTV installed :slight_smile:

1 Like

Thanks, I know the manual update.
But I want to see how the auto process is running once in my life :wink:
That’s why I can’t wait for it to be available !