9.2.0 Discussion

I have one beelink gt1 (s912) and two beelink mini mxiii (s905x) devices that I upgraded from 9.0.3.

All 3 have vnc add on installed and worked on 9.0.3. NOW on 9.2.0 I can only connect to the s912…

Any suggestions? Does anyone else have this problem.
I checked setting and they have not changed. I can connect to all three from smb. Just VNC seems to be the issue.

I use the aml vnc addons

[SOLVED] Updated to a maintained VLC addons.

I had the same thing go into addons and update the TVHeadend Server to the latest version. My Meelo UNO server is headless so I had to use my trusty 5M HDMI to connect to the TV. Also I updraded the TVHEADEND Client on my other boxes I don’t know if this is required I did it automatically to make sure everything was the latest.

1 Like

@theone Please read back a few post back in this topic.

No matter what I do, it always boot to safe mode after update. I was forced to put sdcard to my pc and manually delete all binary addons, then it booted. Need to install them again.

Really, no migration/any warning? Please put warning in announcement. I thought stable updates are always safe to install, well I was it could brick device

Is this likely to be resolved or is it something further up the chain ie a change to curl or Kodi Itself? I can just rename my media files using a script like this.

find /search/path -depth -name '*&*' \
    -execdir bash -c 'mv -- "$1" "${1//&/and}"' bash {} \;

Beelink mini mxiii (S905)
Bluetooth adapter was recognised on 9.0.3.
Adapter is not found on 9.2.0.
It was working in July nighlies (2019.07.06)
Tested latest nightly (2019.09.15) - adapter not found.

If anyone’s interested in looking at this I’m happy to work through nightlies to find where the change happened, also to upload any logs if someone details what’s required.

I guess that’s because of kernel upgrade and some drivers stopped working

1 Like

Could be the same as this:-

I think @anon88919003 has already fixed it for next nightly.

1 Like

Download 9.2.0 tar again and update your box.

After upgrading COREELEC to 9.2.0 I’ve got a problem with the Syncthing-addon on my Odroid C2, which I used for a long time. When activated, it hinders a restart of CoreELEC exactly 90s. After deactivating, everything is fine.
There are no hints in die kodi log, because logging stopped before.
Any ideas?

That’s done it, thanks.

1 Like

Couldnt find anything related to vnc in earlier posts.

Edit: [SOLVED] found that there is a different addon (Amlogic VNC instead of aml-vnc) which is more uptodate

Lot of post about addon problems with solution, like this:

Currently my LG TV is turned on by magic hand. In addition, I can no longer use the TV remote control to control Kodi. I uploaded the logs.

In my case the problem is dvb driver.
After many tries the only one working is “LibreELEC Module Drivers”.
Crazycat (DVB drivers fot TBS) and “DVB drivers from the latest kernel” make tvheadend fails. When the dvb adapter is visible in tvheadend config and try to play a tv channel, tvheadend doesn’t respon anymore. HTSP client complaints something is wrong.

No clear trace of error in log. Only these:

2019-09-17 18:17:59.411 T:4089636688 NOTICE: PVR Manager: Stopping
2019-09-17 18:17:59.976 T:3545658240 ERROR: AddOnLog: Tvheadend HTSP Client: pvr.hts - Command hello failed: No response received
2019-09-17 18:17:59.977 T:3545658240 ERROR: AddOnLog: Tvheadend HTSP Client: pvr.hts - failed to send hello
2019-09-17 18:17:59.991 T:4089636688 NOTICE: PVR Manager: Stopped

Before 9.2.0 I always was using crazycat without problems.

And restore doesn’t work either… I tried to restore a backup made before upgrade to 9.2.0. It seems to work, on screen I see the file decompression and after that, the message to reboot. It reboots, but to 9.2.0, without any message about restoring nothing in boot screens.
In /storage/.restore reside the correct .tar file, but nothing happends on reboots.

Best regards.

I updated the dvb-drivers when tvheadend did not work I updated the server and the dvb drivers. I can’t remember which drivers I am using but it was in My-Addons.

1 Like

I disabled my add-ons (Youtube, OpenVPN , TV Headend Client and server) before updating but could not get TVheadend to work after enabling them, after the update. I tried to get the add-ons to update but they appear to be the latest. In any case the update fails.

For those who have got it to work, what versions of the client and server are you running? My client version is and the server version is 9.1.118.

I keep getting the message PVR manager is starting up when I try to use it

Yeah this update was a mess and a headache. Even the backup that I made before I updated refused to install after the update. TVHeadend and the Plex server add-on just didn’t work.

I spent all day yesterday and did a clean install. I’ve been trying to get everything back to how it was before the update. TVHeadend is working now I just need the Plex server add-on from @tnds82. It seems like his server is down. So it’s a waiting game now.

I finally had to uninstall tvheadend client and server, delete add-on database and re-installed tvheadend client and server to get the latest updated version of these add-ons. For information, the latest tvheadend client is and the server is version 9.2.120

I am finding that most times I upgrade Coreelec, I have to delete the add-on database in order for proper updates to the add-ons to occur

Maybe I did not have to uninstall the client and server before deleting the add-on database (must remind myself to try that next time)

Did you tried save and recover at least channel settings? I can image that headache when I should scan/order/tag/setup all channels there manually again :woozy_face: