9.2.1 Discussion

I updated my Odroid N2 to stable 9.2.1 yesterday and now wake on lan stopped working. I can neither wake up the device in suspend, nore after shutdown.

Is this a known bug and is there anything I can do to fix it?

EDIT: I just confirmed that its the update that is causing the issue. Rolled back to 9.2.0 and wakeonlan works again, applied 9.2.1 once more -> wol stops working.

Will stay on 9.2.0 until the issue gets fixed, but now kodi constantly nags that there is an update available, even though I have disabled the update notification. How can I disable the popup?

I had the same thing on an A95X upgrade. Could not mount /dev/SYSTEM. I managed to fox it relatively easily. I installed 9.2.1 to another card. I checked the installation worked then copied all the files from the DOS directory of the working card to the none working card. Then the original card booted I got a message saying the upgrade was not successful but id did boot into 9.2.1

Last night message popped up about latest update & Kodi 18.5, so updated & appeared to run smoothly. At first everything was fine & then for no apparent reason mouse buttons would not do anything. Cursor still moved about on screen but could not select anything or close out from Kodi. Tried reboot etc but no joy. Using 2.4Ghz dongle etc & never had any issues before. Thinking of rolling back to previous build, any thoughts?

I have a N2 and have a question on the 4K GUI.

Previously it was recommended that the GUI was run in 1080, from memory because the HDR color bit depth change only worked along with a resolution change.

Has the advice changed now?

have someone else noticed when watching a movie and pausing more than 10 seconds then playing again, the picture is freezing for couple of seconds but the sound continues, any fix for It? Odroid N2.

1 Like

@dazbon Could be related to this: Nightly builds

@steve No it has not changed, but with -NG this is no longer important, as color depth is always maxed out, depending on display capabilities.
In 9.2.1 with default settings, there’s no benefit to running GUI at 4K because it’s rendered at 1080P and upscaled to 4K.

I Noticed the same in s905x2 Chinese box, i’ll wait any fix for it.

Hi, after update my Beelink gt1 mini s905x2 4gb from 9.2.0 to 9.2.1 all black color is blue. Next i was try clean install and is same. What can I do with this? Thank you.

@Jery modify config.ini and add use_rgb_to_yuv=0 at the bottom and reboot.

N2 - 9.2.1 disrupt CEC on my system.
Sony w800c – denon x1400 – N2, Shield, FTV Stick

Rolled back to 9.2.0

Same here Beelink MiniMXIII. How can I revert to 9.2.0?

Hi, I have this line in system.ini and tryed 0 and 1. Both are blue.

Use notepad++ to open the file.

Running N2 on 9.2.0 working perfectly for the last few months but upgraded AVR today from STR-DN1060 to 1080 to get HDR passthrough. Tested the Chess 4k HDR stream and everything was fine and now being decoded beautifully. While testing though, 9.2.1 popped up so I upgraded. Uh oh. Scaling turned to custard.

4k videos now play 4 x normal size (GUI set to 1080P) and when stopping the video, GUI is now 4 x larger even though settings still say 1080. If I switch resolution to anything and say No, GUI comes back to 1080P and fits properly.

Rolled back to 9.2.0, but same deal so saw thread above and changed <scalingmethod>0</scalingmethod>. Chess 4K HDR plays fine again now but Elysium trailer plays 1/4 screen and when stopping that trailer, GUI is now 1/4 screen too.

Is there something I can change just to go back to how it was or a nightly with a fix for that?

I had this and I had to just choose each resolution and then recalibrate the screen to make the corner markers correct, if that makes sense.

Thanks. I tried that on 9.2.1 but it was still all over the place. Are you on 9.2 or 9.2.1?

You need to uncomment the line that you changed. Remove the # infront of use_rgb_to_yuv=0

Thanks @allanp81. Under 9.2.0 with <scalingmethod>0</scalingmethod>, I just resized the one trailer; Elysium 4096 x 1716 and they all came right! Whew. Wife happy again. Thought I was going to be walking with a limp there for a while. :stuck_out_tongue:

In theory just set one resolution correctly and then replicate this on the other resolutions under guisettings.xml.