9.2.3 Discussion

Are there any changes with connman version?

Note from the 9.2.2.

I plunged into the deep end and updated manually. DRM content works in SkyGo. AmazonVOD prompts a HTTP error. You have to re-enter your credentials, then it works.

I wondered the same and went searching for it and it would have to be something that would have to be built from current source.

Then I realised that the reference was very likely to be the HTSP client version rather than the service.

No confusion on my side… I just wanted to inform you before this tarball might become distributed via the auto-update :slight_smile:

Btw: I really appreciate your work, I never had something running so smoothly out-of-the-box as the N2 with CoreElec!

1 Like

Still not work driver RTL8153B, for new adapters USB GIGABIT LAN… ;/ Why not update ? ;/

This broke my vim3l. Manually updated and now it won’t boot reporting an error in mount_flash. Any ideas?

I’m guessing that partition names have changed?

Did you have vim3l delivered with CE pre installed?
If yes recover your device by Khadas Android image and USB Burning tool and perform a new CE install by ceemmc.

Thanks for the reply. I feared as much that I would have to fresh install.

Any ideas what has caused this? Is there no other fix?

P. S. Thanks for all of the hard work!

Because the pre installed image was a hack and is not compatible anymore. It’s a fault on CE side, the image should be never delivered. Sorry for this.

Good point. I ment 4.3 which is bundled.
Just waiting eagerly on the thumbnail feature.
Hope it will come to CE.

Good to know.

Mine was pre installed with android and I manually flashed to coreelec from the official repo (9.2.2.).

Will automatic updates ever be available on vim3l?

From where you got the image? Or did you use the ceemmc tool? Khadas do have a big mess up with different images.

I used an image of 9.2.2 from dl.khadas.com and used their emmc flashing tool (forget the name).

Worked flawlessly since install. Tried to update today and suspect that it’s renamed the partitions as it’s not vim3l compatible.

It should be solved quickly. The partition naming is different on Khadas CE image, that is why it’s not booting anymore after update. We are working on a hotfix & re-tag of 9.2.3.

Great, thanks for confirming.

Just for clarification, I need to reinstall? Or is it possible to edit partition names via ssh?

Had exactly the same issue.
Did not need to bring back to stock android. I created an SD card with 9.2.3, booted then just ran the CEEMMC tool.
Installed again without issue then reinstalled all my add ons.
All running fine now without issue.

9.2.3 got fixed but it’s not uploaded yet. It will be available in next few hours. So for VIM3L users, please wait until tomorrow to update the device!

Unfortunately I upgraded to Vim3L.
How can I restore an older version without losing data?
Or what can I do? Not booting …

You have to setup a new (tomorrow) uSD or USB device to boot CE. When it’s booted from external media you need to overwrite cfgload on the eMMC.
The data isn’t lost at all.

More instructions in detail will follow tomorrow.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice