9.2.3 Discussion


Addon update went automatically, after I updated to 9.2.3 and it was booted for the first time. But I need one more system restart just after that addon update…

Updated OTA from 9.2.2 to 9.2.3 on:

  • NexBox A95X S905X (1/8) (-generic)
  • TX3 S905W (2/16) (-generic)
  • Turewell A95X F2 S905X2 (4/64) (-ng)
  • TX5 Plus S905X3 (4/64) (-ng)

Initial -ng update failed due to incorrect tarball on server. Issue was corrected.

Default testing apps:

Video: Crackle FilmRise PlutoTV YouTube (Kodi Official Repository - YouTube API key)
Audio: Grooveshark LastFM Radio SoundCloud (Kodi Official Repository)

Test duration: 10 minutes per add-on for a total of 2 hours and 10 minutes.

All add-ons work within specifications.

No lag or stuttering was experienced during audio and/or video playback from USB SD or streaming over WiFi or LAN.

All hardware appears to be correctly recognized and working to manufacturers specifications.

VPN used (limits available bandwidth): yes


Thanks a lot for your comprehensive tests.

Thanks for the release!
Running amazingly well on Odroid N2.

Since CE now comes with tvh I decided to test-drive tvheadend 4.4. It actually works very well right out of the box. Fantastic.

One thing that’s missing is the ability to create thumbnails for TV recordings. I found this

Am I correct in thinking this feature is tackled and will appear in an upcoming CE update ?

Where did you get TVH 4.4 ?


Are there any changes with connman version?

Note from the 9.2.2.

I plunged into the deep end and updated manually. DRM content works in SkyGo. AmazonVOD prompts a HTTP error. You have to re-enter your credentials, then it works.

I wondered the same and went searching for it and it would have to be something that would have to be built from current source.

Then I realised that the reference was very likely to be the HTSP client version rather than the service.

No confusion on my side… I just wanted to inform you before this tarball might become distributed via the auto-update :slight_smile:

Btw: I really appreciate your work, I never had something running so smoothly out-of-the-box as the N2 with CoreElec!

1 Like

Still not work driver RTL8153B, for new adapters USB GIGABIT LAN… ;/ Why not update ? ;/

This broke my vim3l. Manually updated and now it won’t boot reporting an error in mount_flash. Any ideas?

I’m guessing that partition names have changed?

Did you have vim3l delivered with CE pre installed?
If yes recover your device by Khadas Android image and USB Burning tool and perform a new CE install by ceemmc.

Thanks for the reply. I feared as much that I would have to fresh install.

Any ideas what has caused this? Is there no other fix?

P. S. Thanks for all of the hard work!

Because the pre installed image was a hack and is not compatible anymore. It’s a fault on CE side, the image should be never delivered. Sorry for this.

Good point. I ment 4.3 which is bundled.
Just waiting eagerly on the thumbnail feature.
Hope it will come to CE.

Good to know.

Mine was pre installed with android and I manually flashed to coreelec from the official repo (9.2.2.).

Will automatic updates ever be available on vim3l?

From where you got the image? Or did you use the ceemmc tool? Khadas do have a big mess up with different images.

I used an image of 9.2.2 from dl.khadas.com and used their emmc flashing tool (forget the name).

Worked flawlessly since install. Tried to update today and suspect that it’s renamed the partitions as it’s not vim3l compatible.