9.2.3 Discussion

It should be solved quickly. The partition naming is different on Khadas CE image, that is why it’s not booting anymore after update. We are working on a hotfix & re-tag of 9.2.3.

Great, thanks for confirming.

Just for clarification, I need to reinstall? Or is it possible to edit partition names via ssh?

Had exactly the same issue.
Did not need to bring back to stock android. I created an SD card with 9.2.3, booted then just ran the CEEMMC tool.
Installed again without issue then reinstalled all my add ons.
All running fine now without issue.

9.2.3 got fixed but it’s not uploaded yet. It will be available in next few hours. So for VIM3L users, please wait until tomorrow to update the device!

Unfortunately I upgraded to Vim3L.
How can I restore an older version without losing data?
Or what can I do? Not booting …

You have to setup a new (tomorrow) uSD or USB device to boot CE. When it’s booted from external media you need to overwrite cfgload on the eMMC.
The data isn’t lost at all.

More instructions in detail will follow tomorrow.

s905x3 box. still the video sometimes shows up at the top left corner (1/4) and then resized after 1 or 2 secs. Most of the time that is the case but sometimes, the video is not resized properly until i manually seek video. no such issues on s905x box.

With 9.2.3 version, HDR10+ is broken in Odroid N2 and triggered as HDR

Make sure option HDR to SDR is Auto not off. I haven’t specifically tested since upgrading but that happened to me during testing the nightlies and I had that setting to Off.

You’re right.I had that setting to off. Setting to auto and rebooting solved the problem and HDR10+ is back. Thank you.

As usual I would like to stress the importance of making a full system backup before upgrading/updating.

HOW TO Backup the entire Kodi System to USB Flash Drive - CoreELEC.pdf (4.0 MB)

1 Like

Nice job @Betatester!

You can add another backup option:
When used ceemmc to install to internal eMMC you have two options to backup whole CoreELEC partitions.

When booted from external media like uSD or USB:

Make a backup of current CoreELEC dual/single boot installation on eMMC to current used SD or USB device

When booted on internal eMMC:

Make a copy of current CoreELEC installation on eMMC to current used SD or USB device

To @Erdmi and all VIM3L who where lucky and bricked the device by updating to 9.2.3: the error is fixed and the release tar file got updated on the release download page.

If you have already updated and the system is not booting anymore please prepare a external boot media with new 9.2.3 image like by uSD or USB and boot VIM3L. Open a SSH connection and type:

mkdir /media/ce_flash
mount /dev/coreelec /media/ce_flash
cp /flash/cfgload /media/ce_flash/cfgload

Then power off the device, remove exernal boot media and the VIM3L should boot again from internal eMMC.

Thanks for this.

mount /dev/coreelec /media/ce_flash gives me the following error: “mount: mounting /dev/coreelec on /media/ce_flash failed: Device or resource busy”

Any ideas?

can u please the output of:
ls /dev
dmesg | grep mmc

Try this:

mkdir /media/ce_flash
losetup -f -o 146800640 /dev/mmcblk0
mount /dev/loop1 /media/ce_flash
cp /flash/cfgload /media/ce_flash/cfgload

No errors when executing the commands but when I reboot it displays the same error as before.

“Error in mount_flash: mount_common: Could not mount LABEL=CE_FLASH”

I have my config backup so I’ll just reflash and apply that. Save you a headache.

Would be nice if you can try this:
losetup -f
you will get a next free loop like /dev/loop1

Replace loopx in the commands below to match your next free loop:

losetup /dev/loop1 /dev/mmcblk0 -o 0x8C00000
mkdir /tmp/m
mount /dev/loop1 /tmp/m
ls -l /tmp/m
cp /flash/cfgload /tmp/m/cfgload
ls -l /tmp/m
umount /tmp/m
losetup -d /dev/loop1

Commands completed successfully but same error on reboot.