9.2.3 Discussion

hallo i have a A95 Max update to 9.2.3 and can confirm Problem it still reboot when commanded to shutdown

VC1 codec playback seems to be not fixed in 9.2.3 with HW GPU acceleration on Odroid-N2. I see now that in guisettings.xml it is explicitly disabled:
setting id=“videoplayer.usevaapivc1”>false</setting
setting id=“videoplayer.usevdpauvc1”>false</setting

I tried to place the same lines in advancedsettings.xml on 9.2.2 to do the same, but still on both versions VC1 playback is stuttered. The only way to play it smooth is to completely disable HW acceleration for all formats.

Does someone else have the same problem on Odroid-N2?

We don’t know about this issue… please upload a sample

I have uploaded a sample of VC-1 video with some dynamic scene. You can try to play it with and without HW acceleration to see the difference.


I don’t see any difference between hardware decoding on and off when played on the N2. Nor do I see any problems with any of my other vc1 encoded content.

Also the settings you referenced above are for use on a pc. Both are todo with an nvidia api and have nothing to do with playback of vc1 encoded content on an amlogic based device.

To try and narrow down the cause, if you have a spare sd card you can try a fresh install, and see if the problem still happens.

Ok thank you for checking. Then it is something with my particular installation / settings. I will try then a fresh install with default settings.

So I tried a fresh 9.2.3 installation with default settings and VC-1 plays smooth :slight_smile: Then I went one by one through all video settings and found one which causes stuttering - whitelist for display mode. For me it was set according to my TV to one value only 3840x2160 60Hz. I remember selecting explicitly this in whitelist on some rather earlier coreelec version, because I had display flickering without it while playing some 4K videos. Now I cleared whitelist and all is fine.
So can you give a short description of this whitelist setting? Surprisingly it affected only VC-1.

Some time ago the behaviour of whitelist was changed. Initially whitelist replaced the previous default autodetect behaviour and if a whitelist was not set many video issues resulted.
This was changed in CE such that if the whitelist was not setup then autodetect of HDMI settings was enabled as default (which was the behaviour before whitelisting was introduced).


Just updated my N2 from 9.2.2 to 9.2.3. Went really smooth. Big thanks to the team!!! No major issues whatsoever. Just one observation: I believe(!) that the update reactivated CEC in the config.ini. I had it disabled on 9.2.2 as I’m controlling my home theater with a Harmony system. After the upgrade CEC interference reappeared. I checked the new GUI configuration in the Hardware section and found CEC activated. No biggie. Deactivated it again. All fine. Just wanted you to know…

There was a bug in the settings addon that affected parsing of the CEC value. This was fixed but it probably reset the value for you. Hopefully it was a one-time thing for you.

1 Like

I concur with cdu13a. The file appears to be sound.

Tested on TaNiX TX5 Deluxe Edition (S905X3 4/64) via LAN, USB, SD and eMMC.

Thank you Betatester. The issue is solved already, was one of my obsolete settings.

1 Like

Can you document what setting? Sounds weird that it’s a whitelist setting.

Yes it was whitelist with one only entry 3840x2160p 60Hz. When I cleared the whitelist then playback of VC-1 got smooth again. As weird as it is. As I understand whitelist defines now which video modes kodi does not upscale and sends up HDMI cable in native resolution. Why 4K entry there affected VC-1 1080p GPU upscale I can not explain.

Upgraded via automatic process. After reboot all the TV episode info had gone awry. No episode info and extra info in the lists (see attached photo). Fixed it by deleting the source and rebuilding. Hope this feedback helps.

1 Like

I saw this issue on 9.2.2. Fixed by deleting and re-adding also.

This is known issue: https://forum.kodi.tv/showthread.php?tid=354641
You need to update TVDB add-on. Deleting and adding source is not needed


i have a strange problem propably since 9.2.2.
My equipment Sony XE9305 and 2 players - Beelink GT King and Odroid N2,
same simptoms on both.
Very randomly can happen that i get such a picture on my Tv (see picture), especially
when I stop watching something and get back to list of my movies such a screen appears.

I think this has something to do with HDMI handshake or similar.
Resolution was on default set to 3840x2160p, 59.94 Hz. I’ve set it to 3840x2160, 60 Hz.

Any suggestions what can be wrong here ?

There is a Delay after change of refresh rate which is by default on off, but i doubt it that
this will fix the problem.

When i restart Kodi, the screen is normally shown.

Any idea ?

Thanks in advance.!

Try to set your GUI to 1080p.
I had similar problems when my GUI was configured to 4K.

I have to report one problem - after upgrading my Venz V12 to 9.2.3 the Suspend operation stopped working. When I invoked the Suspend, Kodi stopped but device was still running ignoring all inputs from remote. The only way to continue was to power off the box by the power button on it.
I had to revert to 9.2.2 - there it works correctly.