Installed, in fact updated my S905X box from -ng nightly to -ng 9.2.4 stable and everything works perfect for me. I don’t need nor use bl301 on this box, so should I also update to or can stay on present 9.2.4?

It can’t hurt to update to
But the bl301_inject bug was the only thing that got fixed and your S905X device wasn’t affected by this issue anyway.

Thanks @Portisch, I didn’t have much hope after shorting everything I could find, somehow assuming @skupi’s case would hit me, too, and the eMMC Android would take over.

I’ve now written a guide (it’s under moderation) on how I unbricked my TR99 X2, maybe it helps someone.

I’ve rolled back to 9.2.3 on my N2. I’m finding random but consistent slow downs that require reboots to rectify. When I have time, I may try again as a fresh install. Also CEC doesn’t work on my Panasonic OLED, where 9.2.3 is great. Might be the updated libCEC version I think I saw mentioned above. Anyway, not a big issue, just a preference for me right now.

So nothing about wifi not working on MXQ PRO 4K? I mean like this I cannot really use my box…

Since there always ends up being a libcec issue for somebody when it gets updated, we made it so that you can configure which version of libcec is used. How to configure used libCEC version

So maybe switching to a different version then default may help your situation.

1 Like

Which specific update is giving you the issue?

I just upgrade to on my N2+. SMB is not working. I cant browse to any of my shares on my freenas server. Kodi works fine on my PC, Nvidia shield and when running 9.31 on my N2+. I did a fresh image install on my 16gb emec.

Anyone else have this issue?

I was able to type the full path and connect so I got it working but Kodi doesnt autofind servers on my network when browsing for the path.

Is this a bug? Never had an issue with 9.3.1

Not sure what 9.3.1 is. N2+ is only supported from 9.2.4 up. Running older versions can lead to hardware failure.

Any chance that the update fixed the extremely slow GUI response?
With 9.2.4 i had slow GUI response, which i fixed by disabling hdmi CEC via config.ini

Are you sure that you have GXL device(S905X)? The update tar file does not work for GXL devices…that’s what I read in download section.

Have you tried this fix ?
You wouldn’t possibly have a Samsung TV ?

There are a couple places we still have to get to updating with information about supporting GXL devices with the ng builds. Unfortunately the initial 9.2.4 release had a couple issue, which distracted the developers from getting more information up about the GXL support with the amlogic-ng builds.

Will hopefully get the updated information about the GXL support in place in the next couple of days.

1 Like

I thought 4.0.4 was the default libcec version? I’ll try it out when i get home in a couple of hours.
And no it’s not a Samsung. It’s H96 Pro+ > Denon X4300

Sony 4k TV

With I have a purple screen.
First I’d a black screen and updated via ssh and suddenly the coreelec screen came back but with a purple overlay.

Device: Odroid N2
Kodi log can be found here:

System log:

edit: Turning off and on the tv removes the purple overlay :thinking:

I try to simulate this “issue” but how you performed the mount?
Any media I insert get automatic mounted to /var/media/* and not /storage/*.

I’m having 2 issues, both which were already present in v9.2.3:

  1. Impossible to update library. It’s as though there’s no internet connection however, library updating works fine in Android and I can download updates and add-ons in CoreELEC so, it is not a connection problem. FWIW, my Ugoos AM6 is connected via LAN.

  2. In CoreELEC, I can see my photo folders but when opening them they all show as empty. If I switch to Kodi under Android, all my photos are displayed. System settings are identical so I’m at a loss as to why this is happening.

I had another look at my settings and note that even though auto-updates are turned on, I am still using v9.2.3. I checked my connections and it confirms I’m in wired mode with the state being online. However, my firewall is switched off.

I attempted to change updates to manual but that made no change because it says there are no available updates. It really seems like there’s no internet connection even though it says there is and when in Android there’s no problem.

Sorry i meant to say 9.2.3
I ran that with no issues. I didnt use any usb powered externals. My point is, SMB browsing worked. doesnt.

Are you using SMB to connect to shares? I am having issue where network browsing is not working in SMB!