9.2.5 Discussion

Right, well that was a total disaster but I think it may be getting us closer to the source of the issue.

Here’s a screenshot of 3 different views of the SD card’s content according to Windows:

The first is of the root. Note, there are no .update or .smb folders. device_trees and LOST.DIR are both empty. Top right is the contents of the Android folder. Each one if its subfolders have a sub-directory called ‘files’ and they are all empty. Finally, on the lower right I opened the empty ‘files’ folder under videolan and pasted a file ‘friller.mp4’

Next, I returned to the home cinema and ran CoreElec again. Nothing we can see in the windows screenshot can be seen in CoreElec’s file manager without digging very deep and even then, the friller.mp4 file remains invisible.

So, I’m guessing that either Windows is unable to view the contents of Linux, OR all the directories with storage and databases shown in CoreElec are actually stored on the AM6’s internal memory rather than on the card itself.

You are correct - windows doesn’t recognize linux file systems so looking at the SD card directly will show nothing. However the boot partition is formated in vfat so will show the full contents of the boot disk. The STORAGE disk is where all your user files are stored such as your databases and this is in ext4 which is a Linux files system which makes it invisible to Windows.

Be warned that simply doing anything with Windows file manager and a Linux file system can corrupt it.

However SMB should be able to access those shared folders such as .update., and Coreelec shares a range of SMB folders by default. I have not used Windows Explorer for system admin for years so am not certain what Windows file manager will do when shown a Linux file via SMB.

Shoog

What is SMB?

SMB is Samba, the Windows file sharing protocol.

I think you have a corrupted SD card or at least a corrupted file system, there should be clear instructions on how to use Windows to prepare a working CE install on SD - have you followed these exactly ?

Shoog

:flushed: I don’t know how to use that. Sorry for my ignorance. I’m 65 yrs old.

So, there’s no way to fix this problem then?

These are detailed installation instructions

If I were you I would reformat the SD card or a blank USB stick in Windows and then follow the above installation guide from scratch. Test it by adding in you share folders first and seeing if they populate before attempting to do anything more complex like installing addons.

Not all image burning software does this correctly so I strongly advise using Rufus as instructed.

This will tell you if there is any specific issue with your hardware or install media.

I used Rufus to build the first CoreELEC on my SD card so that should be easy. So, you believe that my installation has been corrupted and requires a rebuild. If I do that, can I restore a previous backup or would that just corrupt the installation again?

Also, as my AM6 boots straight into CoreELEC once inserted, can I assume it will do that again after a rebuild or will I need to use the AM6’s recovery procedure as I do each time the box’s firmware gets an update?

Its a little bit frustrating that you aren’t just trying what I suggested and reporting back. So far I have zero useful information to make decisions on since you haven’t tested any of my advise.

If you have a USB spare burn your new test build onto that so that you still have your original SD - just incase it turns out to be something entirely different.
It should just boot up from USB.
As I said before do nothing other than create a new CE boot media and add your shares to it to see if they populate. Once you have done this report back what happened.

Shoog

I don’t have a spare USB key but I do have a second SD card of the same size so I will do it with that. What do you mean by “add your shares to it”, please?

Go to settings and add your media in the media tab

Should I add one drive at a time or just leave it to scan all the drives simultaneously?

Should make no difference but one at a time should produce quicker answers

Shoog

You’re a better person then me @Shoog, and a lot more patience too.

@QT-Pro It’s worth mentioning that I’ve never used the library facility in CoreELEC, or Kodi on Android, because I’ve always found that both list my music and video media quickly and reliably without scanning them into the library. I therefore don’t need to update the library when I add or remove media from my external media drive, CoreELEC or Kodi finds what’s there immediately whenever it’s run.
JB

That’s the whole point though JBA6, mine doesn’t.
In Android, all my files are there and playable. In CoreElec, the most recently added files are invisible. Their folders are shown but the content is empty.

If yours updates automatically, it tends to suggest you have your library settings on auto-update?

I rely on CoreElec because Android is rather unstable when watching movies. They will either freeze or the drive gets unmounted for no apparent reason. I do get freezing in CoreElec but not as often as in Android and it never unmounts a drive by itself.

Ok, I tried scanning a single drive but the problem remains the same. The scan window opens for a second and then closes, like there’s nothing to scan. It’s definitely not an internet connection issue because the AM6 uses a wired connection which is displayed in CoreElec’s settings.

So let’s be clear, on a completely fresh install it still will not scan your drives ?

Exactly, but only when in CoreElec. If I’m in Android, Kodi scans them without issue.

It’s like there’s some security setting that is blocking CoreElec from scanning but I have checked and double-checked all options in both CoreElec’s and Kodi’s settings and I can’t find anything that could do that. Like I said previously, my instant reaction is that there’s an internet connection issue, but that isn’t the case because CoreElec displays both time and weather info as well as having no problem to download addons and auto-update itself.

Sounds to me like the combination of your USB hardware, both in the box and the external drive(s) plus hub, and the CoreELLEC drivers is simply not a reliable combination. You also mentioned that the drive(s) occasionally disconnect or give problems when playing movies under Android so again this suggests the combination of the box hardware and your external drive(s) has marginal reliablility. Your best solution is likely to be to use a different media playing combination with better reported reliablility.
JB

To make any more progress you need to master SSH and dmesg.

However disconnecting harddrives usually means not enough 5V power to keep your HDD connected. A backpower into a usb hub from a usb charger might help.

Some people are reporting that only the usb3 port is working on the AM6 when running Libreelec, so have you tried all the different ports.

Shoog

I have to admit that I’m beginning to think my AM6 may be defective. After all, I don’t see any other AM6 owners making similar complaints. Ugoos customer support replied that I should contact the seller as after sales is their duty. The seller says to send the box back to him for testing but the cost of postage to China is more than half the cost of the box itself. It may be simpler to just buy another box.

However disconnecting harddrives usually means not enough 5V power to keep your HDD connected. A backpower into a usb hub from a usb charger might help.

The hub is powered. Besides which, drives only get disconnected when in Android. That doesn’t happen when in CoreElec. Other than that, I don’t know what a USB charger is unless you mean the type used for charging a telephone or tablet with?

Some people are reporting that only the usb3 port is working on the AM6 when running Libreelec, so have you tried all the different ports.

The AM6 has 2x USB 2.0 ports at the rear and 2x USB 3.0 ports on the right hand side. I was told that in order for it to be able to read multiple drives via a USB hub, I should use the OTG port. I don’t know what OTG means but I have only tested the hub on that port to date as I didn’t want to risk burning out the 2nd port.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice