Alfawise Z1 bluetooth remote configuration

I have an Alfawise Z1 (2/16) and there was a problem under CE, the BT remote OK button cant working only when i switch to mouse mode. With this little mod i able to use as expected.

First, create /etc/udev/hwdb.d/10-btok.hwdb file and fill with:


Save, reinitialize hwdb and reboot system:

_systemd-hwdb update_

The remote controller use the following codes:

Mute c00e2
Menu 70065
Ok c0041
Up c0042
Down c0043
Left c0044
Right c0045
Home c0223
Back c0224
Mic c0221
Vol+ c00e9
Vol- c00ea
Prev c00b4
Next c00b3

Mouse mode
Ok 90001
1 Like


I have a similar issue but with a different remote. How did you find the name of the of the remote for the 10-btok.hwdb file?

Thanks Paul

Hi all,

I have the same situation where the OK/Enter key does not work on BT, but everything else does. The remote is Tekasmi Q9. I am using it on a S905x3 X96Air. I tried to use keymapper app, but no luck, and tried the above. Do I need to change the file name etc to get this to work? Thank you.

edit-all set, thx

How do I get device’ name? Same problem with two different bt remotes

Run the command udevadm info /dev/input/eventX being X the number of the event you want to change.
I suppose you already ran evtest.

The output of uvedam... will have this part DEVPATH=/devices/virtual/misc/uhid/0005:0957:1001.0002/input/input7 and in order 0005 is b and so on.

My device X96X9 S922X uses BT/IR remote. IR is working fine. Bluetooth, OK button does not work, all other buttons work fine.

I followed the instructions here: 11. CoreELEC: Bluetooth Remotes · CoreELEC/remotes Wiki · GitHub

Do it nearly a dozen times without success. Hope CETeam can help me.

Output of cat /proc/bus/input/devices

I: Bus=0005 Vendor=1d5a Product=c081 Version=0000
N: Name="X96"
P: Phys=b8:2d:28:0a:cd:43
S: Sysfs=/devices/virtual/misc/uhid/0005:1D5A:C081,0003/input/input8
U: Uniq=fe:98:71:5b:1a:01
Q: Handlers=sysrq kbd leds mouse2 event8
B: EV=12001f
B: KEY=3007f 0 0 0 0 483ffff 17aff32d bf544446 0 0 707ff 130ff3 8b17c007 ffff7bfa d9415fff febeffdf feffffff ffffffff fffffffe
B: REL=143
B: ABS=1 0
B: MSC=10
B: LED=1f

and then:

CoreELEC:~ # evtest /dev/input/event8
Input driver version is 1.0.1
Input device ID: bus 0x5 vendor 0x1d5a product 0xc081 version 0x0
Input device name: "X96"
Supported events:
   Event type 0 (EV_SYN)
   Event type 1 (EV_KEY)
     Event code 1 (KEY_ESC)
     Event code 2 (KEY_1)
     Event code 3 (KEY_2)
     Event code 4 (KEY_3)
     Event code 5 (KEY_4)
     Event code 6 (KEY_5)
     Event code 7 (KEY_6)
     Event code 8 (KEY_7)
     Event code 9 (KEY_8)
     Event code 10 (KEY_9)
     Event code 11 (KEY_0)
     Event code 12 (KEY_MINUS)
     Event code 13 (KEY_EQUAL)
     Event code 14 (KEY_BACKSPACE)
   Event type 2 (EV_REL)
     Event code 0 (REL_X)
     Event code 1 (REL_Y)
     Event code 6 (REL_HWHEEL)
     Event code 8 (REL_WHEEL)
   Event type 3 (EV_ABS)
     Event code 32 (ABS_VOLUME)
       Value 0
       Min 0
       Max 668
   Event type 4 (EV_MSC)
     Event code 4 (MSC_SCAN)
   Event type 17 (EV_LED)
     Event code 0 (LED_NUML) state 0
     Event code 1 (LED_CAPSL) state 0
     Event code 2 (LED_SCROLLL) state 0
     Event code 3 (LED_COMPOSE) state 0
     Event code 4 (LED_KANA) state 0
Key repeat handling:
   Repeat type 20 (EV_REP)
     Repeat code 0 (REP_DELAY)
       Value 500
     Repeat code 1 (REP_PERIOD)
       Value 33
Testing ... (interrupt to exit)
Event: time 1675740012.725324, type 4 (EV_MSC), code 4 (MSC_SCAN), value c0041
Event: time 1675740012.725324, type 1 (EV_KEY), code 353 (KEY_SELECT), value 1
Event: time 1675740012.725324, -------------- SYN_REPORT ------------
Event: time 1675740012.781586, type 4 (EV_MSC), code 4 (MSC_SCAN), value c0041
Event: time 1675740012.781586, type 1 (EV_KEY), code 353 (KEY_SELECT), value 0
Event: time 1675740012.781586, -------------- SYN_REPORT ------------
Event: time 1675740012.871569, type 4 (EV_MSC), code 4 (MSC_SCAN), value c0041
Event: time 1675740012.871569, type 1 (EV_KEY), code 353 (KEY_SELECT), value 1
Event: time 1675740012.871569, -------------- SYN_REPORT ------------
Event: time 1675740012.905312, type 4 (EV_MSC), code 4 (MSC_SCAN), value c0041
Event: time 1675740012.905312, type 1 (EV_KEY), code 353 (KEY_SELECT), value 0
Event: time 1675740012.905312, -------------- SYN_REPORT ------------

Press Ctrl C to exit
And create the file .hwdb:

#X96X9 remote

Running this command gives an error:
udevadm hwdb –update
have to change to udevadm hwdb --update to get the result:

/usr/lib/udev/hwdb.d/70-local-keyboard.hwdb:28: Property expected, ignoring record with no properties.

continue to run this command no result:
udevadm trigger -s input

After rebooting the device, the OK button still doesn’t work

Please tell me what am I doing wrong or missing somewhere?

Thanks a lot


Here is my .hwdb file with uppercase D and uppercase C in v1d53 and pc081

 #X96X9 remote

Do you mean this difference?

Yes change to lowercase

The change didn’t work. After I run the command:
udevadm hwdb --update
/usr/lib/udev/hwdb.d/70-local-keyboard.hwdb:28: Property expected, ignoring record with no properties.

Looking at the file /usr/lib/udev/hwdb.d/70-local-keyboard.hwdb I see some setups like my .hwdb file, but my setup doesn’t appear here.
It should be here, right?

Your file in


In this folder there is already file myfile.hwdb. However I copied the file /usr/lib/udev/hwdb.d/70-local-keyboard.hwdb to /storage/.config/hwdb.d/ and added my setup, but it still doesn’t work

My question is when running the command:

udevadm hwdb –update
udevadm trigger -s input

to update my settings to the hardware database. How can I check if I have updated successfully?

I get no feedback when entering those commands but my remote works. I wouldn’t copy the file, just create your own with your specific remote. Make sure spacing is correct , K in KEYBOARD should start under the v in evdev.

Do you have the same model and remote control? What CE version? I use CE 20.1 ng nightly

Vim4 CE 20 Homatics remote.

For BT: why do you have 1D53 if I see from evtest 1D5A?

File should then be like this?

#X96X9 remote

I was amazed by the mistake, but you found it. I cannot express my gratitude enough.

The Ethernet issue remains, and the donation offer still stands. If CoreElec team is interested in acquiring this device for further research, please inform me.

Many thanks to CoreElec team once more.

1 Like