Amiga PUAE not loading .adf

has anybody ever tried Commodore Amiga PUAE add-on from CE add-on repository? I have installed the latest version (.59.1) and was able to make the rom running. In my case it’s kick40068.A1200. So in fact I can see the main screen with the floppy drive, but I am struggling to load the content using .adf file.

I know my rom is correct. First I have compared md5sum from Commodore - Amiga (PUAE) - Libretro Docs page and it matches mine. Secondly, I was able to run very same rom and .adf file under WinUAE, so at least both files should be fine and working on different box.

From some reason, emulator is not loading the file, so I am wondering if anything specific needs to be set up in the PUAE options or any specific destination where the file needs to be put? Based on what I read, emulator should read .adf directly from the destination where the rom resides, which in my case is /.kodi/addons/game.libretro.uae/resources/system

In PUAE options, I picked kick40068.A1200 as kickstart rom, then I tried to play with some other variables, but no success. I am trying one disc game only, no multidisc with m3u playlist.

I can share both rom and .adf if anybody would be keen to try (less than 1.5MB).


I think it (Kodi) just does not pass the floppy-image directly to PUAE.
Same thing with m3u, which kodi probably thinks, is a media file and tries to play it with media player, but then fails.
I think correct way should be an m3u file containing the floppy image names, which is passed to PUAE.
This does currently not work in CoreELEC.

Game ROM images are in /storage/emulators for usual purpose.
And it works like open a game file there by game addons file browser, for which then kodi starts the right emulator (PUAE).

Actually, better try this unofficial retroarch addon, which has PUAE 2021 emulator available, and supports disk control menu, and some more options and features.

Kickstart-Rom Files go to

1 Like

Great, thank you for a kick. I have never tried to run emulator in Kodi, so wasn’t sure how this is set up. I read documentation and some articles, but this wasn’t really CoreELEC specific.
When I added game via emulator section, then .adf was loaded. I had to paly a bit with PUAE settings as on my Homatics Dune box, the emulation was stuttering, so I tried to adjust hardware specific options and setting CPU speed to -900 did the trick (at least for couple minutes playing I’ve tried so far). Not sure if default option 0 was too much or not enough…
I can now run one disc games. I still have to figure out how to use the m3u playlist for multiple disk games as if I run disk 2 separately (where disk 1 finished), it doesn’t resume the emulation of course.

I have tried to create m3u playlist, but as stated, it seems this is not an option for Kodi as if I try to run it instead of .adf file, Kodi got stuck and restarts after while. There is no way to select or input this somehow via the emulator itself so seems that for multi disk games, I will have to try RetroArch.

I tried RetroArch, but I think I am using too early CE release. I have 21.0-Omega_nightly_20231116 and RetroArch only goes from black screen back to Kodi. I will probably have to downgrade to Nexus and retry.

I noticed that same stuttering also, this is a problem of newer builds of PUAE, with this older build, it worked for me.
I wrote something about this before:

But it has not disk control menu, to change disks while running.
You can evade this problem, by emulating a AMIGA-CD32, and use a Software-Collection-CD.

This was the mentioned file i used, had a backup of it in my downloads folder: (3.5 MB)

Right, ok, thanks for sharing older version of libretro. As mentioned, I workaround this by playing a bit with hardware settings of PUAE and in fact it helped.
Anyway, I made RetroArch working today. It is using different emulator (uae4arm) and as you noted, this one has the disk management that works smoothly.
Also, I tried running CD32 emulation and found some .iso images of game collection from AmigaJay on internet. That narrative also solved the disks changing problem with original PUAE. Just some of the games are throwing red screen errors, but I might try different rom, or maybe emulating CD32 on uae4arm in RetroArch.

And one more thing, for my setup (CE 21 nightly running on Homatics Dune), I had to place kickstart innto /storage/.kodi/addons/game.libretro.uae4arm/resources/system for the RetroArch emulator. That was the place where uae4arm was lookig for it, /.kodi/addons/script.retroarch.launcher.Amlogic-ng.arm/resources/system/ didn’t work for me.

I have also some slight issues with gamepad where left stick doesn’t work in many games and arrow keys needs to be used instead, but I went and remapped those keys to work with left analogue joystick movements. It then leads to uncontrolled cursor movements that happens all of a sudden, but I can imagine if it is remapped to different controls it can cause problems. I have original Homatics gamepad, so this might also be some sort of problem.

Other than that, thank you for help. I have now running emulation of good old Amiga games that brings great memories : )

1 Like

With regards to issues with gamepad, I reset everything that I have reconfigured so far and started from scratch. If gamepad is off, then I can navigate thru menu without issues with remote controller only, but of course you can’t play games with it. When I pair that Homatics game controller so that B25 remote controller + gamepad are paired, strange things happens. Like the gamepad sends random keystrokes without me pressing it. Not sure, if the gamepad is bad or if Kodi/CE doesn’t like two controllers paired simultaneously.
I don’t press anything, if I start it behaves like other unintended keys are pressed. I have to turn gamepad off, to start working normally again. I am using standard Kodi controller profile for it as it is not listed among available controllers.
Did anybody experience similar behavior or is it just my gamepad?

I did not use uae4arm, but PUAE 2021 core in RetroArch.
Also i used 20.2 nexus ng stable.
On my setup right now uae4arm doesn’t work.

I have the same issues with PUAE in RetroArch as with PUAE from CE repo. It stutters. I tried to replace it with your package, but the .so library doesn’t work on my box. I was looking into logs and if I remember correctly, it was 32bits, meanwhile I believe I am using 64bit architecture, so I couldn’t use that. I think that was the cause, although I can’t remember now what I spotted in the logs. As mentioned you can optimize it with CPU speed settings, but it doesn’t work perfectly even after adjusting, so I stick to uae4arm emulator. That works great.

I only have issues with remote that is randomly sending unwanted signals. Fortunately this is doing outside of games only. When I want to exit and do something either in Kodi or change uae setting.
Not sure whether adding that specific Homatics gamepad into Kodi controllers would help (maybe it’s not 100% compatible with Kodi default gamepad)? Although I guess this would rather be Kodi development team task than something that CE team could look into…? I would be ready to provide anything where my limited knowledge may help.

You can try 20.2 with it. This is the version i have currently installed on s905x4 X96_x4.

The Kernel is 64 Bit capable, but only 32 Bit userland is available.
Still you can run 64 Bit binaries, if they are statically linked or you provide the needed 64 Bit libraries extra.
For RetroArch Kodi addon for CoreELEC, there is the option to compile it for 64 Bit emulators in this 32 Bit userland. I did not try it. But it should enable more capable 64Bit emulators to run on 20.2 nexus ng.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.