Amlogic-ne, New Era

The problem with this method and the original problem is that my TV will also turn back on when the system automatically resumes.

Trying this, the device does suspend after the given time but again turns itself back on immediately. Also the problem exists when using the suspend menu command.

Even with CEC off and using the menu command to suspend does the same behaviour.

  1. This behavior is indeed “new”. It reacted differently (better) on early versions of CE on the VIM4. I had also reported this regression on the Alpha thread.

  2. However, for me the problem is circumvented by enabling an “automatic shutdown delay”. You’ll be on another source before it goes to sleep, so there won’t be any CEC commands sent to Kodi until you return to that source. So no impromptu awakening. I just tested, it works. (with my hardware)

  3. On the other hand, you have to tell me how you manage to have a sleep mode that isn’t bugged ? I’ve been stuck on this for months. I have a loss of network when coming out of standby. What is your setup ?

This problem started on updates later than 15/11/2022. I will go back to this and test a non working backup.

Where do I find this setting?

I’m not sure, when sleep works properly when it wakes again I have had no issue with network. I will take a look again. Are you using WiFi or Ethernet?

1 Like

As far as I’m concerned, I find this setting in : System settings → Energy management → Sleep → Set timeout
(but maybe you need to install an Addon or other to access it, I don’t don’t know if it’s native?)

I’m using an ethernet connection. And you ?
But I had tested a few months ago on Wifi, and I encountered the same problem. The CE developers here had made me an update which reduced the appearance of this bug. So I think they have pinpointed the source of the problem. But I don’t think I got an explanation, and unfortunately the research was abandoned, and the thread deleted.

@Portisch I have a request, please upload the corrected s4_s905w2_2g file to night build.
Now after every update I have to replace dtb.img manually.

The fix will require more research. So if possible put the device online with tmate later this week so I can access and fix the rest of it.

Be very careful. I wanted to try the 1080p@120hz display mode, it resulted in a total system lockup. Forced to reinstall the whole system. :smiling_face_with_tear:

(Vim 4)

Thats what I’m using on my vontar x4 for very long time now. Never had any hassle.

Same Here. My tv gives a black screen. If I stop the video using x on my keyboard. The screen comes back. No problem with the NG version of CoreELEC.

1 Like

Maybe an isolated case for Vim 4. As I had to reset everything. I even tried the manipulation with a clean system, and the same result, system crash. Black screen, even after a reboot. Had to reset everything a second time.

I use a HK1 Rbox x4s. So totally different system. So I doubt we are the only ones experiencing this.

1 Like

When I try booting to eMMC from CE there seems to be some sort of long delay most of the times that didn’t happened on NG. I started using NE v20230107, now on the latest, wiped & burned the SD card again with another app just in case and it still happends. My HK1RBOX X4 1Gb power light just stays blue, the screen black; if it stays too long I simply use the tv remote input-source and it eventually reboots to android.

A possible small bug, Ethernet fails to be enable if Wi-Fi and Ethernet are both disabled, and then you try enabling Ethernet. A reboot is needed as a workaround.

Thanks you devs & contributors!

Hello @vpeter , I have installed the docker service from the official repository. When I restarted I realized that the service did not start, and I saw that it was because the symbolic link had not been created. I had to do this to get it to work:
systemctl enable docker.service && systemctl start docker.service && reboot
I don’t know if this is just my mistake? I’ll let you know just in case it’s something general.

There has been no recent mention of sm1 support with CE-ne. Is this no longer planned?

Maybe in future, maybe not. Time will tell.

Recent night build ne installed, my dtb.img too.
I have also enabled tmate, please feel free to add the corrected s4_s905w2_2g.dtb to your night build at your leisure.
Is there any chance to enable the bt interface??

Next week on Monday, please enter a username how the wiki shows:

Then leave the device powered on.

Installed the latest nightly (CoreELEC-Amlogic-ne.arm-20.1-Nexus_nightly_20230127.tar).
Problem with external USB3.0 drives remains (constant Disconnecting and then reconnecting again).
It occurs sometimes within seconds, sometimes there are minutes in between.
Problem is that the media playing from the USB drive gets interrupted when it happens.
For the rest (Bluetooth, WiFi, Ethernet, etc.) all fine.