Amlogic-ne, New Era

Amlogic-ne, New Era

Team CoreELEC is proud to present project Amlogic-ne (New Era).

For months, the team has worked tirelessly to build an “almost finished” product, ready for the first public test release.

Team CoreELEC would like to thank all those who helped to get this project off the ground, no matter how small or large their contribution.

Special thanks go to Beelink and Khadas for helping us with the implementation of the new T7 (A311D2) platform, and BuzzTV for their generous hardware and software support.

What is new?

  • New Era is based on Amlogic Vendor Kernel 5.4.125.

  • Device support for New Era currently starts with SC2 (S905X4), introducing support for the new S8 & S9 family generation 4 Amlogic SoCs.

  • Towards the future support for SM1 (S905X3) may be implemented. Further testing in this area is required.

  • Added support for S4 (S905Y4, S905W2) and other new devices not covered by Amlogic-ng, such as T7 (A311D2).

  • The newest generation T7 supports HDMI 2.1 while others remain at HDMI 2.0.

  • Support for GXL (S905X) and G12 (S922X, S905X2, A311D) with Amlogic Vendor Kernel 5.4 remains uncertain .

The Kodi interface still uses the same Kodi Nexus base as Amlogic-ng.

What will change?

  • There are no plans porting Kodi Matrix to Amlogic-ne.

  • Starting with CE-21, and depending on how the new 5.4 kernel performs, sometime in the future support for kernel 4.9 might be dropped entirely.

Currently supported devices:

Supported Amlogic Device Family SoC
Beelink GT King II T7 A311D2
Khadas VIM4 T7 A311D2
Ugoos AM7 / X4 SC2 S905X4
BuzzTV X5 64 AI / 128 AI SC2 S905X4
BuzzTV HD5 S4 S905Y4
Khadas VIM1S S4 S905Y4
Generic SC2 S905X4
Generic S4 S905Y4
Generic S4 S905W2

There are currently no public releases of amlogic-ne available.

9 Likes

Congratulations and thanks for your hard work! I am very glad to see A311D2-T7 being supported.
But I am having issues with booting my Beelink GT King II. I have been trying it many times with no success. The device won’t boot from USB but boot from the original Android.
I am using the image file: “CoreELEC-Amlogic-ne.arm-20.0-Nexus_nightly_20221007-Generic.img.gz” and followed the following instructions flashing it to a USB device.
[install]
https://wiki.coreelec.org/coreelec:beelink
[reset button method]
https://wiki.coreelec.org/coreelec:ceboot

and here is a list of the USB devices I have tried:
16GB-USB2.0-U-DISK
64GB-TFCard
128GB-USB3.0_SATA3.0-SSD

Any of those devices won’t boot the CoreELEC. I really appreciate it if anyone can help me figure out what went wrong and the correct method.
Thanks

Correct dtb.img is placed?
Did you try Reboot to Libreelec app?

I use the USB3 ports and it works without any issue.
What Android firmware version do you use?

Thanks for your lightning fast response!

//Correct dtb.img is placed?
Yes. pretty sure about that.
//Did you try Reboot to Libreelec app?
No, And to be honest I have no idea Libreelec app. It is mandatory to do that?
//I use the USB3 ports and it works without any issue.
Both of the two USB3.0 and the USB2.0 won’t boot in my case
//What Android firmware version do you use?
Version:003P0 2022-08-10 from the link below:
https://www.bee-link.com/cms/support/driverhardware?product_id=90

I also have a boot loop.Comparing Nexus devel_20220929082110-Generic.img with Nexus_nightly_20221007-Khadas_VIM4.img after burning to a usb .There is no aml_autoscript and no cfgload. With these placed on usb it boots

If you have Android installed on eMMC you need to use generic image + copy vim4 dtb.
VIM4 image is used as standalone when there is no Android installed.

-sh: ceemmc: not found

Install a alpha to internal is not so good idea I think…

1 Like

Thanks for your response!
In this version, my HK1 RBOX X4 finally recognizes the 1000M network card.
But I want to write to the emmc so that the TF slot is not occupied.

That’s not supported atm. We still don’t know if and when it will be supported. Many things changed and we’re taking it step by step. Do you want to run from emmc and have a uSD slot free? Buy a VIM4.

Thank you Portisch
Update:
I have the ‘Reboot to LibreELEC’ app installed and it works like a charm!
And finally, there is one thing that is certain: The reset button method is not working anymore in GT-King II.

Wich of those devices are supporting Dobly Vision?

If the ODROID N2 is not supported anymore im thinking of upgrading my odroid to a device with dobly vision

No device using CoreELEC (or LibreELEC or OSMC) will likely ever support Dolby Vision. HDR10+, HLG HDR, & HDR10 - sure.

1 Like

Not even if the soc will do dolby vision?

Bc i just read that the VIM4 can do dolby Vision

It’s all about licensing. The other HDR formats do not require per-seat payments.