Amlogic-ng does not boot on MECOOL KII Pro (S905D)

I know this is experimenta,l but when selecting the above device from the downloads page there is a text saying that it is supported by -ng builds.

So I gave it a try on a spare micro sd card, copied gxl_p231_2g_dvb.dtb to dtb.img.

The result is that it shows the MECOOL logo and then switches to a black screen where it stays forever.

Searching this forum, I found no results.

Can anyone confirm?

Did you follow the “First boot” section from the article linked in the download helper?

You mean I should press the reset button again for a long time, even though the box already boots from sd?

I found out that the box boots but I get these and a black screen

[   27.428929@0] fb: malloc_osd_memory, cma:ffffff800ad14848
[   27.428939@0] fb: malloc_osd_memory, 1218, base:0x000000007f800000, size:8388608
[   27.428942@0] fb: use ion buffer for fb memory, fb_index=0
[   27.428957@0] ion_dev ion_dev: Fail to allocate buffer
[   27.428961@0] fb: malloc_osd_memory: size=1800000, FAILED.
[   27.432761@0] fb: malloc_osd_memory, cma:ffffff800ad14848
[   27.432771@0] fb: malloc_osd_memory, 1218, base:0x000000007f800000, size:8388608
[   27.432774@0] fb: use ion buffer for fb memory, fb_index=0
[   27.432790@0] ion_dev ion_dev: Fail to allocate buffer
[   27.432793@0] fb: malloc_osd_memory: size=1800000, FAILED.

Yes, it must be used for every new installation, and after every Android upgrade.

Did not help.
Tried everything from scratch, tried updating the old sdcard with .nocompat etc. boots but black screen and above error.

There is a problem with device tree for mecool Kii pro, try to use device tree from ki pro - coreelec boots up, but DVB and ethernet doesnt work.

Your Kii Pro has lower hardware specs than the Ki Pro.
The KI Pro DTB is not compatible

KII Pro 10/100
Ram 2 GB DDR3
KI Pro 10/100/1000
Ram 2 GB DDR4
What does it mean when you said there is a problem with Kii Pro DTB ?

I don’t know, I didn’t check the files.
on dtb intended for ki pro coreelec starts on mecool Kii pro. on dtb for Kii pro - Black screen. Any idea?

OK
You will have to wait until @cdu13a gets a chance to look at the dtb for the Kii Pro

I had the same problem on the new installation of a release 9.2.5 (latest stable).

I have Mecool KII pro Android 7.1 wirh a S905 Rev. 2 (S905D) then I used the tree DTB suggested on the installation instrution but don’t boot remain in a booting.

Then I used a workaround using one old DTB I used in a Librelec and started also if telling me a warning with a message that the tree is out of date.

Maybe the tree inside the installation directory isn’t right or corrupted?

Are you saying you are using an old LE dtb and your Kii Pro is booting with CE NG image ?

yes, telling the message that the devoce tree is out to date but booting and working like this. Otherwise with CE dtb not booting.

Which old dtb did you use exactly?
So you say you get a warning, but it still works?
Better than a black screen with the “official” dtb :slight_smile:

if i can put it here I put … its the dtb taken by last Libreelec image written for aml cpu before interrupt if i remember well was 8.2.3.1

dtb.img (55,2 KB)
i change some values between dtb’s so now i have working ng image on my Mecool KII pro. This is some kind of “Fun Build”. Maybe someone want to test it

@Rom3k

Your dtb looks completely different, not just a few values changed. What did you take as the base for your dtb?

Can you do something similar for Mecool KIII Pro?

@zuka1977 I don’t have mecool KIII pro hardware so it’s impossible at the moment.

Finally tested your dtb, works even with the final Matrix release from today.
Thanks!

@Rom3k I compared it to our gxl_p230_k1_pro dtb and the only diff is that you use external ethernet, isn’t it?

About | FAQ | Terms of Service | Privacy Policy | Legal Notice