Amlogic S905X3, S905Y3, S905D3 thread

I don’t know if this will work. Have you gone to the settings, audio, & changed the output?

There are a few HDMI, pulse audio blue tooth, & something else. Try them, you never know.

3,5mm audio output doesn’t work on S905X3
It’s in our todo list, but not yet solved

Thanks, will wait for it :grinning: :+1:

Thanks mate, tried all settings - no luck

Heard its still on the to-do list :+1:

Доброго всем. А есть у кого remote.conf на приставку H9x3?

Good to all. Does anyone have remote.conf on the H9x3 console?

Please use English on this forum.

Confirm your hardware and go over to NEW Repo for Remote files (Thanks to Betatester)

Just for reference:-

A95X-F3 Air -Amlogic-S905x3

Video Support: * Amlogic video engine (AVE) with dedicated hardware decoders and encoders

  • Support for multi-mode decoder - 4K x 2K 60fps + 1x1080P 60fps
  • Supports multiple “secured” video decryption sessions, simultaneous decoding and encoding
  • Video / image decoders:
    -VP9 profile-2 up to 4K x 2K 60fps
    -H.265 HEVC MP-10 L5.1 up to 4K x 2K 60fps -AVS2-P2 profile up to 4K x 2K 60fps
    -H.264 AVC hp L5.1 up 4K x 2K 30fps
    -H.264 MVC up to 1080P 60fps -MPEG-4 ASP L5 up to 1080P 60fps (ISO-14496)
    -WMV / VC-1 SP / MP / AP up to 1080P 60fps -AVS-P16 ( AVS +) / AVS-P2 JiZhun profile up to 1080P 60fps -MPEG-2 MP / HL up to 1080P 60fps (ISO-13818)
    -MPEG-1 MP / HL up to 1080P 60fps (ISO-11172 )
    -RealVideo 8/9/10 up to 1080P 60fps

AV sound is working on coreelec ?

understood - thank you. can anybody confirm there is problem with bluetooth audio? it is like the sound vibrates or lags like when you quickly switch the speaker on and off over and over and it is unable to understand. for me only HDMI sound works.

4 posts were merged into an existing topic: CoreELEC 9.0.x Remote files

Hey guys, does anyone know if the S96 Max Plus S905X3 4/32 can passtrough lossles codecs like Dolby TrueHD + Atmos using CoreElec? Or only Dolby Digital Plus? I know the box with stock software is unable to stream TrueHD.

Yes, all S905X3 devices supported by CoreELEC have support for passthrough of Dolby TrueHD Atmos, DD+ etc.

1 Like

It’s working now on nightly ng builds. I have a Vontar X3 S905X3 rev c. Audio out is via 3.5mm AV socket to soundbar and all is great. I did check with the stable ng build but that didn’t work, so you do need a nightly. I’m using CoreELEC-Amlogic-ng.arm-9.2-nightly_20200506-Generic.img but I think 202000503 worked as well.
Actually if you follow the guide for " How to configure IR remote control" and then How to configure IR wakeup code
and use hk1-x3-vfd.conf for vfd then everything works really nicely. The microSD slot read/write speed is pitifully bad even with microSD Class 10 A1, actually unusable as everything in the UI stutters & lags, but the USB 3.0 port with a good USB 3.0 stick is fine. I’m using a Sandisk Ultra Fit 32GB. I get about 1/3 its rated performance on the Vontar but it’s enough.

I got the box yesterday morning and we had a good hard fight. Now it is compliant :innocent:

1 Like

Hi @julian67,

Thanks for the information, will try this weekend :+1: :grinning:

Remote works fine with standard NEC remote conf file, but thanks
I’m using USB-stick on USB 2.0 port which works nice, not tried SD card
Also made vfd working from the start, so a happy bunny over here.
On this moment I own 3 different Amlogic boxes (X96, H96Max and X96Max Plus) all working CE 9.2 and no major issues.

I will let you know if upgrading to nightly 20200506 makes my 3.5 mm AV work.

Many thanks

Koos

1 Like

Hi @julian67

The 20200506 nightly works :tada: :clap: :+1:
Not yet in combination with HDMI but I can listen to my internetradio now without TV :+1:

Thanks :ok_hand:

1 Like

I’m on nightly of 20200509. I switched mine to HDMI audio out and that works fine too, with output set to ALSA:AML-AUGESOUND, HDMI (I don’t need the multichannel but it does also work).

Guys it seems the bluetooth audio is still lagging after a fresh install.

N5MAX:~ # dmesg | grep -i blue
[ 8.701157@0] Bluetooth: Core ver 2.22
[ 8.701256@0] Bluetooth: HCI device and connection manager initialized
[ 8.701324@0] Bluetooth: HCI socket layer initialized
[ 8.701335@0] Bluetooth: L2CAP socket layer initialized
[ 8.701368@0] Bluetooth: SCO socket layer initialized
[ 13.290541@3] Bluetooth: HCI UART driver ver 2.3
[ 13.290549@3] Bluetooth: HCI UART protocol H4 registered
[ 13.290551@3] Bluetooth: HCI UART protocol BCSP registered
[ 13.290552@3] Bluetooth: HCI UART protocol LL registered
[ 13.290554@3] Bluetooth: HCI UART protocol ATH3K registered
[ 13.290556@3] Bluetooth: HCI UART protocol Three-wire (H5) registered
[ 13.290811@3] Bluetooth: HCI UART protocol Intel registered
[ 13.290993@3] Bluetooth: HCI UART protocol Broadcom registered
[ 13.290997@3] Bluetooth: HCI UART protocol QCA registered
[ 13.290999@3] Bluetooth: HCI UART protocol AG6XX registered
[ 13.291001@3] Bluetooth: HCI UART protocol Marvell registered
N5MAX:~ # hcitool dev
Devices:
hci0 00:05:44:33:22:11
N5MAX:~ # hcitool con
Connections:
> ACL F4:4E:FD:00:FF:90 handle 1 state 1 lm MASTER AUTH ENCRYPT
N5MAX:~ #

but after I set the audio output from ALSA default to Pulse Default bluetooth audio the sound lags continuously. This problem is only in 905X3 box itworks on my 905 box with the same 9.2.2. On my 905 box has no built in BT so I use a dongle. I tried all the audio settings but no success. Any ideas?

Okay. I have inserted the dongle to 905X3 and shut down the built-in one. The audio works perfectly with the dongle so it seems the hardware support lacks. But cannot edit /etc/bluetooth to constantly disable the built-in one.

N5MAX:~ # hciconfig
hci1: Type: Primary Bus: USB
BD Address: 00:1A:7D:DA:71:0A ACL MTU: 310:10 SCO MTU: 64:8
UP RUNNING
RX bytes:676 acl:0 sco:0 events:47 errors:0
TX bytes:3164 acl:0 sco:0 commands:47 errors:0

hci0: Type: Primary Bus: UART
BD Address: 00:05:44:33:22:11 ACL MTU: 1021:8 SCO MTU: 255:16
UP RUNNING PSCAN
RX bytes:20133 acl:33 sco:0 events:1299 errors:0
TX bytes:775128 acl:1231 sco:0 commands:58 errors:0

N5MAX:~ # hciconfig hci0 down
N5MAX:~ # hcitool dev
Devices:
hci1 00:1A:7D:DA:71:0A
N5MAX:~ #

The UART device is (the one does not work:)
HCI Version: 4.2 (0x8) Revision: 0xaa89
LMP Version: 4.2 (0x8) Subversion: 0x7e1c
Manufacturer: Realtek Semiconductor Corporation (93)

And the dongle is (working one):
HCI Version: 4.0 (0x6) Revision: 0x22bb
LMP Version: 4.0 (0x6) Subversion: 0x22bb
Manufacturer: Cambridge Silicon Radio (10)

Assuming the Realtek device has a discrete driver, the easiest way is probably to blacklist the module. This should be close enough directions to get you there. https://linuxconfig.org/how-to-blacklist-a-module-on-ubuntu-debian-linux

About | FAQ | Terms of Service | Privacy Policy | Legal Notice