Amlogic S905X3, S905Y3, S905D3 thread

You can confirm that every box named X96 Air has working GBit ?
Al says: I don’t think so

I can only confirm that my X96 Air 4/64 GB P2 ethernet port is gigabit. Everyone has to know what they are buying.

image

My X96 Air 4/32GB has working (as in tested using LAN Speed Test / ethtool eth0 | grep -i speed returns Speed: 1000Mb/s) GBit.

As said before, after some thermal mods (see thread), it works great and I am very happy with it.

bought for EUR 35 at banggood.

Hi, does your ethernet work!? I have the same box, the 4/64gb version and wifi does work but I just can’t get the wired internet to work, I’ve tried several builds but no success :frowning:

Yes ethernet works perfectly.I have the 4/32 version but I think it’s the same as yours as far as the required dtb file is concerned.Do you use the nightlies? Have you changed the dtb file you are using?

1 Like

Thanks for replying. I’ve installed an older nightly (CoreELEC-Amlogic-ng.arm-9.2-nightly_20200321) and the ethernet is now working! A new issue I have is with rebooting and powering it on, I must unplug it from the wall socket to get it back to work, have you experienced this!?
Edit: any luck with vfd? I’ve read that for our box, hk1-x3-vfd.conf would work but I’m not having any success. Sorry for all the questions but it doesn’t seem many people have the h96 x3 :worried:

https://mega.nz/#!h1d3FYbL!hvjA0uBhtbgJmQ7LcClT0o2JEG1L4TxDRX_R_LC0ukU

  1. Copy the config.ini I uploaded above to the Root of your sd card.
  2. Go to “Coreelec - Hardware - Inject BL301 Blob” and press it to install it.The “IR Remote Power Code” must be “Custom”.
    After that the power button should function perfectly to power ON/OFF your box.
    Also vfd (file for hk1 x3) functions perfectly.In addition to that file you Must install also “Open VFD Service” via the Correlec repository in Kodi.
    I suppose you have already copied the correct files for the Original Remote Control to function properly (all its buttons).
1 Like

Hi, is it possible to set the remote device in addition to turn on and off only sleep mode?
Thanks.

Yes, I had the other buttons working and thanks to you the power on/off is also working now! vfd for some reason I can’t seem to get working, not sure what I could be doing wrong, does one need to edit something on the vdf.conf file?? A newbie question, for me to use the 64gb (or about 58gb that is free) rom of the tvbox to store movies, etc, I’d have to install coreelec internally? No other way, right? Would you recommend that? Is it better to wait for a stable release perhaps? I’d really like to use that free space.
Thanks again, much appreciated!

Did you install the Open vfd Service ? Not only the vfd file for our box.

I prefer to have a dual boot system (Coreelec+Android) so I never thought of using my internal memory for movies etc. Probably I will never do it anyway (with a nightly or even stable).

1 Like

Yes, I’ve installed Open vdf, updated it, I believe I did everything correctly but I must be missing some step. :frowning:
I’ll probably also keep android but alongside coreelec, internally, using this method How to use the Team CoreELEC ceemmc tool Have to read a bit more on it…
Edit: Thanks to @ath156 I now have vdf working!

Hi, did anyone succeed installing Coreelec distro on the Ugoos X3 Cube/Pro device? I normally pick up sm1_s905x3_2g_1gbit from the device_tree, but the system always ends in some mounting error.

Anyone has any idea why?

Dear friends,

Got the X96 Max Plus (4/32 Gb. - 1Gbit LAN) box and nightly runs (updates automatic).
Box works fine, but only the 3,5mm audio output doesn’t giving sound.

Over the day the box has function as “Radio” with internet radio, for which I want to use the 3,5 mm audio connector (connection 3.5 mm -> audio-input on audioset) and in the evening as IPTV/Mediabox (connection via HDMI -> TV -> audioset). Now I can only use internet radio if the TV is on, and that’s a bit silly.

So looking if I did something wrong or CE doesn’t yet work this way (LE did in a “old” S905X version)

Thanks in advance

I don’t know if this will work. Have you gone to the settings, audio, & changed the output?

There are a few HDMI, pulse audio blue tooth, & something else. Try them, you never know.

3,5mm audio output doesn’t work on S905X3
It’s in our todo list, but not yet solved

Thanks, will wait for it :grinning: :+1:

Thanks mate, tried all settings - no luck

Heard its still on the to-do list :+1:

Доброго всем. А есть у кого remote.conf на приставку H9x3?

Good to all. Does anyone have remote.conf on the H9x3 console?

Please use English on this forum.

Confirm your hardware and go over to NEW Repo for Remote files (Thanks to Betatester)

Just for reference:-

A95X-F3 Air -Amlogic-S905x3

Video Support: * Amlogic video engine (AVE) with dedicated hardware decoders and encoders

  • Support for multi-mode decoder - 4K x 2K 60fps + 1x1080P 60fps
  • Supports multiple “secured” video decryption sessions, simultaneous decoding and encoding
  • Video / image decoders:
    -VP9 profile-2 up to 4K x 2K 60fps
    -H.265 HEVC MP-10 L5.1 up to 4K x 2K 60fps -AVS2-P2 profile up to 4K x 2K 60fps
    -H.264 AVC hp L5.1 up 4K x 2K 30fps
    -H.264 MVC up to 1080P 60fps -MPEG-4 ASP L5 up to 1080P 60fps (ISO-14496)
    -WMV / VC-1 SP / MP / AP up to 1080P 60fps -AVS-P16 ( AVS +) / AVS-P2 JiZhun profile up to 1080P 60fps -MPEG-2 MP / HL up to 1080P 60fps (ISO-13818)
    -MPEG-1 MP / HL up to 1080P 60fps (ISO-11172 )
    -RealVideo 8/9/10 up to 1080P 60fps