Audio Sync Issue

Hi all,

My N2, CE 19.4 RC2 is connected via AmazonBasics HDMI Cable to my Sony X90J TV.

I’m having issues where the audio and the lips get out of sync sometimes. Pausing and resuming does not fix it but stopping and starting the playback does. Happens with any source be it a Movie via Plex or FTA TV via HDHomeRun and TvH.

This TV is only new but it happened with the old Samsung TV too so I doubt it’s a TV issue.

Any ideas appreciated.


1 Like

Had this issue recently. Cured by altering the dtb. The fix can be found on the nightlys thread near the end.


But it didn’t work for me. After keeping movie on pause for longer the out of sync will occur again. I will have time on monday so will post log in nightly build topic.

Here is the link to updated dtb that “should” fix this problem

Downloaded and installed the dtb that @loki7777 mentioned. New and old dtb both exactly the same size.

Looks like last nighlty build fixed it but will test more to confirm it.

This audio sync is still an issue. Have installed the recommended dtb and the problem still persists.

Just happened while watching a FTA TV using TvH. The audio is always way ahead, by a second or so, of the video.

Happens with all videos, movies, tv shows, plex. Makes no difference.

Any suggestions appreciated.

EDIT: Here is the debug:

Sync problem was at 6:35pm 8th Feb.

Use latest nightly as it has newer dtb version.
But yes - it was not fixed for me either.

Is that dtb different to the one in the Mega link a few posts up? Because I’m already using the one in the Mega Link.

I think it is as mega files were removed.

Downloaded the nightly and extracted the dtb, and they are different.

I’m still getting audio sync issues with anything I play on my N2. It does not happen all the time and may be OK for a few days, then it will go out of sync. Stopping and restarting the Movie/TV Show or FTA TV will always fix it.

Don’t understand why more are not complaining about it.

We’re trying to figure out this, as you said it’s not something that is always happening so it’s not as easy to identify.

Thanks for the reply it’s appreciated. Let’s hope the issue can be identified so you can attempt to fix it.

Thanks again.

This problem seems to creep in every time theirs a kernel change.


I’ve rarely had a 19.4 version including nightlies and the new stable that didn’t have audio sync issues. 19.3 is spot on though. There were a few nightlies that worked ok, then it turned to shit again. I’ve all but given up. It must just be my installation. If I can be bothered, maybe I’ll try a fresh install.

I had the Audio Sync issues with 19.3 and they are still there with 19.4. Makes no difference if it’s a TV Show, Movie, Live TV or Streaming app. Stopping, not pausing, and playing again usually fixes it.

Very annoying, wish it could be fixed but guess it must be hard as it’s intermittent.

Same here. Nothing is changing for me. Sometimes I can pause/play after few min and it will be ok but other time pause for few sec and oos straight away.

here too
N2 , not in sync after pause on 19.4

I’m really surprised that more people are not mentioning this as it happens quite a lot and there are lots of people using N2’s.

Maybe it’s dependent on what add-ons or setup people have.

No add ons in my config - just standard plus confluence skin - funny thing no issues with LE but from sd card as i don’t know how to move it to emmc.
My box in not N(+) so it is not box related.