Auto frame rate switching 4k movies

Hi,

I just bought the odroid N2 for it’s 4K HDR capabilities. But after installing I’m having trouble using the auto frame rate switching setting in Kodi. I absolutely need this to be able achieve judder-less playback. But I seems that lower refresh rates then 50 are not supported in 2160p, and all movies today are lower of course. I can whitelist only the higher framerates, but then I get judder because of the different frame rate.

so my question is, is there a way around this, or should I send the ODROID-N2 back asap ?

thanks for any insights.

by the way: I was running a Vero 4k+ before this and that did do the frame rate switching at any framerate, but then it does not do a great job at outputting HDR.

Are You sure ?
I watched a lot of 4k HDR videos(frame rate 23,97) and never had issues.

Well when I try to manually set the GUI to the 2160p it also works @ resolutions higher then 50 but not under it. Can you try if you can for example switch the gui to 2160p @ 24Hz ?

I also recently got an N2. I only have about a week left to return it and been testing it thoroughly. I’ve thrown a lot of HDR content to it and so far so good. Here are my currently settings… mirror them and see if that helps:

https://forum.kodi.tv/showthread.php?tid=340809&pid=2912359#pid2912359

I’m at work so can’t test it for you now, but It’s not recommended to do that.

See this post:

Recommended Kodi Settings

yes I know, but it’s just to see whether the board is capable of doing that resolution. I also only use 1080p for the gui normally …

What do you mean “doesn’t work at 24Hz”?
4K@24P works just fine. Maybe it’s your TV or AVR.

I get a “no signal” when trying this resolution. My TV is supposed to support it and my Vero 4k+ was able to output this resolution (using the same HDMI cable). Could the power supply cause such a problem ?

Try to set the 4:2:2 chroma option in CoreELEC settings and reboot. (Under System --> CoreELEC)

Update: tried a different HDMI Port (ARC) and now it works ! Very strange since the Vero had no problem on the other HDMI port … well … I’m happy ! Thanks for all the help !