Beelink GT1 Ultimate [LPN1] - no image

Hi!

Please, I’m requesting some guidance about an issue which is driving me crazy!!

My TV set is a 41’’ plasma Pioneer PDP-4280 (KURO Flat Panel HDTV), with 1024 x 768 resolution and 3 HDMI 1.3 Inputs. The TV accepts and displays 1080p/24Hz or 50Hz or 60Hz flawlessly, although downscaled to 768p.
As the TV hasn’t networked capabilities I thought that the best alternative was an external TV Box (Android TV) attached. Therefore I bought a brand new Beelink GT1 Ultimate (real 3GB Ram, 32GB Rom, Amlogic S912, Octa-Core, ARM Mali-T820MP3), serial number LPN1xxxx and firmware 709N1.

Well, I’ve tried all the possible solutions available but I can’t have a stable visualization experience.

  1. With Beelink’s pre-installed software (Android 7.1) I don’t have an image at all right after the Beelink logo.
  2. When booting from the SD Card with LibreElec [LibreELEC-S912.arm-8.2.5-Chroma.422.10bit] or CorelElec [v. 8.95.7] - both with gxm_q200_3g.dtb - sometimes I manage to watch contents during some minutes but other times it stucks right after the Libreelec or CorelElec logo.

This is really exasperating!

I have a Chromecast attached to my plasma TV and works perfectly well, at 1080p originally! And also works well my Cable TV Box at 1080i or 720p. And also no issues with my laptop or digital camera connected by hdmi…

The strange thing is that with this same Beelink box I can watch everything perfectly well in my other tv set, a small 22’ LG LCD on my kitchen or also well when connected to my PC monitor by hdmi. Both with Android or Corel/LibreElec OS’s. So, a hardware malfunction is discarded.

It seems there is a problem with graphic communication between the GPU and some display models. This problem also occurs with other tv set with different brands, as Samsung LCD (2016 model, for example, on my father’s house). On Beelink’s forum, there are other customers complaining about the same issue, with different tv models.

I posted asking for help on Beelink forum but silence is total.

So, the questions are:

  • how this issue happens (causes…)?
  • there will be a foreseeable solution?

I really appreciate every hint I could get - in practice, I have a bricked box as it is unusable…

Many Thanks!

Did you take a look at the resolution/refresh rate white list?
All combinations promoted by your TV are listed here.
Settings > System > Display

You could try to only allow 1024x768 ones, to let the Beelink do the down scaling and only output the native resolution supported by your TV.

Done!
The nearest resolution available is 1280x720p@50Hz

I can now watch video contents as iptv (even at 1080, downscaled) and youtube videos.

However, it is not 100% stable, it turns dead black in some situations:

  • when changing between iptv channels
  • when changing between different settings screens
  • when inputting text on screen keyboard
  • random situations…

It seems that the system doesn’t like very much to be poked…

Sometimes I can’t boot up the system, it stucks on black screen after CoreElec logo… Then, I have to unplug both power and hdmi cables, wait some minutes, add some hope and…voilá! At least until the next crisis… It’s not very comfortable!

To me it sounds like your in need of a better TV.

Have you tried a fresh install and not restoring backups?

You didn’t modify the resolution whitelist, but the GUI resolution instead.
The whitelist is the topmost option.

But I agree with @anon88919003 here…your TV seems quite outdated and should be replaced sometime.

@anon88919003 and @relkai, thanks for your hints.

I use a fresh install, always.
My TV still has better image quality (picture processing, black levels, contrast, colour accuracy…) than most of the actual sets (well, except for oled’s…), so a replacement is out of the question.

The strange thing is that I have different devices attached to the TV without any issue at all - Blu-ray, cable TV Box, sometimes my laptop, dSLR, Google Chromecast. The downscaling is flawless at all possible resolutions and framerate, via hdmi.

This afternoon I left an IPTV channel for 3 hours on screen. No problems. Then I started zapping and jumping between Kodi menus - it crashed to black screen.

Could you please provide a debug log of your device while this is happening?

thanks, but sorry, I have no idea how to do that… :confused:

You can look here https://wiki.libreelec.tv/how_to/provide_logfile

We need the log after the black screen though and seeing as you can’t see anything then you will have to follow the SSH instructions.

I’m not exactly sure what we can do about your initial problem as your box works on some TVs and then not on others, it may help defining a white list in the Kodi video settings of the resolutions that your TV supports, I think this may also solve your IPTV issue.

On a side note Beelink devices are notoriously bad with the fake RAM scandal and different Ethernet configurations.

Thanks for the link @anon88919003 , I’ll post the log as soon as possible. But, isn’t the Kodi log quickly replaced by a new one when the system restarts, preventing me to access the record that reports the moment of the crash?

One more request, please: how to define a white list in the Kodi video for my TV?

Yes, I’m aware of the ‘fake ram’ issue with Beelink’s model. I think mine has 3 real GB Ram according to the ‘fill ram’ app. I also have no problems with wireless or cable connections.

This weekend a ran few tests connecting different TV models (and ages): It was fine in 2 Sony models: KDL-46HX750 (2012, Full HD) and a different smaller one (2010, 24’’ HD Ready). No issues at all, changing settings, resolution and iptv channels.
However, on a Samsung UE40J5100 (2015, Full HD), I could see nothing: black screen.
Well, it seems that the problem could not be directly related to obsolescence as it does not explain the issues with the more recent Samsung model (and 1080p native!). That’s weird…

Regarding the log being overwritten:
You’ll find a kodi.old.log in the same directory, which always contains the previous log.

@anon88919003 and @relkai, this is the kodi.log from the last crashed session:
01_KODI.log (180.3 KB)

I was just jumping menus and suddenly the screen became black. Previously I had deactivated all kind of services (iptv and vpn, for example) just to help to clarify.

Once crashed the system is no longer accessible via network. So, the log is from the session that followed but it includes the kodi.old.log (line 815 onwards).
This particular session started at 02:09 (line 1315) and crashed at 02:10h.

I hope it helps.
Many thanks for your assistance and effort, anyway.

Your problem seems to be this one:

02:10:00.105 T:4089289536   ERROR: Window Translator: Can't find window videolibrary
02:10:00.173 T:4089289536   ERROR: Control 1000 in window 13001 has been asked to focus, but it can't

This is most probably caused by one of your installed addons.
It’s difficult to say, which of your installed addons causes it.

Do you have a spare sd card?
Try to perform a completely fresh install of CoreELEC and install your addons one by one and test if the crashes are happening again.

Thanks, @relkai
I did a fresh install in a different sd card. No addons, no nothing, just a mouse to click on the screen keyboard to input the wireless credentials. It crashed.
New try but crashed in other situation. And so on…

I will give it up because I can not find any logical explanation for what is happening.

Anyway, many thank for the follow up you gave to my problem.
And, while it worked, Corelec ‘ruled’ and proved to be a much better alternative than the Android factory rom.

Keep up the good work !!

I really have no idea, what could be your problem then.
It could still be hardware related (faulty Beelink device), but I’m just guessing here.
CoreELEC itself is rocking stable on most other device/TV combinations.
Especially vanilla configurations without anything added shouldn’t cause such problems.

I’m sorry, that I can’t help you in this case.

Just an idea, worth a try.
Try to connect to another tv which works with the box and write this command:
cat /sys/class/amhdmitx/amhdmitx0/disp_cap > /storage/.config/disp_cap
It will save the tv’s resolution list to your config folder so next time it will not ask your tv, but will use the copied list. If the problem relies on here then it could help.
You can also edit it with:
nano /storage/.config/disp_cap
to make sure nothing unsupported remained in it
Edit:
You can also make that file with nano from scratch just write the supported resolutions from the following list:
480p60hz
576p50hz
720p60hz
1080i60hz
1080p60hz
720p50hz
1080i50hz
1080p30hz
1080p50hz
1080p25hz
1080p24hz

I have similar problem … so far I was using HD LCD on 1920x1080 and no problems. Then I have switched the TV to the 4K OLED, got the CoreElec on GT1 ultimate (fake 3GB so 2GB for real), it turned as usual with the previous resolution being set - 1920x1080. I have set the resolution to 4K, played some 4K HDR video for the first time for some 30 minutes, everything was fine. Then, on the following restart, I got the next problem - CoreElec starts up, so I see the logo on my HDMI2 channel, but just when the Kodi is about to appear, there is no image on the TV and TV dismisses the input. I can access at the same time to the CoreElec over ssh, so it is there and alive, yet something between GT1 and TV is not fine. I have tried to restart whole system, yet there was no improvement.

So my idea (if there is no any better) is to restore somehow remotely (over ssh if possible) to 1920x1080 again, or please advice if there is a better solution.

Thanks

Edit: I have continued to Google and found out the solution - I have edited guisettings.xml under /storage/.kodi/userdata, restarted the unit, so gui appeared, then I have switched back in the settings from kodi gui output to 1920x1080 and everything went fine. My mistake is that I have ever switched kodio gui resolution to the other than 1920x1080, as I read it should be no swithed, as the Kodi will automatically change the output to the desired video resolution, automatically.

Sorry to revive this old 3ad, but since my (poor) 4K TV died, I`m trying an old Philips 42PF3321/10 (plasma) TV that lied in a friend s cellar.
note: I never had a plasma in the past, so I have to say: what nice colors (expecially blacks) !

According to this official PDF its panel is 852x480p resolution, but supported inputs confuses me a bit…
I have tested some different resolutions (@60Hz) under CE and the best fitting seems to be 1366x720p but it s officially unsupported.
Now I`m going to try native one by adding it in the disp_cap file, the question is: do you think that my S912 box support it ? About refresh: seems that this TV supports 75Hz, should I try it ?

Thanks in advance to any suggestion.

According to the PDF the TV supports

• Video Formats
Resolution Refresh rate
640 x 480p 2Fh
720 x 576p 2Fh
1280 x 720p 3Fh
1920 x 1080i 2Fh

So what are you trying to adjust and why ?
What happens with standard settings ?

Well, seems that @ higher resolution (1080p@60Hz) it “shutters” a bit, so I wanna feed it with the best resolution/refresh.

…what does 2/3Fh mean ? Does CE supports this type of refresh rate ?

Anyway, since the panel is just 852x480p, what resolution (and refresh) do you suggest to put into disp_cap file ?

About | FAQ | Terms of Service | Privacy Policy | Legal Notice