Bl301 injection, problems, help,

Guys, it seems my N5MAX (905X3 box) with 9.2.2 stable does not power off completely (the led keeps light on blue but no network traffic and I am unable to power it off again just with power cicrcle) neither from kodi or remote (KEY_POWER) nor from terminal (shutdown command). So I tried the bl301 injection by inject_bl30. It seems was successfull:

update-bl301.log (https://naga.manoo.hu/nextcloud/index.php/s/MLECnC4K6ab2fsQ)

But nothing happened - no sleep, no wakeup. The config ini was set correctly:

/flash/config.ini (https://naga.manoo.hu/nextcloud/index.php/s/M8z4rCwkL9bbbEb)

and it seems dmesg says nothing:

output of dmesg (https://naga.manoo.hu/nextcloud/index.php/s/6SCX6o8RY6Wkxaa).

and the whole debug is in ix.io: http://ix.io/2ifP

Do you have an idea?

thanks!

manoo

What’s the output of the IR remote by this guide?

It says “Custom”

I don’t know what you mean. Make a log of your SSH connection.

sorry. I mean the IR Remote Power Coda says ‘Custom’. Maybe you mean this?

remotewakeup=‘0xbf40fe01’
decode_type=‘0x0’
remotewakeupmask=‘0xffffffff’

the output is:

N5MAX:~ # ir-keytable -u
Protocols changed to irmp
Waiting for IRMP decode event. Please, press CTRL-C to abort.
Received IRMP code: remotewakeup=‘0xbf40fe01’, decode_type=‘0x0’, remotewakeupmask=‘0xffffffff’
Received IRMP code: remotewakeup=‘0xbf40fe01’, decode_type=‘0x0’, remotewakeupmask=‘0xffffffff’

If it then it’s not working I would need a UART log.
The injection was successful and the IR code got injected too.

dmesg doesn’t show the bl301 prints. If you have no UART you can take a look to this one: CoreELEC Team SDIO Debug Board

Hi Portisch,
sorry if this is a noob question.
I’ve used the embedded feature of bl301 injection and ir code mod that you added to CoreELEC-9.2.2.
I’m running on a Beelink GT King (rev A) and using a Minix A2 lite remote with it instead of the standard remote.
By choosing “Minix” in the IR code list, I thought that the box would answer to IR code sent (such as power on/off) but it is not the case. Am I missing something ?

FYI, the Minix A2 lite remote is using a wireless dongle connection for most of its code, except the power button that triggers IR code to be sent. This code is understood by Minix box.

edit:
my /flash/config.ini has
remotewakeup=‘0xe718fe01’

and ``ir-keytable -u```` returns
Received IRMP code: remotewakeup=‘0xe718fe01’, decode_type=‘0x0’, remotewakeupmask=‘0xffffffff’`when I push the power button of the remote

Just tested here with Minix A2 Lite and Minx NEO T5, working without problems on 9.2.2.

My question was more about knowing if he bl301 injection and the IR code MINIX allowed for controlling a non-minix box.

I was just lucky and had the NEO T5 connected what have bl301 injected. Who will deny the wake up by Minix IR code on any box?

ok, then I have an issue with my box, I will investigate and report back. thanks for your help.

Hi, updated to 9.2.2 on my Odroid N2. All working well except I now have this inject BL301 thing running and it leaves a log in my storage directory stating my device is not supported. I have no need for this, everything was working fine before. How can I disable it? Can’t find any controls and if I run inject_bl301 from an ssh session it says my device is not supported, thanks.

No need to run inject_bl301 for N2

I understand that, as I said I have no need for it. I can see it’s running on startup since I see an HK logo on startup (dislike that) and it’s leaving a log. I want to disable it, preferably uninstall it. How can I do that?

When you don’t like then just ignore it and disable any option in config.ini!?

Also you need to disable the service:
systemctl mask update-bl301.service

Then you need to compile your own version and unset this linux config value:

Not sure I understand. So is there a way I can tell it not to run without actually rebuilding the whole thing? Compiling my own version is not something I can do. Thanks.

Let me reiterate that last comment, I don’t really care if it runs or not, I just want to disable the HardKernel splash screen on startup and tell it not to create a log in the root of my storage directory.

If that’s not something I can do without a recompile I won’t worry about it. I’m just asking if there’s any controls for that. I’ve been setting my options in config.ini all along so no problem for me to continue doing that.

Why ?
I don´t understand the problem ?

2 Likes

I never used inject_bl301 on my N2 as it’s not needed. Did you ever use/run it in spite of that ?
In your case, I’d make a full backup -> new/fresh install -> restore backup, to solve this problem.

HK logo is used across all OS images, Petitboot, Ubuntu, Android…, and I’m glad that it found it’s way to CE. If you don’t like it you can replace it with one you like, or remove it…

About | FAQ | Terms of Service | Privacy Policy | Legal Notice