Bl301 injection, problems, help,

Your device is GXM S912 and not supported by injection.

I already solved, thanks

You’re welcome! Can you tell us how did you do it? Which method did you try? Card, shorting pins, AML flashing tools?

To update the bootloader of the Bqeel M9C Max box (S905x_2 / 16) (gxl_p212_2g.dtb) and be able to use bl301-injection; I flash atvX_p212_Oreo with aml-linux-usb-burn putting the box in amlogic mode by cutting pin # 30 of the Nand memory footprint.
Then I had problems when I wanted to use ceemmc -xv, it gave me an error for not finding the dtb partitions and there if I had to put atvXperience_v4_S905X_RT_BCM.
I also ran into the [usb_download] problem (Bqeel M9C Max - USB OTG port not working) but I was able to solve it without problems. Thanks to this great community.

1 Like

@Portisch I have a question: which software component is in charge to load the bl301 with config.txt settings (namely the remotewakeup code)? Is it the kernel, or some user space application?

The user data is injected by the tool inject_bl301 itself as it maybe require decrypt/encrypt of the bootloader blobs. It get checked on every boot if the checksum of the blob is changed. If yes do automatic a new injection.

Hi guys, I’ve done an inject_bl301 on my X96 (S905X) running 19.1-Matrix_rc4 with Aidan’s Android TV 7.1.2 bootloader. I wanted to be able to turn on the box by CEC and use CEC also on other HDMI sources.

That’s all working now but a new problem has come up: the USB ports will not power off when the box shuts down so my USB amplifier doesn’t turn off. I’ve tried setting usbpower=0 on config.ini but no change, I guess that’s not supported on my box.

Is there any other way to power off the USB ports? I guess it should be possible as it is with the other bootloader. Thanks for any help.

Pay attention to this usb issues

But I am not sure anymore if this apply for GXL. Maybe only for newer devices.

Thanks, I’ll try that script, I’ll see if it does the trick under shutdown.sh

EDIT: I’ve tried the script but no change.

I don’t have the USB power and WoL options under the CE hardware settings, just the Inject BL301 and the IR remote power code. I didn’t mention that as I thought the option would set the usbpower=0 on config.ini which I did via the CLI, but maybe that’s not the case? I also read on a thread that those options are only available on nightly, is that still true? Or are they just not supported for GXL? If the hardware supports them it would be great if they could be added in a future release.

Did you perform reboot twice?

Yes, I rebooted various times. I think (but I may be wrong) that the USB ports powering down when the box shuts down has more to do with the bootloader than the dtb.img that the script reconfigures.

The box’s original bootloader and the one from Aidan’s ROM have my preferred behaviour, others may want the USB ports to remain powered on if they use them for a hard disk, maybe that’s why CE’s enhanced bootloader does that. It would be great if a switch could be added in a future release also for GXL.

Just to say it work with T95 Max Plus 4/32 CE 9.2 ng Nightly

Better later than never. I bought another TX3 with new bootloader, the one that ended in soft brick with older bl301. With the latest one, it works ok

Thanks, bye

@Portisch now that things have settled down with the latest CE updates, would it be possible to check if a switch to turn off power to the USB ports at shutdown could be added to the CE hardware settings for GXL devices?

It’d be great to have this working, it’s the very last thing left for my GXL boxes to reach perfection :smiley:

I don’t think so. GXL is just to customized and it may break other devices.
Also the USB power may connected to the SoC VCC so it cannot be powered when power down.

OK. Do you know what the USB power off setting does on the newer boxes? Does it set usbpower=0 on config.ini? That I tried manually and it didn’t work, if that’s what it does then maybe the USB power is connected to the SoC VCC. If it does something else I can try to do it manually.

No, when implemented you need to know the grill number. You can enter the bootloader console and just try all gpios and measure if it is possible or not.

OK, that I wouldn’t be able to do so I hope that at some point in the future team CoreELEC will try to add this for GXL.

hi,can you provied the p211 dtb for me?

About | FAQ | Terms of Service | Privacy Policy | Legal Notice