Bl301 injection, problems, help,

Hi, i’m having trouble trying to configure remotewakeup with a sony remote, “ir-keytable -u” returns:
#Received IRMP code: scancode = ‘0x00950000’, IRMP protocol = 1, decode_type is undefined!
#Received IRMP code: scancode = ‘0xffffffff’, IRMP protocol = 1, decode_type is undefined!
Some help in this regard …
Thanks.

Congratulations! You are the first one hit this message!

If irmp can not decode it the bootloader will also not be able to. Maybe the easiest is to try another button or remote.

EDIT:
You can try to post your debug to be able to check what protocol it is:

echo 2 > /sys/module/rc_core/parameters/debug

Then press the button on the IR remote, like 3 times every second short press and upload your dmesg:

dmesg | paste

It is interesting because it is the Sony remote control that I am using in my TVbox right now.

Following your recommendation I changed the remote control, now I have one from a Samsung soundbar, but it is not recognized with ir-keytable, even though the protocol is Samsung36 and I see that the protocol is in:

"/usr/lib/udev/rc_keymaps/protocols/samsung36.o "

Despite the above, it returns the following error:

"CoreELEC: ~ # ir-keytable -p all -t
/sys/class/rc/rc0//protocols: Invalid argument
failed to create a map: 22 Invalid argument
Testing events. Please, press CTRL-C to abort. "

Just enable debugging and press the remote button. Then upload dmesg.

When IRMP can not decode it it is for sure ir-keytable can not decode it.

By your logic, does that make the CoreELEC Devs “pirates” then?
They repackaged Linux and Kodi, called it CoreELEC and changed all the splash screens and logos.That’s kinda the point of open-source software - you’re allowed to do that!

I just managed to change the splash screen really easily. I remounted the flash partition as writable, copied my own splash file named oemsplash.png to /flash and then set the flash back to read only mode.

To stop the old splash showing for a second time, I added <splash>false</splash> to advancedsettings.xml

Job done! The only part I haven’t worked out how to change yet is the “Aidens Custom Android TV” splash screen that shows when I first turn the box on. I’m not sure that can be done without flashing a new Android ROM (and finding that one was hard enough!)

What you may not be aware of is that not all of Coreelec is open source.

People can still compile the sources to make an image and they should not really care much at all that they cannot change one minor aspect of a build.

One of the other general principles of open source is that people should be able to get recognition for the parts of the work that they create and contribute to, so if they were to want to lock down the splash screen, it would be entirely reasonable.

1 Like

Well thankfully they haven’t. Although many people think it isn’t possible to change the boot screen (as discussed on several threads in this forum), it is actually quite simple:

  1. Create your image as a 1920x1080 png file, call it splash.png
  2. Copy your image to the downloads folder (/storage/downloads)
  3. SSH to the box and type:
    mount -o remount,rw /flash
    cp /storage/downloads/splash.png /flash/oemsplash.png
    mount -o remount,ro /flash
  4. Add this line to advancedsettings.xml (in userdata folder):
    <splash>false</splash>
  5. Reboot the CoreELEC box

I get what you’re saying about crediting people for their work but I could also point out that CoreELEC have replaced ALL of the Kodi logos with their own. The only place you’ll actually see Kodi mentioned is on the name of the default repo. Everywhere else, the Kodi name has been erased from existence.

Just fyi, we were asked to change that by Team Kodi. And the information about changing splash is all over the forum. And finally our main concern is the fully loaded piracy devices that are sold everywhere.
We only exist because of our love for kodi, we don’t run away from it, we embrace it.
Just one more thing, leave the confrontational tone out of the forum please.

If I came across as confrontational, I apologise, that was never my intention. I was just making the point that end-users changing the splash screen is no worse than changing the Kodi logos.

As for “fully-loaded” boxes, I completely agree. It’s those boxes that have given Kodi a bad name and it’s probably why many of the mainstream services haven’t embraced it and developed their own addons. Some, Netflix for example, have actively blocked Kodi from including addons in the official repo. My guess would be that the reason for that is the association that people unfairly percieve between Kodi and piracy

so probably it was broken somewhere a long long time ago on my transpeed plus s905x3. i have two identical boxes running coreelec. one device can successfully inject bl301 and remove it. another box has the inject bl301 option under the coreelec settings menu already checked. if I try to restore the original bootloader, it does nothing and reverts back to checked state. I noticed that my /flash did not have any backup of the original bl. I was able to copy the bl from the other box that is working but even after copying the bl into /flash (after remounting it as rw), I still cannot inject bl301. at this point, it is really difficult to reflash the stock ROM into this box as I cannot find the stock firmware to begin with. any tips on how I may restore bl301 injection?

Edit. noticed that the bl301 backup in /flash uses the device serial # that’s different from the box that’s having the issue and so after changing the filename of the bl301 backup in /flash I was able to fix the issue. though, i advise doing this as the last resort as I was lucky to have two identical boxes and it seems bl301 backup can be used across the same device despite having different device serial #s.

Maybe your boxes have different rev. of SOC ?
What are the first four digits of the S/N?

2b0c. the restoration worked fine. I think I enabled bl301 injection a long time ago and then somehow lost the backup in /flash hence I could not revert back to the original state. Anyway, using the bl from the same box, I was able to revert to the original bl and then reinject bl301.

Unfortunately, it looks like CEC wake up isn’t even available and when I turn my TV while the device is in sleep mode, the device does not wake up. It goes to the sleep mode well when I turn my TV off via CEC.

EDIT: learned that I needed to enable wake up features from the CEC settings itself, not within CoreELEC configurator. Things seem to be generally working now.

I’ve setup a new SD Card for my X96 Air and can no longer power on the box with the remote. I’ve just updated the config.ini with the correct power code (taken off my old SD card backup), but after a few reboots and power offs it doesn’t seem to have taken? Any ideas? I’ve tried disabling the injection in the settings so I could reboot and turn it back on again to maybe force it to update, but it doesn’t seem to disable, I do continue on the warning but it stays enabled. Either way I have to keep pulling the power which isn’t ideal.
Any ideas? thanks