Bl301 injection, problems, help,

Let me reiterate that last comment, I don’t really care if it runs or not, I just want to disable the HardKernel splash screen on startup and tell it not to create a log in the root of my storage directory.

If that’s not something I can do without a recompile I won’t worry about it. I’m just asking if there’s any controls for that. I’ve been setting my options in config.ini all along so no problem for me to continue doing that.

Why ?
I don´t understand the problem ?


I never used inject_bl301 on my N2 as it’s not needed. Did you ever use/run it in spite of that ?
In your case, I’d make a full backup -> new/fresh install -> restore backup, to solve this problem.

HK logo is used across all OS images, Petitboot, Ubuntu, Android…, and I’m glad that it found it’s way to CE. If you don’t like it you can replace it with one you like, or remove it…

Thanks, how can I remove that splash screen (yeah I really don’t like it)?

Any way to stop that inject_bl301 log from appearing in the root of my storage directory?. I’d be happy it there was a way to put into the logs subdirectory. I put my own stuff in the root of storage and I don’t want any junk in there, especially a log file that provides no information other than to say, “sorry, I can’t run.”

I told you already…

Several ways; replace “boot-logo-1080.bmp.gz” from 9.2.2 with the one from 9.1.1, or make your own 1080.bmp compress it to .gz, or put an empty file for “boot-logo-1080.bmp.gz” or simply delete it…

The splash screens are locked down to prevent pirates repackaging CE.


HardKernel splash screen (the first one shown) is NOT locked. Only CE splash is hardcoded.

This is my N2 background:
boot-logo-1080.bmp.gz (1.5 MB)

It is very hard to see… :slight_smile:

Will use yours for background for present HK logo to see how it looks :slight_smile:
Something like this:
boot-logo-1080_1.bmp (5.9 MB)

1 Like

Thank you!!! HardKernel splash is gone. Now any way to get inject_bl301 to stop putting that log in the root of the storage directory (without rebuilding CoreELEC)?

Run this command in console

systemctl mask update-bl301.service

and disable functionality in CoreELEC settings, Hardware, Power, Inject BL301 blob.

That was actually the first place I looked for controls after the update. I seen no Inject BL301 blob service disable settings there. I just see the added options to control things like USB power and CEC.

Then maybe there are some other settings which forces bl301 inject.

I’m confused by this. It seems the team merged inject BL301 into the main distribution, but didn’t include all the controls. According to the guide it should be possible to enable and disable the service, but I don’t see any controls for that. I do see the options to control various functions, but none to control the service itself.

Have a look at Coreelec settings, You will find it under programs

The log file you are trying to remove is created from CE settings addon. Service you already disabled.
Can you make screenshot of your Hardware page in CE settings addon?

I can’ find any place in the CoreELEC Settings to turn on or off Inject BL301Blob as shown in the guide here; CoreELEC BL301 Wake-Up feature [inject_bl301]

I don’t know, is that option supposed to be there with this new update or is there something wrong with my installation?

Thanks, yeah I’ll do that as soon as I have access. I’ve been kicked off the box since my wife is using it right now.

Really strange to me the option to enable and disable inject BL301 appears in hardware settings as shown in the guide, but I don’t see it after doing this update.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice