Bluetooth remote mapping?

I’ve read a bit bout the remotes and seems like many are against the Bluetooth option. Setup an ir remote the other day. However I have a shield tv remote sitting here. Can pair it and worked for what I briefly tried it for, except the back button. Is there a way to map that or switch to a different remote config? If there is a remote config, any idea which one? Been through the repo but not certain it does me any good for a Bluetooth remote. Also tried the kodi mapping add on. It gets a code from other buttons, but the back button doesn’t seem to read. Did it last weekend so not sure I remember that outcome fully. Also if it matters using an odroid-c4.

Also the gf’s PIA dog ate the IR remote i configured. Have some old mce remotes or some basic harmony remotes if it comes to it.

Would like a way to effectively use the Bluetooth remotes cause I am trying to get away from fire sticks(absolutely hate the internet requirement) and could use those remotes possibly on the rest of the odroids I’d buy.

Ps if the odroid-c4’s are known problems, a heads up would be appreciated.

Thanks in advance for any input.



Thanks for the info. I had time to look at it today and it’s actually the middle button on the shield remote that doesn’t work. Everything else works as intended so far. Global>Navigation>Select Item Gets code (16838168) but doesn’t select. Used a diff button but nothing “selects”. Kodi keymap editor adds the following to .kodi/userdata/keymaps/gen.xml: Mapped middle button to different action outside of global and it works for that. Also tried different buttons on remote to the “select item” option under global and doesn’t work.

.kodi/userdata/keymaps/gen.xml
select

However still does nothing.

dmesg | grep -i rem

[ 0.881602@3] bl301_manager: IR remote wake-up code: 0x23dc4db2
[ 0.881604@3] bl301_manager: IR remote wake-up code mask: 0xffffffff
[ 0.881606@3] bl301_manager: IR remote wake-up code protocol: 0x0
[ 17.489763@2] lirc_dev: IR Remote Control driver registered, major 499
[ 816.956950@3] input: NVIDIA SHIELD Remote as /devices/virtual/misc/uhid/0005:0955:7217.0004/input/input9
[ 816.958342@3] hid-generic 0005:0955:7217.0004: input,hidraw3: BLUETOOTH HID v0.02 Gamepad [NVIDIA SHIELD Remote] on 54:C9:DF:5B:03:29

Should I be looking into gamepad or possibly joystick .xml file instead?

Can you give me make and model?

I’m familiar with the MX3 Air Mouse which is a shield remote.

Its the nvidia shield tv remote. Not sure the actual model number. Its the newer triangle one.

When you say middle button, you mean button #5?

image

That would be correct. 5

Tailing the log after pressing the button I get the following if it means anything that I’m not aware of, but the obc- is a different number I notice.

2020-11-07 05:38:35.472 T:4060308048 DEBUG: GetActionCode: Trying Hardy keycode for 0xf200
2020-11-07 05:38:35.472 T:4060308048 DEBUG: Previous line repeats 1 times.
2020-11-07 05:38:35.472 T:4060308048 DEBUG: HandleKey: long-0 (0x100f200, obc-16838913) pressed, action is
2020-11-07 05:38:35.555 T:4060308048 DEBUG: Keyboard: scancode: 0x00, sym: 0x0000, unicode: 0x0000, modifier: 0x0

Not sure I am following this article right, but found something similar I think. I then tried to map the 0xf200 to something.

gen.xml
selecthighlight

But that hasn’t fixed it and tail has the same lines as above and doesn’t work.

Could you enable debug logging, press key #5 a few times, then send me the log?

0xf200 means Kodi doesn’t know what command to assign the signal to. I will need the entire log not just the tail to see if I can find a solution.

Thanks

I can.

Thanks for the help btw.

https://drive.google.com/file/d/1e9rrZvWvT04q2VdqD9J9jkKyoW-knpJz/view?usp=sharing

Try this:

<?xml version="1.0"?>
<keymap>
  <global>
    <keyboard>
     <universalremote>
      <obc16838913>Select</obc16838913>
     </universalremote>      
    </keyboard>
  </global>
</keymap>

To be certain, we’re saying to replace /storage/.kodi/userdata/keymaps/gen.xml with only the above?

If so, that didn’t work unfortunately. Still seeing the 0xf200 in the log.

https://drive.google.com/file/d/1oDuqXFGgmHWpL2ITniqWSXZhJZKtHspl/view?usp=sharing

.kodi/userdata\keymaps\keyboard.xml

Renamed to keyboard.xml instead of the gen.xml file that “keymap editor” add-on names it. However, get the same Trying Hardy keycode for 0xf200 business as before. Should I just get a different compatible remote, or is there anything else you think that would help?

It was a long shot but still… Sorry it didn’t work.

The USB WiFi and Bluetooth remotes are really touch and go. I stopped trying to figure them out a long time ago.

The remotes I use on my testbed are those of which I know from experience to be working the most reliable:

MX3 2.4G - Wireless Double-Faced Remote Control Keyboard/Air Mouse/Voice
Logitech Harmony 665 - Advanced Remote Control
Flirc USB - Programable USB Adapter (last resort)

Thanks again though.

It’s funny you mention the harmony 665. I just remembered I had a couple earlier and was going to give them a try as I was thinking how much a pia this shield remote has been. Any recommendations or links to make that work quickly/better?

also

Works like a charm. Idk about you, but I’m kind of a fan of the more buttons as to the less is more logic any way.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.