Logitech Harmony Setup

I have CE 8.90.4 running on my Odroid-C2, and now have to setup my Logitech Harmony 950 (IR only!), to get it working.
Preferred solution would be to work out-of-box without need for editing CE Remote files / Harmony Keymaps :star_struck:
Anyone has a hint which Manufacturer/Device to choose within Harmony Database?

I also use CoreELEC 8.90.4 on my Odroid-C2 and I use Microsoft Media Center IR remote (bought more than a decade ago) with it. I don’t need to add any remote files on the Odroid-C2. It just works right out-of-box. Therefore, I believe you can program your Logitec Harmony as Microsoft Media Center remote.

I use same coreelec version but on a Vorke S912. I setup the Harmony as a Mecool Kiii pro and it worked out of the box, no modifications.

I setup harmony as mecool kiii pro instead of my actual vorke because it has more kodi specific buttons, like “info”

Same for me; my old Harmony 525 works great programed as “Microsoft Media Center Remote”.

I asked them to add the Khadas VIM2 device to their database,
And they are truly added.
So try asking them to add your device to their database as well.
They have excellent service.

https://community.logitech.com/s/topic/0TO31000000UKNpGAO/remotes-and-smart-home

Please could you explain how you did this?

I assume,you select the Mecool KIII in the harmony database, then you stop kodi via ssh etc & press the buttons on the harmony to get the scancodes?

then you create the keymap file?

I have tried this but using the Pivos xios from the harmony database, but although I can see scancodes, only a couple of the buttons work.

I have a H96 Pro. the basic remote works, so I am just editing this, with the scancodes i get.

for example, ok 0x2bdce do I use the full code or the last two?

What am I missing?

No, my suggestion is different from what you are trying to do with the Pivos.

Step 1: add device in harmony manufacturer: “mecool”, model “kiii PRO”
Step :2 do nothing, its supposed to just work

I have added the KIII as you have done, but it doesn’t work on my H96 Pro.

I somehow need to convert the key presses to something the H96 Pro recognises.

The alfawise H96 Pro plus is in the harmony database, but that only has the same buttons as the original remote.

Hmm, it really worked for me without anything else. I have a Vorke Z6, and after I installed Coreelec, I setup the Harmony as a Odroid, and as a Mecool Kiii, and a Mecool M8s, and other and surprisingly they were all just working out of the box.

My thoughts on what you could try:

  1. First, I said “Mecool Kiii Pro”, not just “Mecool Kiii” - make sure you included the “Pro”

  2. It’s possible that all buttons work except the Power button - sometimes that’s more difficult. Try switching it on using the original remote control’s Power button, and then checking if the other buttons work using the Harmony

  3. Finally, make sure you used the correct dtb file. I see dozens of posts where people are having trouble with their devices because they used the wrong dtb.
    Good luck

Thanks, I had to delete the cfg & keymap files. Then added the Mecool KIII Pro to the harmony.

Works well, & as you say more buttons. :grinning:

I tried the Mecool KIII pro suggestion for my Harmony One to control my Mecool M8S Pro L. I only have one activity - Watch TV. I added the Mecool KIII Pro as a device that was used for the activity of Watch TV. The only buttons I had to change were Volume Up/Down and Mute which I had to Map to the other device being my Panasonic TV. Everything else worked. One strange thing was that MyHarmony app recognised the KIII Pro but then named it as Mecool DVR. Anyway, it worked. Thanks for the tip.

I’m hoping someone might be able to help me, my question is a bit too specific.

I have Vorke Z6 S912 box, with CE 8.95 and controlling it with a Harmony Remote (set-up as a Mecool KIII Pro).

The remote works absolutely perfectly… almost… with only one small thing that annoys me:

  • Let’s say I’m browsing a list of videos.
  • If I quickly click (for example) down 3 times, I hear the GUI sound click 3 times, but the cursor only moves down maybe 1 or 2 of the 3 times.

I’m surprised that I hear the GUI actually make 3 clicks, but the response is only 1 or 2 movements. So the signal is received 3 times, but not all of them cause a response?

I suspect it’s either an advanced HArmony Remote setting, or an advanced CE setting that has to do with response times? I’ve read many different posts on remotes but I don’t feel that anything was exactly what I need - I was hoping someone might know?

btw I have found that the NEC IR in these boxes can use the harmony ‘windows media center’ device on harmony. I added ‘Microsoft Windows Media Center’ as a Device and then used the ‘rc6_mce’ rc_keymaps
that way you have many more keys available!

1 Like

The Logitech Harmony remote is supported out of the box and no configuration is needed.

Add the following device in MyHarmony.

Press yes when prompted.

You can alter the input delay settings to make your remote more responsive as below.

and by adding the following commands to /storage/.config/autostart.sh

ir-ctl -t 50000
ir-keytable -D 375 -P 100

If your remote is not working then check if /storage/.config/rc_maps.cfg exists on your device and if so delete it and reboot and then your remote should work.

I took the easy way out on my Harmony 650. Bought a $20 FLIRC USB dongle from Amazon, loaded the Kodi profiel on it and paired my Harmony to it. Done. Beauty is I can use the FLIRC interface to map functions to the remote and vice versa with Harmony software. Basically acts like a keyboard paired to the Harmony.

@anon88919003 Does CE support Power-On or Wake-Up with the Odroid C2 using a Logitech Harmony remote?

What I did with my Logitech Harmony is what adamg said, but the Power On button didn’t work (I have a Vorke Z6 S912).

So i also added the Vorke Z6 original remote as a device into the Harmony. I set it up so that all buttons respond the the Windows Media Center, EXCEPT the Power On button. That comes from the Vorke Z6 device.

Thanks @nd299! I set up all the buttons except for the power button to the MCE device in Harmony and added a HardKernel device just so it can send the power on and power off signal.

My Odroid shutsdown and powers on perfectly now!

Is this process still valid for the setup a Logitech Harmony Remote? I have tried without success.

I have a Beelink Mini MXIII II working fine with the supplied remote.
I wish to use my Logitech Harmony too?
Should I be changing the /storage/.config/autostart.sh or the /storage/.config/rc_maps.cfg?

I also tried and failed configuring both with the MECOOL Mecool Kiii Pro profile, which didn’t work either.

echo "meson-ir * mecool" > /storage/.config/rc_maps.cfg

No changes are necessary to autostart.sh to use Harmony Remote setup as Mecool KIII Pro. It is already supported by CE (so ensure you have no other remote configuration files present to interfere with correct operation). If you are dual booting Android and wish the same remote setup to work, then some changes are necessary in Android (they differ depending on the Android version, pre-Android 7 is simply replacing remote.conf, later versions more of a PITA)

About | FAQ | Terms of Service | Privacy Policy | Legal Notice