Boot issue with X96 Max Plus Q2 4G/32G/1000M (stock firmware 20201209-1446)

I got a X96 Max Plus 4GB/32GB/1000M yesterday (from geekbuying).

Stock firmware is “X96Max_Plus_Q2_20201209-1446”, device name is “X96Max_Plus_Q2” (according to Android “About Phone”).

I tried to boot 19.1-Matrix_rc2 from SD card, no luck so far: Depending on the boot method, I end up in the Android Recovery console, or the boot hangs with a black screen or with the X96 logo shown. I never saw any CoreElec boot logo, so obviously it got stuck very early.

I tried a whole range of DTBs, to accomodate for fake hardware, e.g.:

  • sm1_s905x3_4g_1gbit.dtb
  • sm1_s905x3_2g_1gbit.dtb
  • sm1_s905x3_2g.dtb
  • sm1_s905x3_odroid_c4.dtb
  • g12a_s905x2_2g_1gbit.dtb

None of them had any effect.

After the tests I verified that the card was okay by booting with an X96 mini (using gxl_p281_1g.dtb). That worked fine, as usual.

How I tried to boot:

  1. Power off, insert card, power on with holding the reset button in AV port with a toothstick. I held the button pressed until the end. First the X96 logo showed up, then I ended in the “Android Recovery” console.
  2. In the Android Recovery console, when I “Reboot to bootloader”, I end up with the X96 logo. It hangs there.
  3. I also tried to press the reset button during power on only for a few seconds. Made no difference, again in “Android Recovery”.
  4. Furthermore, I installed the “Reboot to LibreELEC” apk (version 4.0) and tried to boot from there. Boot got stuck as well, with a empty black screen.
  5. I used the “Update” app, selected some zip file and started the update. This got me into the “Android Recovery” console again.

Again, stock firmware is


Android Recovery says:


AIDA64 and “Fake Device Test” didn’t give me any clue that the hardware is fake, so at the moment I think it’s indeed a S905X3 with 4GB and 32GB. A speed test showed an downstream of 250 MBit/s, so it’s pretty sure indeed a 1GB ethernet interface as well.

I haven seen this firmware version 1446 from 9. December 2020 mentioned in this forum. Only references I found so far were from Slimbox. It sounds like it’s possible to burn a Slimbox firmware on a Max+ Q2 box with this firmware.

I haven’t tried yet.

Next time do not buy cheap chinese devices from geekbuying.

Lesson learned…

I beg to differ: Lesson learned

In fact I bought this box fully conscious that getting it to work might be an adventure and even impossible. Bought it for fun, one might say.

Furthermore, I think the information I gave might help other ones to evaluate the risk of doing such a deal.

@Portisch, I wonder whether the SDIO board might help me debugging what’s going on here?

We have some more users with this type of hardware working fine with last rc4 release.

You can try to recover Android completely by Burncardmaker and when Android boots up again start again to get CE running on uSD or USB.

It looks like the UART header is next to the HDMI port (4pin). So you can open the device and connect a TTL UART converter if you need to.

Strange, the box fails to pick up the firmware from the uSD.

I used Burncardmaker 2.0.2, tried two different uSD cards and two different firmware images (X96Max_Plus2_20200901-1005.img and X96Max_Plus_Q2_20201209-1446.img).

When I insert the uSD card and power on the box, the box simply boots into normal operation, without attempting a firmware upgrade.

I also tried and pushed the reset button while powering on. In this case the box boots into Android Recovery console. Just as with the CoreELEC image inserted.

The SD card slot works otherwise, I was able to read from another uSD card from within Android.

It looks like the box ignores any uSD card while booting.

I have a X96 Max Plus Q2 4G/32G/gbe device, too. I bought it from Taobao.
Boot using “sm1_s905x3_4g_1gbit.dtb” is successful on CoreELEC 19, except Wifi & BT not supported. It was in March. In 20210419 nightly build, Wifi & BT are working. The CE team added the driver. Thanx to them.
I can assure you CoreELEC 19 is working on the device, despite some minor issues.
My advice is try another SD card or use a external card reader. I have two SD cards, one is 4GB, the other is 8GB. the former works on X96 internal card reader, while the later only boot on external card reader.

I bought X96Max plus.Chips used as s905x4.The file cannot be used.Coreelec. You have to wait for the files to support it.

Thanks for that hint. I tried to reboot from my two prepared uSD cards (16GB and 32GB) with an external reader as well. Firmware upgrade doesn’t start, once again a normal reboot into Android only.

OTOH, from within Android, the two cards can be read without any problems. With the internal reader as well as with an external. I can see the aml_sdc_burn.UBOOT file, the aml_sdc_burn.ini and the img file as well.

I have no doubts for that.

It’s only that I don’t manage to get CE to boot nor to install another Android firmware using the uSD method.

I guess I’ll have to try and upgrade the firmware via USB.

I’m pretty sure that my box has a S905X3, as it was sold. AIDA show a CPU Clock Range of “100-1908 MHz” (X4 should go up to 2000 MHz), a CPU Revision “r1p0” (which ought to be an X3) and an Android API Level 28 (X4 should use 29).

Mine stock firmware seems the same with yours. This is a screenshot from “Device Info HW” which is available from Google Play Store.

Success! I successfully downgraded the firmware using AML USB Burning Tool to the version that’s linked on the product page on Geekbuying (“X96Max_Plus2_20200901-1005”).

After this firmware downgrade is was able to boot CE from uSD using the toothpick reboot. Using CoreELEC 19.1-Matrix_rc4, everything seems to work, including WIFI (tested) and Bluetooth (listed, but not tested).

I’ll try to upgrade back to 20201209-1446 and try whether I’m able to boot into CE from this version after this down- und upgrade.

You use Aml burning tool .You have to use License File Or not?How do you do the program?thank.

Not sure what you mean: In the end I more or less followed the information about Firmware updates for the box that GeekBuying has on their product page. This article contained links to the firmware and the burning tool: X96 MAX Plus Amlogic S905x3 Android 9.0 8K Video Decode TV Box 2.4G+5.8G WiFi Bluetooth 1000Mbps LAN Firmware Updated 20190625 -

I can install the old firmware.But the machine does not turn on.Can’t do anything at all.Wait a long time for the logo to hold.Pressing the reset button has no effect.What should I do?Now brick Four machines already. Thank you.

Its because you are using a Image of 2GB on a 4GB box or 4Gb on 2GB box, that can happen.

You need to find the right firmware for the box. Once you have the correct firmware you will be able to flash it but you need to leave the usb cable connect like 10 min and the box will connect to USB burner and flash again the correct fimrware.

Its not clear what is your status right now but because i have the same machine i can confirm that CoreElec works if is booted from a USB stick on the the USB 3.0 port using the previous to last nightly build and the * sm1_s905x3_4g_1gbit.dtb
Because nightlies get frequent updates if the nightly you picked doesn’t work just keep going back a version till you pick the right one…if you need more help post here to look what is my exact version.
Everything else than CoreElec just doesn’t work.
All the above work on X96Max_Plus_Q2_20201209-1446 (4/64)
I am curious what is exactly the “previous” firmware and where you got it…and ofcourse if it works as it should.


Im using this one :stuck_out_tongue:


Hi all got one of these 4gb/32gb and had a terrible time trying to put CE on sd card. Anyway just to say as a few have said the card slot doesnt work. It doesnt !!
I used a usb drive in the usb 3 drive and it works a treat.
It wont boot properly when you have anything attached to the usb2 slot (HDD on mine). But will when its removed.
I am going to try installing on box internal memory to see if that helps.

I have the same issue as mentioned by flight in his very first post, i.e. the X96Max+ does not boot from SD card nor USB (I have tries all options explained in this post except downgrading the firmware)

Stock firmware is “X96Max_Plus_Q2_20201209-1446”
Board is sm1_ac_213-4g from franklin

I downloaded CoreELEC-Amlogic-ng.arm-19.2-Matrix_rc2-Generic.img.gz, wrote it on my SD card with Rufus and then copied sm1_s905x3_4g_1gbit.dtb into the root and renamed it into dtb.img

I’m quite familiar with Linux, Ubuntu and LinuxMint but not with ARM devices (although I replaced Android on my phone with LineageOS)

I have a very basic question: how this device knows there are 2 bootable devices (the internal emmc and the SD card) and why it would select the SD card first? Isn’t there a switch to tell it to boot from SD card rather than emmc?

@flight: what is your current status? CE works after downgrading the firmware?

Thanks in advance for any help

Finally I opened the X96Max and during powering up I permanently pushed the reset button which is inside the AV connector and I got CE booted from my SD card.
I rebooted the box and it still boots first from the SD card!
Next step: become familiar with CE (i.e. Kodi), add some plugins and get the remote control to work