Calibration image fails (again on 8.90.3)

I just tested on Billy Lynn (60 i/s), and there is a problem of fluidity in 50hz, which is solved in 60hz. :frowning:

Well, of course there is.

You asked about the fluidity of the 50hz Interface, and then you test with 50hz video :smiley:
Don’t mix apples and oranges :wink:

Read again slowly :
“I solved that by changing the refresh rate to 50Hz.”
“But what impact on the fluidity of the interface and 60fps videos ?”

Test result :
With the image parameters set to 50hz as recommended by “aposhtol”, to avoid the problem of misalignment of the calibration; Well, the video at 60 hz jumps.

Therefore, this solution is not viable. :frowning:
Do you have another idea ?


Yes, buy a better box or tv…

My both boxes, X92_S912 and X95_S905W, are set to 1920/50Hz for the interface. Playing any 60Hz video switches my Oled Tv to 60Hz and there is absolutely no problem. Also, I have no problem of any misaligment on any resolution/frame rate.
Therefore, my solution works for me, and you have to find out why it does not work for you…

There is little chance that it comes from my TV because I tested on 2 very different models, and even finding. For the box, it is a Beelink GT1 so with a S912 like you. I’ll wake up tomorrow by restarting the box after the 50hz video settings changes. But anyway, the native frequency of modern TVs in France is 60hz, so the 50hz is not recommended. There must be a way to solve the problem cited in this topic by another means?

If you don’t have proper image size on some frequency, that has to be corrected with calibration, then it is either your box or your tv misaligned. Nothing else influences this.

So your TV is not being switched from 50Hz to 60Hz when 60Hz material is playing.

Therefore, you can’t have Whitelisted that res/frequency correctly (or there is an issue with your HW - most likely the box since you have already stated that 2 different TVs are failing to switch so the only common item in your setup is the box)

1 Like

Just wanted to share this.

My KM8P just upgraded to CE 8.90.4 and I noticed both menu and videos in kodi are shown bigger than my TV display (1080P) can show where some parts are beyond the edges of my TV display. So, I went ahead to Kodi’s Settings -> System -> Display -> Video calibration to adjust my TV display. So far, so good until I rebooted my KM8P. Upon coming back from a reboot, the problem persists where kodi is again shown bigger than my TV display (1080P) can show. In other words, the settings on previous video calibration is now lost after a reboot. So, I started searching for solution in this forum and found this post. Then, I followed a suggestion by aposhtol to change a refresh rate from 60 Hz to 59.54 Hz and now the video calibration setting sticks through a reboot.

I hope this will help others.

1 Like

Try to keep on topic (clutter removed) :wink:

1 Like

I was having the same problem with 8.90.4. I would calibrate the screen size to my tv but calibration would get lost every reboot, like coreelec couldnt save the settings.

Someone advised be that actually we shouldnt be using the calibration menu at all. So i put calibration to deafault (0,0) and instead i searched on my TVs picture menu there was an aspect ratio option called “full scan” which fixed the image perfectly without calibration. Normally tv has as default aspect ratio “16:9” which seems is not right for coreelec


just wanted to come back to this to say that the above fix for setting the refresh rate to 60hz no longer works for my box - every time i reboot or power off, the screen calibration needs re-doing again.

my television is over 5 years old so i have limited options on that to do anything.

i can put up with resetting the calibration for now but hopefully it’ll be fixed in a future update

1 Like

Never seen any issues on 1080p resolution with calibration
If it connected via HDMI, than the main reason is scaling or aspect ratio for HDMI input in TV settings. It must be switched off.
Also you can try different hdmi port

I have a Toshiba that’s 11 years old and it has 1:1 scaling.
Not ALL TVs have it, but most do.

Aha, I didn’t quick click on :smile:

My TV is one that has “aspect ratio” instead of “scaling”. For some reason, I had it set to “!6:9” so after “Auto” didn’t work, I realised it should be “Original” so I did that and it works just fine now.

Funnily enough, the third HDMI port on my TV seems a damn sight lot sharper than the 2nd !

For old Toshiba Regza TV’s it’s a button “quick” on remote
After you need to select Picture size: Native.
This is configurable for each HDMI port

#pebkac strikes again

1 Like


Not sure if anyone noticed this but I get some issues with video being wrongly calibrated after my TV switches to other resolutions. By default my Kodi GUI is set to 1080p and the calibration looks perfect. The issue is there when i’ll try to play ie. 720p or 4K video. When you pause the video you can clearly see that parts of the GUI like buttons or progress bar are being cut off. I can correct this by changing TV stretching options, but I’d prefer to keep them on ‘Normal’.

Any one has these issues?


As I said above this is 99% TV settings.
1080p, 720p and 576p shows correctly on my both TV’s
For each problem resolution you need to check hdmi/picture size settings, they can be different. If you set them in “native” you problem will be solved.
Check the google for such issues for your tv, may be it can help to find correct settings faster

Today I was setting up a new LG LED UHD TV (WebOs 3,5) and came upon this problem - the picture (1080p) was too big.
On my LG Oled TV there is an option in Quick Menu to set Aspect Ratio to “Just Scan” which is 1:1 ratio and picture perfectly fits.

On this new LG LED TV that option, “Just Scan”, is not present in “Qick Menu”. It took me some time to discover this option in “All Settings” menu. There under “Picture” -> “Aspect Ratio” the option “Just Scan” was set to “Auto” (default). Changing this option to “Just Scan -> ON” put everthing in its place, and full 1:1 picture is displayed.

This option is only available for HDMI inputs, not for DVB-T TV programs…

1 Like