Cant connect with putty

he hello
i have latest coreelec on a sd card it starts but i cant ssh with putty wen i put the internet adres in the browser i see al files ,if i put the internet adress with 8080 behind i got to the controll panell.
but with putty it says connextioen error i have w10 pc and set all the security off but still i cant login in with putty
i read a lot on this site but i cant get it done can someone please help me and yes i enabled samba and ssh in the corerelec settings

You could try using command prompt to ssh.
Try using ssh root@<box ip addr>. The default password should be coreelec.
If that’s not working, you can try turning ssh off and back on and reboot.

well it says could not resolve hostname

It seems that your home network does not publish the hostnames. Find out and use the IP address, I always use this method.

well it works now a new problem i tried to put my remote file in to the box by hitting its ip adress in the top bar of my pc but it wont connect than i tried with sftp drive and tried to put the files in the map config rc keys but than it says the file is to big any idee what to do

Put your “remote file” on an USB stick and transfer it with (pretty potent) Kodi File Manager to correct path.

ok i have 2 files m8spro+ and rc maps so do i have to put the 2 files were and second how do i find kodi file manager
thanks for help

You’re using Windows 10

The Windows + R will show you the “RUN” box where you can type in your box IP address of box on your home network.
Hit enter and all the Directories you are looking for are visible and ready for you to copy your files to and from your PC and Box
Windows+R

well thanks that did it but now i have a new question maybe in the wrong subjrct folder but i trie
in correlec by default the resolution is set by 3840/2160 60hrz al my movies play well even hd 1920/1080 or 4k 3840/2160 60 hrz
but my question is when i put on the info button from my 4k tv it always say resolution 3840/2160 so should i leave this so ore should i set my resolution to 1920/1080 en let coreelec do the work thanks for helping me

You have two options:

  1. Configure your GUI to use 1920x1080@50Hz (or 60Hz)
    Your TV will now automatically switch between 1080p and 4K
  2. Keep the GUI configured to 3840x2160 and add all 4K and 1080p resolutions into the whitelist (on top of the same menu where you change the GUI resolution)
    After configuring the whitelist, your TV will also switch between the resolutions

thanks for reply can you explane a little more how to do this i am new on coreelec so thanks a lot for helping me

Just go to Settings > System > Display and change the following values:
Resolution: 1920x1080
Refresh rate: 50.00

That’s all to allow Kodi properly changing the resolution.

now i understand i will try it thanks

well that didnt work
i changed it in system display to 1920x1080 but even if i play a 4k movie my tv says it is 1920x1080 so what do i wrong here

i think i have to disable the whitelist or deselect the resolutions in the whitelist but how do i do that

i read this post below but i dont now how to do this

Settings > Player > Videos

  • Adjust display refresh rate => On start / stop
  • Sync playback to display => disabled

Settings > System > Display

  • Whitelist => de-select all options
  • Resolution => 1920x1080p

You just open this whitelist setting and deselect all activated resolutions.

well i cant deselect this i only can choose a setting strange

well i found this i think for me it is still more confused because if i empty the withelist above happens
means the tv shows always 1920x1080 but i cant empty the withelist how do i disable the withelist

If you open the whitelist menu, you will see some resolutions and Hz numbers mentioned. Hz can also be understood as “fps” (Frames per second). The list shows, what your TV/Monitor is capable of. Let’s assume, we have a FullHD TV connected which is also capable to do different fps on its respective resolutions. So 24, 23.98, 30, 59.97, 60 for 19201080 for example and also 24, 23.98, 50, 60 for 1280720 and 50, 60 for 720*576 (the list is somewhat huge Wink ).

If you don’t enable any of those settings, Kodi will pass everything it plays directly to the TV. That will mean if you play some SD Live-TV channel (which sometimes has 720570 at 50fps) your TV will probably show 1080p instead (which will mean 19201080/50fps). So your TV does the upscaling then. If you enable 720*576/50fps at the whitelist, your TV will show 576p and there’s absolutely no upscaling and the TV shows the native resolution the Live-TV channel has. That willl also result in a 576p Kodi GUI if you hit ESC during a live-tv playback.

If you have 720576/50 disabled, but have 19201080/50 enabled and play some SD live-tv channel, Kodi will search if you have a matching resolution/fps whitelisted. As you don’t have 576p whitelisted, Kodi will check the next higher one as long as it gets something that matches (in that case 1920*1080/50) and will use that to pass it to the TV. So in that case, Kodi does the upscaling.

well i have it working the problem was
Adjust display refresh rate => On start / stop wasnt enabled i dont know if it wasnt by default or i did something stupid before
so the tv gives the correct resolutions by playing hd or 4k i just stay trying till it is perfect.
next problem is wen i start a 4k movie first 10 seconds i have the sound and then the picture starts playing strange and i think overal it is slow boot from coreelec is perfect and fast but the interface is slow loading tumbnails go very slow could it be that i am working from sd card still it is a class 10 card. so here my question that is a little bit taboo here would it be faster if i install on internal hope the devs dont shoot me for asking this and also thanks a lot guys for helping me

Yes, it will be so much faster … OK, no it´s only a fairy tale.
Dont try internal install to fix some problems.
First step -> a clean and working installation on fast SD card.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice