CE and N2+ not passing HDR10+

I did a search and do not see any recent info…

My Odroid N2+ and CE 19.4 will not pass HDR10+, only HDR10. For verification purposes, I have the N2+ connected directly to the display (Samsung Q70T). I also have a Zidoo ZX9 and it properly passes HDR10+ when connected using the same HDMI cable, same ports on the TV, and playing the same files.

I have both HDR > SDR and SDR > HDR turned off in Kodi.
Any ideas on what could be the cause?

HDR10+ works correctly on CE since… A long time. 19.4 is not the most recent stable version of CE. 19.5_rc2 is. Just fyi, display info on CE19/20 4.9 kernel shows HDR10+ as HDR10 even though it’s passing HDR10+ to the tv (confirmed on the tv).

Thanks for confirming it should be working. I’m using the TV also to validate HDR10+ (it shows an indicator). I’ve updated to 19.5rc2 and even tried the nightlies with no difference. Would there be any value in doing a complete wipe of the boot drive and reinstalling CE?

Hi, my TV is not 4K HDR but with HDR>SDR i can see movies HDR.
When i try to watch an HDR10+ movie, i hear the soundtrack but the screen stay black.
Is it normal ?

I agree with dekesone, I encounter the same issue with an Odroid N2.

A while ago (when HDR10+ was officially supported on CE), my 2019 Q950R Samsung TV was displaying the HDR10+ logo when playing HDR10+ medias from CoreElec.

A few weeks ago, I noticed the TV doesn’t display the HDR10+ logo anymore with HDR10+ medias.

I deciced to wipe everything and installed 19.5 RC3 from scratch, nothing changed.
I also tried to update to CE 20 beta, same problem.

It doesn’t seem to be a problem with the TV as the HDR10+ logo is still displayed on the TV with HDR10+ medias played from the Apple TV 4K.

Also, I agree with Vasco, the HDR10+ info was never displayed directly in CE but the TV used to show the HDR10+ logo and it just doesn’t do it anymore.

It’s maybe because of Amlogic did mix up follow source or sink.
We solved a issue if a sink is only HDR10 capable but source is HDR10+:

So if the source is HDR10 and sink HDR10+ it will also not “upcolour” it I guess.

This patch is not yet backported to 4.9 kernel.

Thanks Portisch !

Any idea when / if it will be ported to kernel 4.9 ?
Or should we expect a fix with CE 20 ?

I was finally able to test this and I still get HDR10+ on my tv with N2+ and CE20

That’s interesting… What version of CE20 are you using ?

The test was run on 14/12 nightly of CE20. Didn’t try with today’s nightly

Thanks, I’ll test it later today and get back with the results :slight_smile:

I am running CE NE on my HK1 Rbox X4, and have never seen HDR or HDR+ on my TV screen. My TV supports all of the videos like HDR and Dolby Vision.

Then there’s something wrong with your setup, HDR and HDR10+ are supported in CE for a long time. DV isn’t.

Thank you, I will do more testing.

If you have something like an AVR between the box and the TV try directly just for testing.

I have the box connected directly to the TV’s HDMI port. I swapped with a cable going to a different HDMI port, and still no HDR10.
I tested the same video using Kodi running on an Nvidia Shield, and my TV shows HDR10.
What else can I be missing?

Check the HDR to SDR settings and other stuff in video. Try to return to default. You can also try a fresh image in a uSD just to see if it’s some setting that is wrong. I have multiple devices and no problem getting HDR.

I tested my Beelink GTmini2 (Amlogic S905X3), running CE Nexus from microSD card. Box connected directly to HDMI input #4, still no HDR display on my TV.

I switched to Android running on same device. Playing the same video using Kodi, I get HDR10 displayed on my TV.

Edit: I switched back to CoreELEC and bingo, CE is now showing HDR10. I do have buffering on some of my high bitrate videos, can that be the cause of not using the HDR setting??
My media is stored on external hard drives connected to a mini PC. All of my devices are connected via Cat 6 ethernet cables.

Can you post dmesg from that device?

How do I get dmesg? I also set the tone map SDR to HDR and rebooted, still no HDR display on my TV.