Chapter Skip Forward Crashing Kodi Intermittiently

Hi everyone,

I’ve just updated to the latest nightly build (20191025) and have struck my first kodi crashing issue since purchasing the N2.

When using the chapter skip forward function on both 4K and 1080P content I’ve had the player freeze up, then either restart kodi or reboot the system. Here’s the link to the kodi crash log: http://ix.io/1ZRC.

The files themselves are all located on a USB drive connected directly to the N2 and powered by the USB bus. I also have a second external hard drive connected which doesn’t seem to exhibit the same issue, but this drive has its own power supply and currently only has 576P content on it.

I’m going to move the files I’m having a problem with between the drives and see if the problem follows the files or not. In the meanwhile I’m hoping someone can add some insight on what the actual problem might be.

Thanks in advance.

Okay, I’ve tested the same files on the second drive and can confirm that the issue follows the files.

More so, the issue occurs at the exact same point in each file every time, which suggests that there is a problem either in the file itself or a problem with the way the player reads or handles certain data.

While it’s not a pressing issue, as I’m rarely skipping my way through movies, I’m keen to hear if anyone else has the same problem and what/where I can look for a resolution.

I think it’s a Kodi bug. Try this on 18.4 Kodi on another platform.

Thanks TheCoolest.

Will give it a whirl.

I’ve installed Kodi 18.4 on my Windows 10 PC and attempted to play the problem files, these all work fine when using the chapter skip forward function.

I’ve also adjusted the chapter markers on one of the problem files using MKVToolNix to see what affect this has. Doing this created different crash points within the file when chapter skipping, so I’m assuming that the problem is a combination of chapter marker and the ability of the hardware to handle mismatches in marker position and video/audio.

Have you tried a fresh install?
Could you try to play the same file from network or internal memory?

Hi Pelican,

No, haven’t tried a fresh install, will give that a go when I have a chance.

I’m not running a networked configuration, so can’t play the file via network sorry. Will try and copy one of the problem files to the SD card though and see if there’s any difference.

Will update once I’ve had an opportunity to test further.

Tried a fresh install of the latest nightly build (20191027) onto a 16GB eMMC, same result - crashes at the same point for each file.

Unfortunately I can’t copy any of the problem files onto the eMMC or SD as there is insufficient space on each and I don’t have anything bigger available to me.

I’ve done some more testing today and have narrowed the issue down to the audio format being used during playback.

All the files I’m experiencing issues with are playing with TrueHD 7.1 as the default audio channel. When using the channel skip forward function these will crash kodi. Usually the crash occurs at the exact same skip point, but occasionally it will crash at a different point if I try to skip forward chapters in quick succession.

If I change the audio channel to AC3, I can skip forward through each of the files I’ve experienced an issue with - I’ve tested this with six different mkv files successfully.

I’ve also tried disabling audio passthrough and have tested both HDMI and HDMI Multi PCM as the audio output options - the files will continue to crash kodi if TrueHD is used in these configurations.

Does anyone have any suggestions on what else I might be able to check or test?

Try enable Passthrough and turn on the “TrueHD capable receiver”.

I’m also experiencing crashes if Kodi decodes the TrueHD stream.
If I bitstreamed it and let my AVR/TV decode it, it’ll not crash during chapter skip.

But, even bitstreamed, TrueHD will still produces bugs… although not as bad as crashing Kodi…

There’s two problems with that:

  1. My AVR can’t decode TrueHD.
  2. Even if it could, I don’t have an option under Passthrough for “TrueHD capable receiver”. I only have “Dolby Digital (AC3) capable receiver” and “DTS capable receiver” options to choose from.

Ah, ok then…
How about this:

  1. Set Number of channels to 2.0
  2. You’ll see “Enable Dolby Digital (AC3) transcoding” in Passthrough options, turn this on

Btw, this will decode your TrueHD 7.1 to PCM 7.1 and then transcode it to AC3 5.1
Which if you have an AC3 5.1 2nd audio stream in your file, I think it’s more efficient if you just change to that at the start…

You can simply enable Dolby Digital, and it will extract the DD Core out of the THD stream.

if it’s mkv then the thd core is separate not embbeded.

Make sure you didn’t chose SPDIF but HDMI at passthrough device.

It used to work fine for me for years with this configuration.

Thanks for the suggestion.

Tried it but I have the same result as when selecting the TrueHD stream - Kodi crashes at the same points in the movie.

For now I’ll select the AC3 5.1 stream on playback start, as I know this works fine.

My AVR only supports S/PDIF, hence why the other options are not available to me in the Passthrough menu.

As an experiment I tried changing Passthrough to HDMI and enabling all passthrough options to see how my TV handled TrueHD. Unfortunately I heard a lot of nothing, so I disabled all the HDMI passthrough options again and set it back to S/PDIF.

What is interesting though, is now when I play a movie with TrueHD selected as the audio channel I’m getting a PCM stereo input displayed by my AVR - previously it would show Dolby Digital full channel input. The channel skip forward function is also working properly in this state.

Check this topic. It’s the same issue with Osmc. Seems to be affecting uhd remuxes.