CoreELEC 19.1-Matrix_rc1 Discussion

I can cofirm that CE 19.0 Matrix runs on my Mini M8S II S905X box.
But only from SD-Card or USB stick.
I tried to port it to the internal memory using the CEEMMC tool but after that my device was bricked.
I know it’s not on the list of officialy supported devices but I hope one day it will be because CE runs far better on the internal memory for me. That might be because of my slow USB stick but I’don’t want to buy a new one just for that purpose.
Until then I’ll stick to the Legacy builds.

What did you have in internal when you tried cemmc?

I used ceemmc with the first CE19 release on March beginning. After running it my Mecool KI Pro box was bricked and I needed to open it and locate the points on the chip to get it reflashed again with Amlogic tool. So be cautious trying that. But I am still interested in it to be able to abandon my sdcard. I chosed to replace the ANdroid partition and tried to use the full memory for CE. Maybe that was my fault and I should have been chosing the option to keep it with Android datat? I read that CE19 RC1 has some changes regarding for ceemc but unsure if I should retry again…

@ Vasco: At that time I had CE 9.2.6 in my internal.

@byomi: I tried the dual boot option too afterwards. Same result.

To use ceemmc you must have android in internal. You may try again but always be prepared for a recovery operation.

1 Like

Ok understood that with ceemc. Maybe try again later once I solved the problem with video playback (stutter / jiddder). Tried to play Minions films while log. As stated earlier the stutter / jidder is solved when disabling h264 hw acceleration but then I get low framerate playback on HD channels in IPTV simple client and that’s no solution. Never had problems on CE9.2 (non-NG). Here are my logs:

CE-debug:
http://ix.io/2Uf1

Log (Stutter / Jidder with VideoPlayer::OpenFile: /media/sda1-usb-SanDisk_Ultra_US/Minions (Hd).mkv):
http://ix.io/2Uf2

Test-Video:

Edit:
This forum user has the EXACT same problem. Tested his file and it is identical issue:

Thanks for the logs. Can you share a small sample of the video like 30 sec or something like @boot2k3 asked in the old thread?

OK now I flashed my device back to Android but when using ceemmc I get following message:

Install in single boot mode not possible!
No DT partition was found

last time I could choose between all 4 options. Do I have to do something in addition?

Your device/firmware is just to old. Buy a newer device or just use dual boot. This limit was introduced with a reason!

I just updated my previous post with a testvideo so we got everything in one place. Let me know if it stutters for you too?

Trying dual boot results to this:

Please choose one option? [1/2]: 1

Aborting!

So neither option is really availible for my device. The Legacy builds will have to suffice then.

Ha!
As discouraging your reply was it gave me an idea and it works.
I saw a youtube tutorial " How to flash [ROM] ATVXperience on Mini M8S II (p212 board, S905X)".
It’s an Android 9.0 firmware running on the same kernel CE 19.1 Matrix does.
After flashing my box with it I ran ceemmc again and it worked.

Maybee you could post that somewhere in a tutorial so others with the same problem will find their solution quicker than me.

If you use the search in forum you’ll find many users that updated the firmware of various different devices. That has been our answer many time, update firmware. It’s impossible to cover all devices and sometimes users have to be a little more proactive in finding the solution that fits them.

1 Like

Well updating my firmware was the first thing I did.
The problem was that the latest official firmware for my device is from 2017.
The ROM I used is custom made but hey, if that does the trick who cares.
Just wanted others to save some trouble by making my discovery puplic.
It could have saved me some hours of my life had I found a report like this anywhere on the net.

Thanks anyway. At least it lead to something good.

And we thank you for that because others will search the forum and find your post with the answer they’re looking.

Next topic,
anyone experiencing problems with their usb ports?
It seems like my rear usb port doesn’t work anymore after the switch to CE 19.1. The on on the side of the box still works like a charm.
Maybe its a problem that came with the custom ROM I used earlier but shouldn’t the ceemmc tool have overwritten everything from the Android Firmware?

Edit: It realy was the fault of the ROM and its bootloader I was using. I’ll try some different ROMs out and be back if find a fitting one.

No, it still uses the bootloader and you should have confirmed how everything worked with android just to see if that was the adequate firmware for you.

1 Like

Good evening, I am an owner of Odroid N2, I have installed kodi19.1 Matrix, everything works but an option that I liked a lot is missing, it is located on the home skin settings and it is “hide to cinema / movie coming out” on kodi Leia was present now she is gone. It is a bug or it is activated with some addon incompatible with this version. Thanks.problema kodi.bmp (4.9 MB)

The nightlies are running spectacularly on my x96 S905x box. I’ve noticed, however, that the update progress dialogue is no longer shown at the splashscreen in CE 19. I’m guessing this is intentional and honestly gives everything a much cleaner look.

Is there a setting buried in a startup script that I can manually add/modify to have that dialogue displayed?

The reason I’m asking is because others in my home have suddenly decided to start using the “nightly” testing box again and I’m sick of answering questions about whether the box has stalled at the boot screen.

Hey guys I flashed this to emmc on my odroid c4, all working lovely although menu colours seem a bit washed out, is this normal? Getting surround sound working with my sonos beam is tricky, is it just not ready for all files yet? Some are fine, some no voice audio, I’ve changed to 5.1 out rather than 2.0 like we used to… I’m primarily setting the box up as an emby server which it seems to do fine. I need add transmission and other services but just wanted check the basics first.
Are there just some audio driver glitches? I don’t mind stick with it I’ve got other boxes to wat h on. As this is odroid I figure support should be reasonable, just wondering state of play really, maybe I could start helping somehow.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice