CoreELEC 19.2-Matrix Discussion

I have an a95x box (s905x) that I use a 8812BU based AC wifi USB adapter as it is much faster than the onboard N wifi.

On older CE versions I had to disable the onboard wifi or neither the onboard or the USB adapter would work if they were both plugged in/active at the same time.

After installing the latest update I an unable to disable the onboard wifi using the blacklist.conf file, and neither wifi adapter works at boot if the USB adapter is plugged in.

I had previous added ‘blacklist wlan’ to my blacklist file, and it worked without issue.
I can confirm that those files are in place, and my black list appears unchanged from previous versions.

If I look at lsmod I don’t see any name changes that jump out at me.

Module                  Size  Used by
ir_rc6_decoder         16384  0
ir_nec_decoder         16384  0
ir_lirc_codec          16384  0
lirc_dev               24576  1 ir_lirc_codec
meson_ir               16384  0
rc_core                40960  6 ir_rc6_decoder,ir_nec_decoder,ir_lirc_codec,meson_ir,lirc_dev
hci_uart               86016  1
btbcm                  16384  1 hci_uart
btqca                  16384  1 hci_uart
btintel                24576  1 hci_uart
bluetooth             425984  27 hci_uart,btintel,btqca,btbcm
wlan                 4198400  0
88x2bu               2981888  0
mali                  348160  1
joydev                 24576  0
nfsd                  364544  3
exportfs               16384  1 nfsd
nfs_acl                16384  1 nfsd
wireguard             139264  0
ip6_udp_tunnel         16384  1 wireguard
udp_tunnel             16384  1 wireguard
wifi_dummy             16384  0
amvdec_vp9            135168  0
amvdec_vc1             69632  0
amvdec_real            45056  0
amvdec_ports          249856  0
v4l2_common            16384  1 amvdec_ports
videobuf2_dma_contig    20480  1 amvdec_ports
videobuf2_memops       16384  1 videobuf2_dma_contig
v4l2_mem2mem           28672  1 amvdec_ports
videobuf2_v4l2         28672  2 amvdec_ports,v4l2_mem2mem
videobuf2_core         49152  3 amvdec_ports,v4l2_mem2mem,videobuf2_v4l2
amvdec_mpeg4           65536  0
amvdec_mpeg12         110592  0
amvdec_mmpeg4          40960  0
amvdec_mmpeg12         49152  0
amvdec_mmjpeg          36864  0
amvdec_mjpeg           40960  0
amvdec_mh264          172032  0
amvdec_h265           163840  0
amvdec_h264mvc         57344  0
amvdec_h264           151552  0
amvdec_mavs            61440  0
amvdec_avs             69632  0
amvdec_avs2           221184  0
stream_input          208896  12 amvdec_h265,amvdec_mavs,amvdec_mh264,amvdec_h264mvc,amvdec_ports,amvdec_real,amvdec_vp9,amvdec_h264,amvdec_avs2,amvdec_mpeg12,amvdec_avs,amvdec_mmpeg12
decoder_common        196608  18 amvdec_h265,amvdec_mavs,amvdec_mjpeg,amvdec_mh264,amvdec_mmpeg4,amvdec_h264mvc,amvdec_mmjpeg,amvdec_ports,amvdec_real,stream_input,amvdec_vp9,amvdec_h264,amvdec_avs2,amvdec_mpeg12,amvdec_avs,amvdec_vc1,amvdec_mmpeg12,amvdec_mpeg4
firmware               28672  18 amvdec_h265,amvdec_mavs,amvdec_mjpeg,amvdec_mh264,amvdec_mmpeg4,amvdec_h264mvc,amvdec_mmjpeg,decoder_common,amvdec_real,stream_input,amvdec_vp9,amvdec_h264,amvdec_avs2,amvdec_mpeg12,amvdec_avs,amvdec_vc1,amvdec_mmpeg12,amvdec_mpeg4
media_clock            45056  14 amvdec_h265,amvdec_mavs,amvdec_mh264,decoder_common,amvdec_ports,firmware,stream_input,amvdec_vp9,amvdec_h264,amvdec_avs2,amvdec_mpeg12,amvdec_avs,amvdec_vc1,amvdec_mpeg4
amlvideodri            24576  0
videobuf_res           16384  1 amlvideodri
videobuf_core          32768  2 amlvideodri,videobuf_res
videodev              290816  6 amlvideodri,v4l2_common,amvdec_ports,videobuf2_core,v4l2_mem2mem,videobuf2_v4l2
media                  40960  1 videodev
fuse                  131072  1
fbcon                  61440  0
bitblit                16384  1 fbcon
softcursor             16384  1 bitblit
font                   20480  1 fbcon

I tried upgrading to the 10/18/21 nightly, and it has the same issue.

I rolled back to 19.2 RC3 and was able to get everything working without issue again. I am guessing something changed between RC3 and the final release that impacted blacklisting the wifi somehow.

Does anyone have any ideas on how I can disable the onboard wifi adapter again without a hardware modification to the system?

your blacklist config would be needed. and also provide all debug logs

@Portisch
I provided the blacklist config in my post, but I will put it in code brackets so it is easier to find.

blacklist wlan

Here are debug logs.
http://ix.io/3C6J

please also:

ls .config/modprobe.d

and then cat for each conf file you get:

cat .config/modprobe.d/xxxx.conf

Hello, someone have the dtb tree of p281_gxl_4/32GB from Box D905 ???

Thank you.

@Portisch

ls .config/modprobe.d

blacklist.conf                   disable-spdif-for-hd-audio.conf

cat blacklist.conf

blacklist wlan

cat disable-spdif-for-hd-audio.conf

# INTEL HBR WORKAROUND FOR DTS-MA & Dolby TrueHD PLAYBACK

# Uncomment the following lines to disable any S/PDIF out to deliver
# bitstreamed audio on Intel builds. This is a rough workaround for
# users that have both S/PDIF and HDMI audio outputs on their motherboard
# or motherboard+discrete graphics combo.

# EVEN IF YOU ARE NOT USING THE S/PDIF OUTPUT
# but still have one, you will need to uncomment the lines below !

# after uncommenting these lines, you must reboot for these settings to take effect

# blacklist snd_hda_codec_realtek
# blacklist snd_hda_codec_sigmatel
# blacklist snd_hda_codec_cirrus

Did this information help you gleam any new ideas of what might be amiss with the blacklist between 19.2 RC3 and 19.2?

please also make a dmesg | paste as it’s not included in the log above, thx

@Portisch
As requested:
http://ix.io/3Ca0

Try blacklist wlan-qca9377-aml in your blacklist config.

@Portisch
That fixed it.
I guess the module name or the way it was being processed changed in the last revision.
Thanks for your help.

Hello,
With the new 19.2 matrix the screen resolution 1024x768 disappeared. It is no longer in the menu.
Is there a trick to get it back ?
Thank you.

Hello,
I have a Sunnzo S9 mini S905W.
My screen randomly goes pinkish/greenish. I have read in this forum that is is possible to add a RGB option in a file by sshing into the box. How to do that ?
Thank you.

Hi
Do you speak about this ? Color space issues - #6 by pierino2010
?
But I have brand new Sony TV and I have this issue too … I think there is nothing to do with RGB or something like …

I have sshed into my box and entered the 2 lines. I’ll tell you it this fixes the random pinkish/greenish display. My TV is 2010 Sony Bravia.
Thank you.
Edit November the 18th 2021
In Android box itself, I chose the RGB settings.
In CoreElec, I added the 2 mentionned lines in autostart.
Result : The pinkish/greenish colors have disappeared.

I have a 2020 SONY X900H and I have this issue too.

I did not tried this tweak for now because I’m not sure …

Does anyone know if this RGB issue also concerns the news TV ? like news 2020/21 Sony TV ?

Good news about Atmos dropouts: Kodi 19.3 already out with those fixes Kodi 19.3

And it’s already in CE nightlies.

2 Likes

OK wait and see for 19.3 instead of 19.2 8-))

19.3-Matrix is released, please continue here:

About | FAQ | Terms of Service | Privacy Policy | Legal Notice