CoreELEC 19.2-Matrix_rc3 Discussion

No, I haven’t. I tried as usually, but it didn’t work at all. I had all kinds of problems, which led to the decision to start from scratch. Unsurprisingly, all problems were gone afterwards.

You could try simply throw the update file in the folder and hope for the best. But if errors occur, don’t hesitate and start over from scratch.

1 Like

I noticed kodi always play english auido stream on some korean spanish tv show video.butI already check ‘prefer default audio stream’ option

Try to reproduce this on Kodi Matrix in Android/Windows/Linux. If it reproduces there, it’s a Kodi issue, not CE.
It’s also possible that your preferred language stream is not marked correctly in the file, and Kodi can’t select it, so it uses something else as the default stream.

1 Like

Hey, late reply.
I had resigned to do other things instead so it took a while to figure out, but it was actually a poor connection to the main router that caused it (broken flip thingy on the cable end).

And to further clarify; when I last used it, it downloaded the update, and then I didn’t use it for a long time, then recently booted up again and it automatically applied the update, so I never saw if there was ethernet connection prior to updating. Naturally I assumed it was the update.

Hello everyone.
Successfully installed CoreElec 19.2 RC3 dtb → gxl_p212_1g on Leelbox S1 - S905X - 1/8 gb - wifi RTL8189ET.
The stock rom of the box was android 6.
I first upgraded Aidan’s ROM (android 7.1.2) with usb_burning_tools: [v7.5] (UNIVERSAL) Aidan’s ROM [S905X] 1GB 2GB; later i installed CoreElec on sd.
Everything working, wi-fi, lan, etc …
But I don’t know if the remote control works as I use a mini usb keyboard.
Thanks for the great work.

One more LED issue (Ugoos AM6 Pro, RC3).
When I shut down the system, LED remains red as if it were on (by the way, green does not work also but i don’t care). RC2 works properly (as for shut down issue).
I have tried changing dtb.img as it was mentioned above but it did not work.

try nightly build

Nightly installed. Shut down LED issue solved, green LED issue did not (System LED: On, Green LED: On, LED colour - red).
Thank you.

I have tried same video on coreelec and kodi matrix on android.
android version can correctly playback default audio stream. only coreelec always choose english audio stream

CoreElec does not choose anything, as this is done by Kodi. Check your settings since my CE Matrix_Kodi chooses default audio stream without exception.

I am using rc3 on a M8s II Mini with an Android 9 bootloader. So far everything has been running perfect until today. I have a pioneer sc-lx86 AVR connected via HDMI and Audio passthrough activated for all supported audio types which worked like a charm. Today however all AC3 and AC3-E content stopped working and nothing I do can change that. I tried deactivating passthrough for both but then the video playback just stalls and nothing happens anymore.
Does anyone have the slightest idea what happened ? All my other devices (including a RPi4 running libreelec I use to check if things are still working) still work fine.

Thanks a whole lot

The green screen in the first boost will be fixed any soon?

Sorry, there are no issues with “green” screen since a more than a year now.
So please be sure you have minimum Android 7.1 on your device and that the TV is powered before the device is powered that the TV EDID can be proper read by the device.

My build is the last matrix with a new installation and sdcard. I said that because in my last coreelec 9.2.7 i didn’t have such issues like that. Since the change its happening in every single boot. And yes, this occur when i turn on the box and the TV is still in standby.

1 Like

As Portisch said, your problem is that EDID does not exist when the TV is off, so CE defaults to an incompatible mode.
You need to either add a disp_cap file, make sure that the TV is turned on before CE or at the very least set the correct resolution\refresh rate for your box to use as default when EDID is not available by using fw_setenv.

Thanks. I will try that. One last question. That fix could be damage in any way my build?

No. You can run fw_printenv hdmimode & fw_printenv outputmode to see the default values.

That is my default config. If i enable “0” to “1” setenv native_4k_gui, does it solve the green screen?

Is it really to hard to make text copy/paste instead of using image?

I thought it was easier to read on an image than on a wall of text. My bad.