CoreELEC 19.2-Matrix_rc3 Discussion

Please use this thread for general 19.2-Matrix_rc3 discussion

3 Likes

Manual update success here on Odroid N2. :slight_smile: (from rc2)

Just to report that starting with rc3, some widevine add-ons quit working just like with the nexus release. There is a window that pops up stating that Kodi 19 is not ready to run widevine.

I am pretty sure it has to do with the change in widevine version and all that came with it.
All the main streaming services work, though. I’ll take it up with the addon author as I think these are not adjusted for the new situation yet.
Just to report what to expect in some cases coming from rc2 :wink:

Thanks for your continued support!

AM6 Plus here (not the B version) with BL301 injection.

With RC2 (and all previous version) the power led was blue when device was off and pink when CE was on. With RC3 the power led remains pink when turned off. Going back to RC2 fixed it.

Please try to adjust the “System LED” in rc3 in coreelec settings, hardware

1 Like

Hi, is there any reason to use armhf libraries instead of aarch64, in this release?
It’s not mentioned in the changelog.

My dynamically linked binaries made for aarch64 does not work anymore.
For example, I have this file, which is working on all aarch64 systems:

ELF 64-bit LSB executable, ARM aarch64, version 1 (GNU/Linux), dynamically linked, interpreter /lib/ld-
linux-aarch64.so.1, for GNU/Linux 3.7.0

In this release, linux-aarch64.so.1 is missing and is replaced by ld-linux-armhf.so.3

No unfortunately none of the options had any effect.

Wechip v5 S905X 2GB connected to 1080p TV
Auto Upgraded from 19.2RC2 to RC3
Everything works fine as before after the upgrade
Netflix and Disney+ addons continue to work fine (Widevine CDM version 4.10.2252)
Thanks a lot for this update

@Huit please test this dtb.

Place this dtb as dtb.img on COREELEC partition and also remove dtb.xml to remove old settings.
After boot a “Green LED” should become available in coreelec settings.

Please try different combinations if it you get the same behavior like before. Please remaind to reboot after change the LED setting. If you got it working like before please post your dtb.xml.

g12b_s922x_ugoos_am6.dtb (72.9 KB)
g12b_s922x_ugoos_am6b.dtb (73.0 KB)

1 Like

Hello,
are there some news about my problem?

I tried CE 19.2, 19.3 and problem still persists. Last working version for me is CE9.2.5., which is ok, but I would like to continue.

Good evening everyone.
I want to share my experience, maybe it could be useful to someone.
I bought a x96 mini box with 2/16 gb - S905W, which between discounts, coupons, etc … cost € 11.50.
I opened the box and I found a nice surprise: the cpu is a S905L - 1/8 Gb.
However I have successfully installed the build: CoreELEC-Amlogic-ng.arm-19.2-Matrix_rc3-Generic.img.gz with dtb file → gxl_p212_1g.dtb.
Everything works, wi-fi, etc …
Of course it still has to be tested thoroughly.
Have a nice weekend everyone and thank you very much for the great job

@Portisch thanks, that fixed it!

The default settings of the leds (on) worked.

Here’s my dtb.xml
dtb.xml (7.3 KB)

1 Like

@Portisch is this DTB for AM6B is updated from the previous version?

My simple doubt…
Does the DTB file gets updated automatically whenever there are changes?
OR
Should it be manually copied like during the new installation?
Experts may please clarify…
Thanks in advance.

If you already have an install with an AM6B DTB, then it will be automatically updated when you update to a newer build/version.

1 Like

Thanks a lot for your clarification

Why has been the Automatic option for HDR → SDR removed?

Also for SDR → HDR the Automatic option has been removed.

You have the option to turn each option on or off.

Gives you more control to decide how you want each one to function.

Was it automatic? When? Which iteration? :thinking:

You can force HDR to SDR and/or SDR to HDR.
When both of the options are off, the system will run in SDR normally and will automatically switch to the appropriate HDR format when necessary.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice