CoreELEC 19.2-Matrix_rc3 Discussion

Hi everyone- just joined.
I was about to ask about a problem I had yesterday - installing InputStream Adaptive from Coreelec Addons on Matrix_rc3 - when I tried again 10 mins ago and now it’s installed.
That is fast work.

1 Like

Welcome to the community! :slightly_smiling_face:

Hola. Soy nuevo en esto de los foros, tengo una King gt Pro con CE matrix 19.2 rc3 y tengo unos reinicios en medio de peliculas. Mas menos cada 20/30 minutos. Alguien podria ayudarme ? Estare muy agradecido

Hello. I’m new to this forums, I have a King gt Pro with CE matrix 19.2 rc3 and I have some restarts when playing movies. More or less every 20/30 minutes. Can you help me? Thank you

This is an English only forum.
Your post was translated by a team member and edited, but I can’t understand what your problem is.

I have a problem with 19.2_rc3 which does not exist on any 9.x.y version on my N2:

For years I’m using a WiFi keyboard Rii mini i8+ via USB WiFi dongle connected to USB 3.0 port, and the problem is short keypress. Using this keyboard for years my finger actions on the keyboard are pretty much automatic. The thing is that the short keypress is way to short and about 95% precent of the time I end up with a long keypress action instead of intended short keypress. As if the time for short keypress is only about 50ms, and on all 9.x.y versions it is about 300-400ms…

Is there anything I can do lengthen the time needed for for long keypress?

Maybe it’s something we missed on switch from 9.2 to 19!?

How can I help to find the cause for this behaviour?
Just to mention, I did not try how it behaves on front USB 2.0 port…

Edit: Just tried it with the front USB 2.0 port, and then it behaves normally, as it does with dongle in USB 3.0 ports on 9.x.y versions! So, looks like only (back) USB 3.0 ports are affected.

Hello. Today i reinstalled matrix 19.2 rc3 (sd card 32gigas. ) And again i have the issue reboot when i watching a movie. 20/30 minuts reboot again . have a king gt pro only working with addon Venom . I try addon balandro and again reboot the system. I dont know what is happening. I try reinstall five time . In all times have a same issue.

If all box rebooted then it could be bad power supply.
In case only kodi restarts then you can upload crashlogs.

Link above ,but select crashlog in menu

Yes,reboot the king gt pro but just when i use Matrix and only when a i am watching a movie.

Please use addons not listed on the banned blacklist and try again! No support!

Dont worry. I erased the addon. However a still have a reboots in my tvbox. I am new in this

Please provide more information:

I was glad to see this in the release notes:

  • Fixed possible black screen after vendor logo

Unfortunately, this issue is not fixed.

With my LG 24MP88HV-S the screen will go black after the coreelec logo finishes loading.

This happens only after the EDID is ‘registered’ so-to-speak with the OS… In other words, when moving from a working screen to this screen, everything is fine on the first boot. On a subsequent reboot, the problem appears.

The channels play fine, I have it set to play an m3u automatically on startup, but as soon as I escape the channel to the menu, the screen goes black.


It’s about after vendor logo, not coreelec logo.
This is a sign you have chosen another GUI resolution.

Use a fresh install and try again. If it still goes black without any modification please post some debug info. Open a SSH connection and use ce-debug to create a debug log.

No, sorry, I will not help troubleshoot this further. You have the information, you figure it out. I took the box out of service anyways.

I did not choose any other resolution, everything is as vanilla as can be. No customizations.

So the problem is solved then :slight_smile:

No tips? :X
It’s been so frustrating all the freezes.

Our X96Air P2 4/32GB 1Gbit Lan (S905X3) box is currently still on 9.2.8 and I’m just wondering if the upgrade to 19.2-Matrix_rc3 really can be as easy as downloading the Amlogic-ng update file to /storage/.update to update manually?

I only have a few addons from the official repo installed and would not want to fiddle around with that box or risk any downtime as it’s in use every evening in our home cinema.

Has anyone successfully upgraded that way?

It’s not the recommended way but it’s perfectly doable. I did it in some of my devices. It’s easier if you don’t have “complicated” addons or modded skins. You can make backup just in case and go for the update.

1 Like