CoreELEC 19.3-Matrix Discussion

You must use SMBv1, but it´s not secure

In 19.3 matrix RC3, no disable deinterlacing option, Is there a default value that cannot be changed?

Thanks for your reply. Yes I understand that and have tried it in CE 19.3 to no avail. But it works fine in CE 9.2.8 with SMB2 being the minimum level set. Are you saying that whereas it works in 9.2.8 it does not with Matrix 19.3 ?? There must surely be many others getting this problem too. It is very frustrating having spent many hours trying to fix it as you can imagine. I have Cron and Asanti enabled in CE too.

I am not worried too much about security as nothing particularly valuable and personal on my NAS and my LAN and NAS drive are quite well protected anyway. So SMB1 is not a problem but I clearly wont use it if not necessary of course.

Following is the information for SMB version supported for Zyxel NAS:
SMB v1: NSA series, NSA325 v2 and previous model
SMB v2: NAS series, NAS326, NAS520, NAS540 and NAS542.

Try to force SMBv1
Plan B: use NFS

I replaced my old NAS which only supported SMBv1.
Now I use SMBv3 running CE 19.3 - it works.

1 Like

As a follow up to my post above, and as per @kshi’s advice (thanks, man), I have, after considerable effort, installed Aidan’s V7.4 ROM (the only Android 7 ROM that could be flashed), after which the USB burning tool wouldn’t recognize the box anymore. Anyway, as I could also no longer boot CE 9.2.8, even with the toothpick method, I successfully installed CE 19.4 nightly booting it from Aiden’s ROM using Boot to Libreelec app.

I was delighted to see that HDR to SDR option is now available but probably a redundancy because CE does the conversion anyway (on or off after reboot doesn’t make a difference), the options seem to come from the above Android 7 ROM?

However, even though I now successfully managed to install Netflix addon and WidevineCDM, Netflix content still only plays in 960x540px, while in CE 9.2.8 it played in 1080. I have reset and reinstalled WidevineCDM numerous times to no effect. Has anyone come across this problem, can this be due to the Nightly Release? Is it a known issue?

I also couldn’t access the disk connected to my router until I set Minimum and Maximum version in Services/Samba section to SMBV1. (as a comment to @RayW issues).

1 Like

Read this for Netflix and learning how to use it in latest update. Skip the test build part because the feature in now part of the official addon.

Damn, that was quick and SUCCESSFUL!

All is well now and the 19 can fully replace the 9 for me.

Thank you!

1 Like

I have an Ubuntu server with samba shares providing media access to 3 media players. Samba access there works fine.
I did however run into an issue where my A95X (which I think is very similar to the TX5) would not transfer data over the onboard wifi after upgrading to 19.3CE. I think there is a driver issue in 19.3/19.4 CE that impacts devices using the QCA9377 driver.
If you are using wifi, try an ethernet cable as a test. If that resolves your issue, you can add an external USB wifi adapter that works and blacklist the QCA9377 as a work around. It’s not ideal, but it’s the best suggestion I can offer until the driver issue is looked into.

Hi, friend of mine has the same problem 1080p TV and no HDR but would play 1080p HDR or 4k HDR… So I bought him, cause he won’t spend much money, the x96 mini with 905W. Supported by Kodi 19.3 and with option HDR to SDR. Am@zon 28 Euro. And plays like charm. Booting a bit slow, although with a high speed transcend sd card, but that’s ok for that price.

Hi @all, i am stuck with a X96 Max+. I made a couple of boxes with CE but this box get me insane. I tried 19.3. and also the legacy build with all 2 dtb images. But the box won’t boot from sd card with toothpick method like all others I played around with 905x,w,p and 922 boxes. The only thing that comes is the Android panic screen in the screenshot below. What do I do wrong or am I missing something. Thanks in advance for the hint in the right direction.

you have to use USB latest models does not work boot from SDCard

1 Like

First thx for the answer. You mean i must burn CE on USB Stick?! Does X96max+ boot from USB if i understand you right.

Thank you so much. I had set the min level to SMB1 but not the maximum level. Once I forced SMB1 by setting Min and Max to level 1 bingo finally I could see my old NAS drive. Very strange why I did not have to force SMB1 with CE 9.2.8 but have to with CE 19.3 ???

Uhhh sure ? its very bad if its true… Do you speak about X96Max+ only or all android box ?

Seems it depend on what version you have. Mine now boots only with usb Stick in usb3 port and with the dtb for 4 gig but without 1gb network. After I tried all dtb for this box only the one in legacy build from CE worked and after that couriosly I took the 19.3 update and it worked, There are many different versions of this box out, so it seems.

you probably have an AI revision where there is support for the Nightly release if you want to use gigabit dtb.

1 Like

Ok thanks for the hint. Will try nightly :raised_hands:

Ok tried nightly but it was hanging on some startup things like time syncro. After i copied the dtb without 1gig from Legacy build over the one from nightly, system boots up normal with nightly. I have a „x96max+ rev b“ system info says.

Please continue here: