CoreELEC 19.3-Matrix Discussion

Thank portidch for your quick ansver, so you think it’s the same for S905X4 and S905Y4 ?

Yes, sell it and buy another device if you want to use CoreELEC.


Thanks and sorry that I only now saw your post and will try what you suggested when I find some more concentration. I currently do have an ATV ROM based on Android 6, correct.

In the meantime, is there a way to have HDR content play as SDR EOTF but in BT.2020 colorimetry (Rec.709 is currently forced for HDR>SDR conversion) and possibly have the EOTF manually adjusted according to the brgihtness of the TV? I have tried tinkering with am_vecm parameters in real time but with no success. I have a 4K SDR TV with rather high brightness (cca 600 nits) which can do BT.2020 and would love to have more color volume.
I see people talk about setting the HDR SDR parameters, even for display brightness, in CE’s GUI System Settings but I don’t seem have any of these. Is it because I only have a S905X.


I have searched high and low here and cannot find anyone reporting problems accessing via Samba. I have an old reliable and regularly used Zyxel NAS Drive NSA320. I used to access shares on this drive via Samba from my TX5 Plus box in CE 9.2.8 no problem. Since now upgrading on a new SD card to Matrix CE19.3 I just cannot access any Windows Samba shares. I have ensured all the settings and network names are the same as with CE 9.2.8 which still works fine. So what have I perhaps not done to not see my Windows Samba network devices in 19.3. Not worried about my PC access from the TX5 Plus box but just want to access my NAS Drive which is on fixed LAN address It’s Server name is NSA320 and I have even tried filling in my user name and password to access the NAS from CE 19.3 KODI but all to no avail. It works in 9.2,8 but for some reason not in19.3

Is there a bug and I’m thus wasting time and effort trying to fix this problem or have I just forgotten to do something essential to access Samba shares?? I have even tried enabling SMB1 on the box but no difference and on 9.2.8 the minimum level is SMB2 and that works fine. Maybe something has radically changed with Samba access in19.3 ??

Please can somebody help as I cannot set up my various movies, TV series and music libraries as I had with 9.2.x

You must use SMBv1, but it´s not secure

In 19.3 matrix RC3, no disable deinterlacing option, Is there a default value that cannot be changed?

Thanks for your reply. Yes I understand that and have tried it in CE 19.3 to no avail. But it works fine in CE 9.2.8 with SMB2 being the minimum level set. Are you saying that whereas it works in 9.2.8 it does not with Matrix 19.3 ?? There must surely be many others getting this problem too. It is very frustrating having spent many hours trying to fix it as you can imagine. I have Cron and Asanti enabled in CE too.

I am not worried too much about security as nothing particularly valuable and personal on my NAS and my LAN and NAS drive are quite well protected anyway. So SMB1 is not a problem but I clearly wont use it if not necessary of course.

Following is the information for SMB version supported for Zyxel NAS:
SMB v1: NSA series, NSA325 v2 and previous model
SMB v2: NAS series, NAS326, NAS520, NAS540 and NAS542.

Try to force SMBv1
Plan B: use NFS

I replaced my old NAS which only supported SMBv1.
Now I use SMBv3 running CE 19.3 - it works.

1 Like

As a follow up to my post above, and as per @kshi’s advice (thanks, man), I have, after considerable effort, installed Aidan’s V7.4 ROM (the only Android 7 ROM that could be flashed), after which the USB burning tool wouldn’t recognize the box anymore. Anyway, as I could also no longer boot CE 9.2.8, even with the toothpick method, I successfully installed CE 19.4 nightly booting it from Aiden’s ROM using Boot to Libreelec app.

I was delighted to see that HDR to SDR option is now available but probably a redundancy because CE does the conversion anyway (on or off after reboot doesn’t make a difference), the options seem to come from the above Android 7 ROM?

However, even though I now successfully managed to install Netflix addon and WidevineCDM, Netflix content still only plays in 960x540px, while in CE 9.2.8 it played in 1080. I have reset and reinstalled WidevineCDM numerous times to no effect. Has anyone come across this problem, can this be due to the Nightly Release? Is it a known issue?

I also couldn’t access the disk connected to my router until I set Minimum and Maximum version in Services/Samba section to SMBV1. (as a comment to @RayW issues).

1 Like

Read this for Netflix and learning how to use it in latest update. Skip the test build part because the feature in now part of the official addon.

Damn, that was quick and SUCCESSFUL!

All is well now and the 19 can fully replace the 9 for me.

Thank you!

1 Like

I have an Ubuntu server with samba shares providing media access to 3 media players. Samba access there works fine.
I did however run into an issue where my A95X (which I think is very similar to the TX5) would not transfer data over the onboard wifi after upgrading to 19.3CE. I think there is a driver issue in 19.3/19.4 CE that impacts devices using the QCA9377 driver.
If you are using wifi, try an ethernet cable as a test. If that resolves your issue, you can add an external USB wifi adapter that works and blacklist the QCA9377 as a work around. It’s not ideal, but it’s the best suggestion I can offer until the driver issue is looked into.

Hi, friend of mine has the same problem 1080p TV and no HDR but would play 1080p HDR or 4k HDR… So I bought him, cause he won’t spend much money, the x96 mini with 905W. Supported by Kodi 19.3 and with option HDR to SDR. Am@zon 28 Euro. And plays like charm. Booting a bit slow, although with a high speed transcend sd card, but that’s ok for that price.

Hi @all, i am stuck with a X96 Max+. I made a couple of boxes with CE but this box get me insane. I tried 19.3. and also the legacy build with all 2 dtb images. But the box won’t boot from sd card with toothpick method like all others I played around with 905x,w,p and 922 boxes. The only thing that comes is the Android panic screen in the screenshot below. What do I do wrong or am I missing something. Thanks in advance for the hint in the right direction.

you have to use USB latest models does not work boot from SDCard

1 Like

First thx for the answer. You mean i must burn CE on USB Stick?! Does X96max+ boot from USB if i understand you right.

Thank you so much. I had set the min level to SMB1 but not the maximum level. Once I forced SMB1 by setting Min and Max to level 1 bingo finally I could see my old NAS drive. Very strange why I did not have to force SMB1 with CE 9.2.8 but have to with CE 19.3 ???

Uhhh sure ? its very bad if its true… Do you speak about X96Max+ only or all android box ?

Seems it depend on what version you have. Mine now boots only with usb Stick in usb3 port and with the dtb for 4 gig but without 1gb network. After I tried all dtb for this box only the one in legacy build from CE worked and after that couriosly I took the 19.3 update and it worked, There are many different versions of this box out, so it seems.

you probably have an AI revision where there is support for the Nightly release if you want to use gigabit dtb.

1 Like