CoreELEC 19.3-Matrix Discussion

Please provide samples for the related files so we can check them and edit your post. Refer the type of file/codec but don’t use full release name file. That’s not accepted here.

Hi vpeter
I tried these from stable relase 19.3-Matrix:
gxl_p231_1g_m8s_dvb.dtb
gxl_p231_1g_dvb.dtb

If I try the night release 20211120 with
gxl_p231_1g_m8s_dvb.dtb
gxl_p231_1g_dvb.dtb
then I do not see any I2C device in /proc/device-tree/

And what works with 9.2.8?

Yes if I using this dtb gxl_p231_1g_m8s_dvb.dtb (40.6 KB)

Before I tried the dtb from AlexElec from: AE-AML/device-trees-amlogic-001_gxl_p231_1g_m8s_dvbt.patch at master · AlexELEC/AE-AML · GitHub
gxl_p231_1g_m8s_dvbt.dtb (41.1 KB)
because with this AlexElec working correctly.

@megaslx we’re here to help and not overcomplicate. Why can’t you just present your problem in a “cleaner” way?

Was/Is the version of android on your device 6.x? If so it sounds like a boot loader issue. I’ve had S905x boxes that would boot to CE 19.x but crash/reboot inexplicably.

The solution is to update to an Android 7.x or greater, either a general usage for S905x , ala Aidan’s Rom or ATVxperience or one of the other ROMS mentioned in the threads below:

https://discourse.coreelec.org/t/testers-wanted-gxl-1gb-ram-devices-amlogic-ng/15877/3

https://discourse.coreelec.org/t/coreelec-amlogic-ng-4-9-kernel-for-s905x-s905d-s905w-funhouse-builds/9432/230

https://discourse.coreelec.org/t/do-amlogic-ng-builds-work-well-on-gxl-s905x-s905d-s905w-devices/12179

https://discourse.coreelec.org/t/s905x-1gb-android-6-and-coreelec-ng-boot-failure/14767

In a nutshell, do your reading as it’s all been covered in the linked threads. Please make sure you have a working ROM for your box before you try installing anything. That way you have something to fall back to if something goes wrong.

Mecool M8S plus DVB-T - AVL6762 + M803
Only DVB-T tuner does not work in CoreEelec 19.3, other all works.
In CoreElec 9.2.8 working DVB-T2 correctly.

[    0.000000@0] CoreELEC dt-id: gxl_p231_1g_m8s_dvb
[   15.032923@1] DVB: aml_dvb_probe: probe amlogic dvb driver
[   15.032967@1] DVB: aml_dvb_probe: dmx rst ctl = ffffffc022d13e40
[   15.032975@1] DVB: aml_dvb_probe: asyncfifo rst ctl = ffffffc022d13f00
[   15.032982@1] DVB: aml_dvb_probe: ahbarb0 rst ctl = ffffffc022d13a00
[   15.032990@1] DVB: aml_dvb_probe: uparsertop rst ctl = ffffffc022d13880
[   15.033112@1] DVB: registering new adapter (amlogic-dvb)
[   15.033118@1] DVB: aml_dvb_probe: Registered adpter: amlogic-dvb
[   27.627465@1] amlogic-dvb dvb.50: DVB: registering adapter 0 frontend 0 (Availink avl6862)...

CoreELEC:~ # ls /dev/ |grep i2
i2c-0
i2c-2

CoreELEC:~ # ls /dev/dvb/adapter0/
demux0     demux2     dvr1       frontend0  net1
demux1     dvr0       dvr2       net0       net2

But the same configuration in CoreElec 19.3-Matrix does not working.

CoreELEC (official): 19.3-Matrix (Amlogic-ng.arm)
CoreELEC:~ # dmesg |grep dvb
[    0.000000@0] CoreELEC dt-id: gxl_p231_1g_m8s_dvb
[    6.993258@0] kernel-overlays-setup: processing conf /storage/.cache/kernel-overlays/50-driver.dvb.dvb-latest.conf
[    7.136192@3] kernel-overlays-setup: added modules from /storage/.kodi/addons/driver.dvb.dvb-latest//kernel-overlay/lib/modules/4.9.113
[   17.117416@2] dvb_meson dvb: Found i2c-1 adapter: Meson I2C adapter
[   17.117428@2] dvb_meson dvb: ts0: parallel
[   17.119337@2] dvb_meson dvb: ts0_control: 0x0
[   17.119490@2] dvb_meson dvb: dev_name=avl6762
[   18.342610@1] dvb_meson dvb: DVB demod detection for i2c-1 (Meson I2C adapter)...
[   19.557801@3] dvb_meson dvb: Checking for Availink AVL6762 DVB-T2/C demod ...
[   19.557984@3] i2c i2c-1: dvb_meson: i2c wr failed=-6 len=3
[   19.558119@3] i2c i2c-1: dvb_meson: i2c rd failed=-6 len=4
[   19.558266@3] i2c i2c-1: dvb_meson: i2c wr failed=-6 len=3
[   19.558418@3] i2c i2c-1: dvb_meson: i2c rd failed=-6 len=4
[   19.558426@3] i2c i2c-1: dvb_meson: attach failed reading id
[   19.558434@3] dvb_meson dvb: Failed to find AVL6762 demod!
[   19.558438@3] dvb_meson dvb: Total DVB modules found: 0
[   19.568413@3] dvbdev: DVB: registering new adapter (dvb_meson)
CoreELEC:~ #  ls /dev/ |grep i2
i2c-0
i2c-1
i2c-2
i2c-3
CoreELEC:~ #  ls /dev/dvb/adapter0/
demux0  demux1  demux2  dvr0    dvr1    dvr2    net0    net1    net2
CoreELEC:~ #

sorry,the imax hdr media playback problem happends on android kodi too,so it’s kodi’s problem.but I make a few mins smaple file out of the original one so you can reproduce it. the link:Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.

Can you try with this dtb? 53.1 KB file on MEGA

In case something happen be sure to know how to recover. But I think this should not be needed.

Thanks. With this tdb DVB-T working correctly.

But not working NAND or eMMC for reading or writing optionds for booting.
I thik that could be a tdb issue too.

CoreELEC:~ # fw_printenv
Cannot parse config file '/etc/fw_env.config': Invalid argument

CoreELEC:~ # cat /etc/fw_env.config
# Configuration file for fw_(printenv/setenv) utility.
# Up to two entries are valid, in this case the redundant
# environment sector is assumed present.
# Notice, that the "Number of sectors" is not required on NOR and SPI-dataflash.
# Futhermore, if the Flash sector size is ommitted, this value is assumed to
# be the same as the Environment size, which is valid for NOR and SPI-dataflash

# NOR example
# MTD device name       Device offset   Env. size       Flash sector size       Number of sectors
#/dev/mtd1              0x0000          0x4000          0x4000
#/dev/mtd2              0x0000          0x4000          0x4000

# MTD SPI-dataflash example
# MTD device name       Device offset   Env. size       Flash sector size       Number of sectors
#/dev/mtd5              0x4200          0x4200
#/dev/mtd6              0x4200          0x4200

# NAND example
#/dev/mtd0              0x4000          0x4000          0x20000                 2

# Block device example
#/dev/mmcblk0           0xc0000         0x20000

# VFAT example
#/boot/uboot.env        0x0000          0x4000

# Amlogic NAND
/dev/nand_env           0x000000        0x10000         0x10000

# Amlogic eMMC
/dev/env                0x000000        0x10000         0x10000

root@CoreELEC:~$ ls /dev/f*
/dev/fb0            /dev/firmware_vdec  /dev/full
/dev/fb1            /dev/fsck.log       /dev/fuse

/dev/fd:
0  1  2  3  8
root@CoreELEC:~$ ls /dev/na*
ls: /dev/na*: No such file or directory
1 Like

Good.

I’m not familiar with emmc/nand. Do you boot from SD card or emmc/nand?

I using booth mode.
For standard booting from internal flash, for testing using USB microSD.
In 9.2.8 fw_printenv working.

Can you reboot and post url from command

dmesg | paste

There is dmesg.
demesg.txt (77.6 KB)
http://ix.io/3FNG

I can only assume that environment partition (env) does not exists. And that’s why you can’t edit boot environment.

Same here.
N2 running CE 19.3 on SD card

fw_printenv
Cannot parse config file ‘/etc/fw_env.config’: Invalid argument
file /etc/fw_env.config
/etc/fw_env.config: ASCII text
/etc/fw_env.config exists but the command fw_printenv is not working

Hi @vpeter
Can confirm the file from mega:
457f5bf2b61dfc2ccce22bd9032c23cec402210179ad79ba1766a2a8d4934721 gxl_p231_1g_m8s_dvb.dtb

Works ok.

Cheers

m8

1 Like

There is dmesg from CE 9.2.8 http://ix.io/3FYU
Could be a issue with Nand PHY device driver or device tree.

[    3.145854@1] nandphy: Nand PHY Ver:1.01.001.0006 (c) 2013 Amlogic Inc.
[    3.152549@1] nandphy: ######STS IRQ mode for nand driver
[    3.157799@1] nandphy: NAND device id: 2c 64 44 32 a5 0 0 0
[    3.163266@1] nandphy: detect NAND device: A revision 3D L04A NAND 8GiB MT29F64G08CBCGBSX
[    3.171973@1] nandphy: param data[32~43]: 4d, 49, 43, 52,4f, 4e
[    3.177239@1] nandphy: nand Manufacturer: micron
[    3.177239@1]
[    3.234327@1] nandphy: micron_check_rand_mode()
[    3.234544@1] nandphy: clk_reg = 81000244
[    3.237196@1] nandphy: bus_c=6,bus_t=7,sys=4.0ns,T_REA=16,T_RHOH=15
[    3.243399@1] nandphy: new oob mode
[    3.248008@1] nandphy: NAND CKECK:arg nbbt:arg_valid=1,blk_addr=2,page_addr=0
[    3.256696@1] nandphy: nand blk 16 is shipped bad block
[    3.259185@1] nandphy: nand blk 32 is shipped bad block
[    3.264443@1] nandphy: nand blk 34 is shipped bad block
[    3.272358@1] nandphy: NAND CKECK:arg ncnf:arg_valid=1,blk_addr=5,page_addr=0
[    3.284702@1] nandphy: nand block at blk 16 is bad
[    3.292572@1] nandphy: nand block at blk 32 is bad
[    3.293117@1] nandphy: nand block at blk 34 is bad
[    3.307650@1] nandphy: NAND CKECK:arg phyp:arg_valid=1,blk_addr=6,page_addr=2
[    3.317273@1] nandphy: nand block at blk 16 is bad
[    3.325145@1] nandphy: nand block at blk 32 is bad
[    3.325690@1] nandphy: nand block at blk 34 is bad
[    3.343406@1] nandphy: NAND CKECK:arg nkey:arg_valid=1,blk_addr=4,page_addr=126
[    3.361354@1] nandphy: nand block at blk 16 is bad
[    3.369232@1] nandphy: nand block at blk 32 is bad
[    3.369777@1] nandphy: nand block at blk 34 is bad
[    3.398116@1] nandphy: NAND CKECK:arg ndtb:arg_valid=1,blk_addr=8,page_addr=486
[    3.416372@1] nandphy: nand block at blk 16 is bad
[    3.424260@1] nandphy: nand block at blk 32 is bad
[    3.424806@1] nandphy: nand block at blk 34 is bad
[    3.456878@1] nandphy: NAND CKECK:arg nenv:arg_valid=1,blk_addr=9,page_addr=204
[    3.461146@1] nandphy: nand blk 16 is shipped bad block
[    3.463806@1] nandphy: nand blk 32 is shipped bad block
[    3.469073@1] nandphy: nand blk 34 is shipped bad block
[    3.474345@1] nandphy: nfboot    :
[    3.477781@1] nandphy: off:0x000000000000-0x000001000000 :partn=0:single_chip single_plane
[    3.485971@1] nandphy: nfcache   :
[    3.489418@1] nandphy: off:0x00001a800000-0x000026000000 :partn=1:single_chip single_plane
[    3.497615@1] nandphy: nfcode    :
[    3.501062@1] nandphy: off:0x000040800000-0x00009b800000 :partn=8:single_chip single_plane
[    3.509258@1] nandphy: nfdata    :
[    3.512705@1] nandphy: off:0x0000dc000000-0x000124000000 :partn=1:single_chip single_plane

Hi, new here but I have been using LibreElec for a while. I have a Zen 11 Pro (very similar to TX5 Pro) and I have just installed CoreELEC 19.3 on a new SD as interested in the new kernel 4.9 and nfs4.
Everything seems to work just fine except for the wi-fi, where I can’t see any 5Ghz networks.
Reading previous posts about qca9377 I have attached the following files (I couldn’t post last one, to follow):

http://ix.io/3G0u - dmesg
http://ix.io/3G0v - udevadm

Thank you in advance.

http://ix.io/3G0w - journalctl