CoreELEC 19.4-Matrix Discussion

Hello, i have an X96 max plus and after updating from 19.3 (usb) i get the following in the splash screen.

Cannot initialize conversion from codepage 850 to ANSI_X3.4-1968: Invalid argument
Cannot initialize conversion from ANSI_X3.4-1968 to codepage 850: Invalid argument
Using internal CP850 conversion table.

Is there a way to fix it, thanks in advance.

And this text stays on screen or the device boots fine?

1 Like

At first no but after a few reboots (disconnecting and connecting) it started to work fine it just display the message for a second before the splash screen, i think is working fine now, thanks.

I had the same short message on a Ugoos Am6 device, its a very short message so i have to take a
handy video to indentify it.
Then I test a fresh install on a SD Card, with the same result
So I make a complete new Installation from the Box (new Android Image with USB burning tool)
After that the message is gone

It also happened with a fresh install (with Libreelec usb burning tool) but Coreelec is working the same as usual. I did upgrade from a backup on the emmc just to check and there is no message, mounting error maybe.
With a fresh install it did not gave any problems except for the message.

24 posts were split to a new topic: High CPU usage by banned Addons

Tried to update X96 S905x3 from 19.3 to 19.4. Unfortunately there is stuttering on some 4K videos. No errors, and hardware decoded. The same 4K video plays very smooth on 19.3.

Try latest nightly. If the same then upload file sample and log.

Please remind:

A post was merged into an existing topic: Ce19.4 's emby-next-gen and embycon can’t play

A95Max S905X2 Problem ausschalten shutdown geht nicht.
Android 8.1 neu geflascht und SD Karte mit Corelec 19.4 neu installiert.
Box beim runterfahrem permanent reboot.
bei Coreelec 19.3 ist alles okay.
ist es möglich g12a_s905x2_4g_1gbit.dtb 19.4 gegen eine ältere Version <19.4 replace zu tauschen

Hi there,
A95Max S905X2 problem switch off shutdown does not work.
Reflashed Android 8.1 and reinstalled SD card with Corelec 19.4.
Box permanently reboot when shutting down.
with Coreelec 19.3 everything is ok.
is it possible to replace g12a_s905x2_4g_1gbit.dtb 19.4 with an older version <19.4 replace

1 Like

We have German speakers in the team but this is an English only forum. Please translate.

1 Like

HI, das tauschen einer dtb aus der 19.3. “sollte” zum testen kein problem sein. ich musst auch bei meinem S905X2 eine andere dtb nehmen, da ich eine Fake Box hatte und mit der, die du hier genannt hast, meine Box nicht bootete. probier es einfach aus. Kannst ja nichts kaputt machen. Sicher Dir einfach die aktuelle auf den Rechner weg und nimm die funktionierende aus der 19.3.

HI, swapping a dtb from 19.3. "should not be a problem for testing. I also have to use another dtb with my S905X2 because I had a fake box and the one you mentioned here didn’t boot my box. just try it. You can’t break anything. Just save the current one on your computer and take the working one from 19.3.

I must say I love Kodinerds but we’re not in Kodinerds forum!

I know, i know. No log, no problem.
But i got problems with hdmi-cec since 19.4 rc versions, i start a movie and totally random breaks the hdmi-cec down, no warning only the remote works not anymore. I had the same issue with a previous version, there has the hdmi-cec driver change helped. I try to do a log, later.

Beelink gt-king pro, LG tv, logitech harmony touch remote

1 Like

Then post when you got a log…
You need to enable libCEC component logging in Kodi and share this kodi.log

There was a CEC fix today so all with 19.4 and CEC issues try first nightly 20220315 or above before report an issue.

ok i needed a lot of time to bring the issue back, i got a log but its over 50 mega and the system cant upload it (failed to paste log files, try again). i uploaded this here: 50.9 MB file on MEGA

on the last 10-20 min could something happen before that worked.

ok i will try the csc fix after a reload. thx

where can i download this version? and how to install? I see only 3.10 date images.

Tomorrow, March the 15th.

1 Like