CoreELEC 19.4-Matrix_rc3 Discussion

Please use this thread for general 19.4-Matrix_rc3 discussion


NEO U22-XJ MAX can’t boot, not even a clean reinstall.
The last version this device can work is nightly build 20211222.

Maybe you used the wrong DTB? I using the max right now and watch Olympics!?

1 Like

DTB can’t be wrong. I flashed rc2 rc3 and all the nightly builds back to 20211222, and the 20211222 build worked. I even tryed U22-XJ DTB, the box can boot but no audio signal.

I tryed manully update 20211222 to rc3 (via OTA), after reboot it just stuck in the black screen forever.

Did you replace manually AGAIN the dtb.img by the minix_u22j_max one? There are multiple max versions online with rc3 so when even no clean install is working you have some error. On beginning the wrong DTB was used in nightly.

I also tryed using 20211222 DTB after flashing RC2, still can’t work

Do clean install and use the correct DTB provided by the clean install. If it still doesn’t work try something different and or provide logs, thank you.

I flashed RC3 again and checked the DTB again and again, still black screen

Try another boot media and or provide logs

I can’t provide logs since the box just stuck in the black screen and can’t boot

Do you use sd card or USB stick?
If sd card then could you try USB stick just to check if it starts from usb or vise versa?

I use sd card
Retryed with USB stick, still no luck

What vendor android version do you have on box?
Because we don’t have an issue.
Or you use wrong dtb. Try not Max dtb for test or Max if you use not Max

Or on working build please execute
cat /proc/cpuinfo | grep Serial
And give us an output.
May be you have rev. a box that shouldn’t be for Max.


Updated 2 X96 Max+ in SD card to CoreELEC 19.4-Matrix_rc3.
Updated 1 X96 Max+ in internal eMMC to CoreELEC 19.4-Matrix_rc3.

I bought all them more than 1 year ago.

No issues at all. SD upgrade OK (from 19.3); eMMC upgrade OK (from 19.3).

Kind regards

1 Like

Recently I updated my A95X Max box from 19.3 to 19.4.rc3 stable image, and have a
problem to switch off.Coreelec 19.4 rc3 Test shutdown the unit, it immediately reboots
Whenever I want to shutdown the unit, it immediately reboots.
A95max 4GB64

I’ve updated my 1/8G S905X Trongle X4 from 19.4 rc2 to rc3, no change with the PS2/PS3 controller problem I reported on the rc2 thread (logs there).

KI Pro everything works fine on pendrive. does not work on sd card the latest android version for the same should not be compatible with the new kernel. I would like to know if it can be fixed? or should i stop in coreelec 19.2 version? thanks.