CoreELEC 19.5-Matrix_rc3 Discussion

I’ve problems with library too.
One problem is the same of simrose.
The other problem is that after library update I can’t see the original name of the file even if I have checked the options in library settings.

It occurs with original skin and with confluence.
I’ve not tried others skin.

I’ve installed it on a X96 max + 2101 on emmc with dual boot.

I do have working Ethernet on the 20-rc1 but its around 100mbit/s only eventhough the link shows 1Gbit.
Some material is stuttering like this. Will try to find the cause for this but i assume its related to what you found here.

Do you have long cable?
I have another device working fine with a 3m cable directly connected to a router. But the same device do not have a eth0 connection with same setup but on different LAN structure. I will try to test this a bit.

I did test with N2+, no difference in speed with or without the DTS changes. Both times I reached ~1GBit with iperf3 test

Sorry but I’ve done an error.
I’ve seen the right menu choice in other menu section, cleared library and now all works.


Same HW and same issue here: IP connectivity is lost after wakeup from suspend and reboot is needed.

1 Like

To the CE-19 rc3 or CE-20 rc1 user have issues with LAN ethernet. Please pick your DTB from the attached zip file and place it renamed as dtb.img on COREELEC partition. To restore the original dtb.img just run the update again with last release you have installed.

Please report back if this solve the issue or not. (1.5 MB)

I am afraid not. This behaviour is random. Sometimes it’s connecting after waking up, sometimes not. Rebooting resolves the problem, reverting back to RC2 resolves the problem.

Then you will need to make dmesg logs. Best with rc3, one log where it works and one log where it does not.

Sure, and noob question… is there a way to open console while Kodi is running. I am unable to ssh my device while there are connectivity issues, I can only acess the device locally with a keyboard.

UART or Wifi?

Right! Will try wifi.

working.log (117.1 KB)
notworking.log (157.7 KB)
dmesg logs attached

nothing to see in the logs, all times it report meson6-dwmac ff3f0000.ethernet eth0: Link is Up - 1Gbps/Full - flow control off. did you try the dtb from here. if no change we need to search ~250 commits what are between rc2 and rc3

will make new fresh install with new dtb provided, gimme few minutes.
btw, sorry for being so pesky… rc2 hadn’t caused any troubles before rc3 relase so Ican use rc2 without any problems
and I know it’s loads of work for you

Best for CE it will be to identify the reason to solve it properly. But we can not replicate this issue by our self so will need help by users testing images.

Maybe you can try first the nightlies to identify last working one?

rc2 was on 20220727
rc3 was on 20221204

There are not all nightlies archived but maybe you can identify already some working/non working versions. This will shorten our search for the reason a lot.
Just setup a fresh media with the nightly CoreELEC archived nightly builds, then set auto update in CE settings to manual. And then update manual by the archive until it is broken.

Yes Sir! :slight_smile:

1 Like

Problem resolved!
Fresh install of RC3 with provided new dtb.img file works fine with no issues.
First time I tried new dtb, I inserted it into update image so I think it has been my fault.
Many thanks for your commitment, this project is awesome.

with the dtb from the extra zip file I provided it works?
and with the fresh virgin rc2 install with included dtb not?