CoreELEC 19 Matrix Discussion (Kodi RC)

Installing widevine via inputstreamhelper should not reboot your box. All the script does is download the ChromeOS image, extract and copy the file to the .kodi/cdm folder. If the box reboots on wifi, there are other issues to be addressed that are unrelated to the widevine installation.

Wild speculation, but I’m wondering if it’s related to issues that seem to occur on certain S905x boxes (in varying degrees of severity) when they’re running NG builds with a bootloader from an Android version that’s less than 7.x? Another instance of system lockups/rebooting when doing disk write intensive tasks on an S905x that is using Android 6.x bootloader?

Out of curiosity, @gujal, was the last Android Firmware on your device Android 6?

1 Like

Yes, Wechip v5 runs Android 6. There is no official higher version available

And you may be right as I didnt have this problem earlier when it was running non-ng kernel

Yea, I kinda suspect that might be the problem, I had a similar issue with my X96 and the NG builds.

Do you have an original copy of your device’s firmware and are you familiar with using the AML USB Burning Tool? I have an Android 7.1.2 firmware that seems to happily install to just about any S905x device I’ve come across. I believe @Betatester also has a different one he and others have had similar success with. PM me if you’re interested (and have a working rom for your device to go back to in the event something goes wrong) and I can give you a link to mine.

1 Like

That’s interesting as my Tanix TX5 Pro(s905x, android6) reboots quite often.
The latest image seems to be on Android 9 ATV - not sure it would help, but worth a try.

cdu13a explained it well in this thread:

Check your CPU temperature.

@kshi Your suspicion is confirmed. Example: my NexBox A95X-B7N (S90X) I use for testing, had the oddest symptoms running Android 6.x till I upgraded to Android 7.x. I have suggested several times in the forum to upgrade to Android 7.x before using CE-NG or Matrix. On S905X SoC it’s also important to keep an eye on thermal cooling.

1 Like

No issues with your USB ports?

@Betatester, Agreed. Along with making sure I have the CPU performance set to on-demand, I’ve since installed a larger heatsink to the CPU and made modifications to the case. For giggles, I might try 3d printing a better enclosure as the X96 was clearly designed to be compact over thermally efficient.

1 Like

Yes, I updated the device with the firmware provided by @kshi and the problem has gone, Thanks!.
It is now correctly downloading and installing widevine without any issues on CE19
So to summarise on the same hardware
Amlogic kernel 3.x has no issues with Android6 booloader
Mainline kernel 5.x as used by LE Matrix has no issues with Android6 bootloader
But NG kernel 4.9 as used by CE19 works properly only with Android7 bootloader

1 Like

Temp is OK.
So trying to update with an Android 7.1.2 universal image(X96 forum on 4PDA).

I have a box x96, revision “Q5X V2.1 16483” (s905x, 1Gb, 100Mb, wifi-rtl8189etv), tried to flash a lot of firmware, only “HUG-TX7-nikodi - 20180104” came up, all builds work. In Flashed Linux using Khadas util.
P.S. When parsing the epg, Kodi periodically hung up. The reason is a lack of memory, installed zram, the problem disappeared.

Not that I know of

1 Like

I’m getting a very odd coming out of suspend / idle issue in the last few builds, where I turn on the TV in the morning and the screensaver is showing but when I use the remote I hear the sound that its registered but the screensaver stays on. Only option then is to pull out the Odroid remote and use it to power off the box and reboot,

I have been in the logs and nothing seems to show up but there is a huge time gap in them where they stop logging around 21:38 last night and don’t start logging again until the reboot shows at 08:04 this morning.

Edit: Forgot to say that I have tried various screensavers and they all have the same issue.

Yes, that’s an Android 7 backport fitting most of all S905X boxes - X96, Tanixes etc.

Hi Folks,

i am facing some issue with ‘too many open files’ errors on the latest nightly. i am in process of migrating all my boxes to matrix, after very good results on three initially (2x s905x and 1x s905x3). i just upgraded another s905x and s905x3 box, and on both of them i cannot restore a backup i took last week with kodi backup addon (i was able to restore this same backup shortly after i took it last week to a s905x and s905x3, an also the RC1 android build installed on my Sony Android TV, although on the TV i had to reinstall a couple of addons post restore) On the new nightly, the restore starts, copies a few files then errors and in the log i see huge amount of below errors when accessing the shares where the backup files are located

unix_err:‘18’ error : ‘Too many open files’

i was able to restore the back up manually by stopping Kodi and replacing relevant directories over smb on the two boxes, this worked well, however, i have just tried to make a fresh start on my music library, but it only scans my first few artist folders, then fails after that with same unix error about too many open files. same behavior exists on both the s905x and s905x3 boxes…

has anyone else had similar issues?


fyi if you are interested in ATV version of firmware, i have had great results with the atvXeprience v4 rom (Pie), it fixed the issues i had with v6 roms and matirx. i put it on all my s905x boxes (7 if them!) and on every one it took a few attempts with burn tool to get it on, erroring after the ‘formatting’ step, on one box it took 4 tries but the others worked on second or third attempt. Once on it works well and is quite snappy for droid, and comes with teminal so you can just do ‘reboot update’ to get in to CE for the first time.

Hi all
I run official ng CE (9.2.5) Leia (on GT-King and on Kvim3L) from eMMC.
Which will, eventually, be a valid upgrade method to end up running Matrix from eMMC ?
a) putting Matrix tar and dtb in ~/.update ?
b) leaving Leia in eMMC, booting Matrix from SD and using ceemmc ?
c) installing Android in eMMC, booting Matrix from SD and using ceemmc ?

Is there an archive of older CoreELEC 19 nightly versions?

The last couple of nightly wont download any artwork from themoviedb, I just keep getting this in the Kodi log:-

2021-02-04 17:02:11.348 T:7358 ERROR <general>: CCurlFile::Stat - Failed: Couldn't connect to server(7) for

Even through the link opens perfectly fine in a browser. I’d like to roll back and see if an earlier version fixes it but I can’t find any older nightly versions.