CoreELEC 19 Matrix Discussion (Kodi RC)

Odroid user here. No issues installing any IA add-ons.
I do however experience the occasional kodi restart after a IA stream ends

Hi folks,

i am having some issue with CEC, from my testing i dont think it is a CE issue but wondering if there was any option in CE to workaround it. CEC works on all 6 of my boxes around the house, however, two TV’s specifially, when i turn off the TV it puts my s905x box to sleep. this stops my EPG staying up to date with nextPVR (local docker install) and also if i have a video playing when i turn the TV off, when i turn it back on playback resumes for a few seconds then the box hangs and i have to pull the power to get it back. this behavior is specific to just these two TV,s no matter which box i connect to them. this is new behaviour since going to matrix, however, i also updated the android roms to ATV Pie roms after going to Matrix as i was getting lockups in CE with the 6.0 roms in place when using ITPV, or copying files to the boxes over smb (the pie roms seem to have fixed this) not sure if the new roms are the issue?

is there something i can set in CE that tells the box not to go to sleep when i power off the TV?

note i checked CEC settings in the TVs and there are no config options available, just CEC on or off.


Please check in settings->system->input. You have there the config of libCEC, one of them is what to do when tv is turned off. Just choose ignore.

thanks! i will try that out…

I run LE and CE on the same box (2 different microSD cards :slight_smile:)
so copied libwidevine from LE to CE microSD as it is the same box
Once the file is copied, Netflix and Disney+ addons work perfectly in CE

And Yes on LE, no CEC
hardware acceleration uses prime in LE and is hit and miss, sometimes h264 play but not consistent. most times just audio plays/ Also when it does play correctly, fw or rev video causes it to hardlock. Have to ssh and restart kodi

On CE it uses the am-h264 and is fantastic, even 10bit hevc encodes playback fine with hw acceleration. perfection :grinning:

I only use Wifi, may be some time out in wifi causes the Inputstream helper ChromeOS download to timeout or something, but still dont understand why it restarts the device completely. On LE it works fine

Installing widevine via inputstreamhelper should not reboot your box. All the script does is download the ChromeOS image, extract and copy the file to the .kodi/cdm folder. If the box reboots on wifi, there are other issues to be addressed that are unrelated to the widevine installation.

Wild speculation, but I’m wondering if it’s related to issues that seem to occur on certain S905x boxes (in varying degrees of severity) when they’re running NG builds with a bootloader from an Android version that’s less than 7.x? Another instance of system lockups/rebooting when doing disk write intensive tasks on an S905x that is using Android 6.x bootloader?

Out of curiosity, @gujal, was the last Android Firmware on your device Android 6?

1 Like

Yes, Wechip v5 runs Android 6. There is no official higher version available

And you may be right as I didnt have this problem earlier when it was running non-ng kernel

Yea, I kinda suspect that might be the problem, I had a similar issue with my X96 and the NG builds.

Do you have an original copy of your device’s firmware and are you familiar with using the AML USB Burning Tool? I have an Android 7.1.2 firmware that seems to happily install to just about any S905x device I’ve come across. I believe @Betatester also has a different one he and others have had similar success with. PM me if you’re interested (and have a working rom for your device to go back to in the event something goes wrong) and I can give you a link to mine.

1 Like

That’s interesting as my Tanix TX5 Pro(s905x, android6) reboots quite often.
The latest image seems to be on Android 9 ATV - not sure it would help, but worth a try.

cdu13a explained it well in this thread:

Check your CPU temperature.

@kshi Your suspicion is confirmed. Example: my NexBox A95X-B7N (S90X) I use for testing, had the oddest symptoms running Android 6.x till I upgraded to Android 7.x. I have suggested several times in the forum to upgrade to Android 7.x before using CE-NG or Matrix. On S905X SoC it’s also important to keep an eye on thermal cooling.

1 Like

No issues with your USB ports?

@Betatester, Agreed. Along with making sure I have the CPU performance set to on-demand, I’ve since installed a larger heatsink to the CPU and made modifications to the case. For giggles, I might try 3d printing a better enclosure as the X96 was clearly designed to be compact over thermally efficient.

1 Like

Yes, I updated the device with the firmware provided by @kshi and the problem has gone, Thanks!.
It is now correctly downloading and installing widevine without any issues on CE19
So to summarise on the same hardware
Amlogic kernel 3.x has no issues with Android6 booloader
Mainline kernel 5.x as used by LE Matrix has no issues with Android6 bootloader
But NG kernel 4.9 as used by CE19 works properly only with Android7 bootloader

1 Like

Temp is OK.
So trying to update with an Android 7.1.2 universal image(X96 forum on 4PDA).

I have a box x96, revision “Q5X V2.1 16483” (s905x, 1Gb, 100Mb, wifi-rtl8189etv), tried to flash a lot of firmware, only “HUG-TX7-nikodi - 20180104” came up, all builds work. In Flashed Linux using Khadas util.
P.S. When parsing the epg, Kodi periodically hung up. The reason is a lack of memory, installed zram, the problem disappeared.

Not that I know of

1 Like

I’m getting a very odd coming out of suspend / idle issue in the last few builds, where I turn on the TV in the morning and the screensaver is showing but when I use the remote I hear the sound that its registered but the screensaver stays on. Only option then is to pull out the Odroid remote and use it to power off the box and reboot,

I have been in the logs and nothing seems to show up but there is a huge time gap in them where they stop logging around 21:38 last night and don’t start logging again until the reboot shows at 08:04 this morning.

Edit: Forgot to say that I have tried various screensavers and they all have the same issue.