CoreELEC 19 Matrix Discussion (Kodi RC)

Have this a try the last few days. Can’t say I’ve had any issues, feels a bit snappier than 9.2.5 and hard to say, but I think HDR picture is slightly brighter in Kodi 19 compared to 18.9. I have a ramped up setting for day time HDR viewing and found it wasn’t required as much as in 18.9. Maybe I’m crazy though…

how to compile the xbmc-19.0RC1-Matrix? could U give some info.



Will CoreELEC-19-Matrix will support my Odroid C2 ?

In the latest news, I’m reading that “GXB support got dropped by Amlogic in newer Kernel.”.

It’s kind of confusing for me, because I read somewhere that Odroid c2 = GXBB = S905; but CoreElec will support GXL (s905X/L ?) and it seems to be almost the same SoC. Also, most of them seems natively supported by linux for quite a while now. I’m scratching my head arround this but I just don’t get it.

I just want to know if my Odroid C2 will be supported for some time or I should buy another card.

Thank you,
sorry for my bad english

Hi Guys,

This works perfectly on my S905x3 X96Air box, except for one issue; I cannot get AML-VNC addon to connect.

My VNC Viewer is asking for username and password. I’ve tried kodi and coreeelc, but nothing works.

Is VNC broken on this build?


Right now there will be no support for GXBB. You are still able to use CoreELEC 9.2.5 what is working without any issues. GXBB support got dropped by Amlogic and devices like C2 aren’t in active production anymore.

For future when you want to use Kodi Matrix it’s recommended to use hardware like G12A/G12B or SM1. SC2 will be the next SoC (S905X4) but there does nothing exist right now.

Maybe it’s root and coreelec? Not sure…

1 Like

Thanks. Alas, I’ve tried that with no success :frowning:

Seems VNC addon is broken atm. Will fix it later today.

i have the problem when i reboot my htpc (odroid n2, CE 19 nightly) it sometimes (or always, have to test that) leads to the situation that my marantz sr 7011 does not recognize the htpc rebooted. that was working like a charm in 18. i will test today how reliable i can reproduce that.
anyone else facing CEC problems in 19?

I had the same with my onkyo tx-nr555 and my lg cx connected to my N2 using the latest matrix build.

After couple of times plug out the psu i recognized my N2.

It seems cec getting worsed with very update.

There are almost daily some changes about CEC. Like right now I triggered another issue what should be fixed in next nightly…

1 Like

Tnx one question, do i need to set a physical hdmi port in cec settings for best functionality?

Thank you :wink:

This does depend on your hardware setup if libCEC is able to read the correct id when getting started.
This maybe fails if you use a AVR between TV and CE device.

1 Like

You could use any of described methods.
In method a) you don’t need to put dtb file in update folder, only .tar update file.
Preferred method is clean install.

If, with clean install, is meant: “empty ~/.kodi” or even “empty /storage”, sure, that is the idea for all 3 methods.
But, if, indeed, simply putting release Matrix tar file in ~/.update will upgrade from latest Leia on internal eMMC, then such seems perhaps not so (yet) for RC1, … why else does
CoreELEC 19 Matrix (Development Release)
explicitely mention
Please do not upgrade on internal eMMC!
Basically that was what triggered my question:
how shall upgrade from Leia to Matrix eventually be achieved once Matrix is released?
And, along same line: is there an RCn n>1 planned for which we can already upgrade on internal eMMC?

1 Like

We always recommend caution when using this kind of releases because uSD/USB installs are more easily recovered. That said, i run matrix in emmc. There’s only one thing I would mention, are you using ceemmc? Or do you have an old 3.14 kernel installtointernall? If this is the case, you should use Android to recover and then make a fresh install with Matrix, after which you can use ceemmc to run dual boot (or only CE) from emmc.

1 Like

@Vascobraga : thanks for information
I used ceemmc to install Leia to eMMC on both GT-King and Kvim3L (both ran vendor Android). And I can now run Matrix RC from external SD on them just fine.
Am I correct to conclude you ran Leia from eMMC and upgraded by putting Matrix in ~/.update ? Or did you use ceemmc to overwrite Leia by Matrix in eMMC? Or didn’t you even have Leia in eMMC when you installed Matrix to eMMC?

I used tar update. There are lots of add-ons that will update and who knows what can go wrong but you can try it.

Thanks for answer. I am not in a hurry to update CE in eMMC and I will sure start from clean storage. Most addons I use are Matrix ready (except spotify but now I use librespot) because I already run Kodi Matrix RC on an own built x86_64 gentoo HTPC box where everything is built from source. All I wanted to know is: once CoreELEC Matrix is released, if one will be able to install it on Amlogic boxes such as mine by tar (without need to first reinstall Android and use ceemmc). Your testimonial answered that question and it makes me feel very comfortable looking forward. Have a nice day.

Hi all,

Yes, I’m getting the same 'too many open files" with a fresh install of nightly_20210210 on Beelink GT-King. It’s happening when scanning new library for music and TV shows from SMB shares on a server. Only some of the content is getting scanned in. If I then try to manually browse the files I get the same error. Only a reboot lets me browse files manually again, and scans to library fail again.