CoreELEC 19 Matrix Discussion (Kodi RC)

Yes, that’s an Android 7 backport fitting most of all S905X boxes - X96, Tanixes etc.

Hi Folks,

i am facing some issue with ‘too many open files’ errors on the latest nightly. i am in process of migrating all my boxes to matrix, after very good results on three initially (2x s905x and 1x s905x3). i just upgraded another s905x and s905x3 box, and on both of them i cannot restore a backup i took last week with kodi backup addon (i was able to restore this same backup shortly after i took it last week to a s905x and s905x3, an also the RC1 android build installed on my Sony Android TV, although on the TV i had to reinstall a couple of addons post restore) On the new nightly, the restore starts, copies a few files then errors and in the log i see huge amount of below errors when accessing the shares where the backup files are located

unix_err:‘18’ error : ‘Too many open files’

i was able to restore the back up manually by stopping Kodi and replacing relevant directories over smb on the two boxes, this worked well, however, i have just tried to make a fresh start on my music library, but it only scans my first few artist folders, then fails after that with same unix error about too many open files. same behavior exists on both the s905x and s905x3 boxes…

has anyone else had similar issues?


fyi if you are interested in ATV version of firmware, i have had great results with the atvXeprience v4 rom (Pie), it fixed the issues i had with v6 roms and matirx. i put it on all my s905x boxes (7 if them!) and on every one it took a few attempts with burn tool to get it on, erroring after the ‘formatting’ step, on one box it took 4 tries but the others worked on second or third attempt. Once on it works well and is quite snappy for droid, and comes with teminal so you can just do ‘reboot update’ to get in to CE for the first time.

Hi all
I run official ng CE (9.2.5) Leia (on GT-King and on Kvim3L) from eMMC.
Which will, eventually, be a valid upgrade method to end up running Matrix from eMMC ?
a) putting Matrix tar and dtb in ~/.update ?
b) leaving Leia in eMMC, booting Matrix from SD and using ceemmc ?
c) installing Android in eMMC, booting Matrix from SD and using ceemmc ?

Is there an archive of older CoreELEC 19 nightly versions?

The last couple of nightly wont download any artwork from themoviedb, I just keep getting this in the Kodi log:-

2021-02-04 17:02:11.348 T:7358 ERROR <general>: CCurlFile::Stat - Failed: Couldn't connect to server(7) for

Even through the link opens perfectly fine in a browser. I’d like to roll back and see if an earlier version fixes it but I can’t find any older nightly versions.

You should have some more info in kodi.log for the reason.
The best would be to enable debug log and restart kodi or reboot.

Well, it’s always the case, as soon as I post with a problem I end up fixing it 2 minutes later :smiley:

I simply re-updated with the last nightly and it’s now working… go figure :man_facepalming:

1 Like

Video doesn’t pass through the gpu shaders in CoreELEC, so the implementation of this in Kodi cannot be used directly, but would need to be ported to the internal constants in the Amlogic hardware which handles the mapping. It’s possible in principle, but see my comment at

update, actualy none of them (netflix, amazon vod, hbo, youtube) work anymore, might be for a while as i have not been using it lately. just opens addons with empty screen, nottingh else happens. have to analyze depper and provide logs over weekend.

can you guys check if your video addons still work?

When opening an old xvid avi file noticed that it does not use the am-mpeg4 hardware decoder but goes to software decoding resulting in a stuttering video playback. Do you need a log to source this?
On Odroid N2 and C4.

You could use any of described methods.
In method a) you don’t need to put dtb file in update folder, only .tar update file.
Preferred method is clean install.

1 Like

I run CE 9.2.5 (Leia) on a Mecool KII pro from internal eMMC.
I would like to test CE Matrix RC1 from uSD card but It seems not to boot as it doesn’t get past the Mecool logo with no video signal.
I copied gxl_p231_2g_dvb.dtb as dtb.img in the root of COREELEC partitition so I don’t get as to why it doesn’t boot. Any suggestions? thanks

Try /flash

Also you need to run Amlogic-ng 9.2.5!

Do you mean that I have to upgrade to amlogic-ng in the emmc to be able to boot Matrix from the uSD?

skin problem, video addons working ok.

I’ve flashed the recomended HUG-TX7-nikodi - 20180104 image(Android 7) and tested the latest build on my Tanix TX5Pro - so far so good, no rebooting while playing UDP streams.
But noticed much darker picture compared to none NG builds. I have to abjust brightness level up to 60.

1 Like

Thanks for the suggestion.
I avoid ChromeOS and ATV because Google forcing you to enter a google account on startup.
Happy not to use google services on these devices, google need not track my viewing and gaming habits :wink:

There is no such effect on my x96 box.
P.S. On any CoreELEC builds, ng or non-ng, stable or test, Matrix.

Anyone have problem to install Stalker Client on CoreELEC 19 RC1? Installation stop on 64% and i get some error message.